aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-all/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-07-28 11:45:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-07-28 11:45:08 +0000
commitd1107bb40e81d1186ea75412dd5d61d736e4d726 (patch)
tree103926d89737f146b97db5255f054196dadab9fc /devel/boost-all/Makefile
parentd89dccb61e24d9db4b71225fafab4061ae50cf51 (diff)
downloadports-d1107bb40e81d1186ea75412dd5d61d736e4d726.tar.gz
ports-d1107bb40e81d1186ea75412dd5d61d736e4d726.zip
Notes
Diffstat (limited to 'devel/boost-all/Makefile')
-rw-r--r--devel/boost-all/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/devel/boost-all/Makefile b/devel/boost-all/Makefile
new file mode 100644
index 000000000000..2768d904cb2d
--- /dev/null
+++ b/devel/boost-all/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: boost-all
+# Date created: March 21 2009
+# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= boost-all
+
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+COMMENT?= The "meta-port" for boost libraries
+
+OPTIONS= JAM "Boost.Jam - boost.org build utility" on \
+ LIBRARIES "C++ source and shared libraries" on \
+ PYTHON "Boost.Python - interfacing Python and C++" off \
+ DOCS "Documentation & examples" on
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+.include "common.mk"
+
+.if !defined(WITHOUT_LIBRARIES)
+RUN_DEPENDS+= ${PREFIX}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
+.endif
+
+.if !defined(WITHOUT_JAM)
+RUN_DEPENDS+= ${PREFIX}/bin/bjam:${PORTSDIR}/devel/boost-jam
+.endif
+
+.if !defined(WITHOUT_PYTHON)
+RUN_DEPENDS+= ${PREFIX}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+.endif
+
+.if !defined(WITHOUT_DOCS)
+RUN_DEPENDS+= ${PREFIX}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
+.endif
+
+do-install:
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>