aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-all
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:33:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:33:04 +0000
commit3f6692467b46056d3a9c7fe9bc78c439f0274b0b (patch)
tree7134ace5e6a89215f59520c4db5ef4ec5cdd4162 /devel/boost-all
parentf5646e4a1ca307e327df3a308bd22d48f9673cc4 (diff)
Notes
Diffstat (limited to 'devel/boost-all')
-rw-r--r--devel/boost-all/Makefile23
-rw-r--r--devel/boost-all/common.mk6
-rw-r--r--devel/boost-all/compiled.mk73
3 files changed, 55 insertions, 47 deletions
diff --git a/devel/boost-all/Makefile b/devel/boost-all/Makefile
index 9dfc2c3c39a7..2a67f82ab0ce 100644
--- a/devel/boost-all/Makefile
+++ b/devel/boost-all/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: boost-all
-# Date created: March 21 2009
-# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
-#
+# Created by: Alexander Churanov <churanov.port.maintainer@gmail.com>
# $FreeBSD$
-#
PORTNAME= boost-all
@@ -13,29 +9,30 @@ EXTRACT_ONLY= # empty
COMMENT?= The "meta-port" for boost libraries
-OPTIONS= JAM "Boost.Jam - Build tool from the boost.org" on \
- LIBRARIES "Free portable C++ libraries" on \
- PYTHON "Boost.Python - interfacing Python and C++" off \
- DOCS "Documentation & examples" on
+OPTIONS_DEFINE= JAM LIBRARIES PYTHON DOCS
+OPTIONS_DEFAULT= JAM LIBRARIES
+JAM_DESC= Boost.Jam - Build tool from the boost.org
+LIBRARIES_DESC= Free portable C++ libraries
+PYTHON_DESC= Boost.Python - interfacing Python and C++
NO_BUILD= yes
.include <bsd.port.pre.mk>
.include "common.mk"
-.if !defined(WITHOUT_LIBRARIES)
+.if ${PORT_OPTIONS:MLIBRARIES}
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_thread.so:${PORTSDIR}/devel/boost-libs
.endif
-.if !defined(WITHOUT_JAM)
+.if ${PORT_OPTIONS:MJAM}
RUN_DEPENDS+= ${LOCALBASE}/bin/bjam:${PORTSDIR}/devel/boost-jam
.endif
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_python.so:${PORTSDIR}/devel/boost-python-libs
.endif
-.if !defined(WITHOUT_DOCS)
+.if ${PORT_OPTIONS:MDOCS}
RUN_DEPENDS+= ${LOCALBASE}/share/doc/boost/doc/html/index.html:${PORTSDIR}/devel/boost-docs
.endif
diff --git a/devel/boost-all/common.mk b/devel/boost-all/common.mk
index 1b014201329a..b551b7c03dff 100644
--- a/devel/boost-all/common.mk
+++ b/devel/boost-all/common.mk
@@ -1,10 +1,12 @@
-PORTVERSION= 1.48.0
+PORTVERSION= 1.52.0
PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//}
DISTNAME= boost_${PORTVERSION:S/./_/g}
CATEGORIES= devel
-MAINTAINER= churanov.port.maintainer@gmail.com
+MAINTAINER= office@FreeBSD.org
CONFLICTS+= boost-python-1* boost-1*
MASTER_SITES= SF/boost/boost/${PORTVERSION}
+
+USE_BZIP2= yes
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index c24415d8e345..730673dd1bdf 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -1,51 +1,60 @@
-
-USE_GCC= 4.2+
USE_LDCONFIG= yes
-BOOST_SHARED_LIB_VER= 4
+BOOST_SHARED_LIB_VER= 5
PKGMESSAGE= ${WRKDIR}/pkg-message
MAKE_JOBS_SAFE= yes
BJAM= bjam
-CXXFLAGS+= -Wno-long-long
PLIST_SUB+= BOOST_SHARED_LIB_VER=${BOOST_SHARED_LIB_VER}
PKG_MESSAGE_FILE_THREADS= ${PORTSDIR}/devel/boost-all/pkg-message.threads
PKG_MESSAGE_FILE_PYTHON= ${PORTSDIR}/devel/boost-all/pkg-message.python
-BOOST_TOOLS= gcc
+BJAM_ARGS= --layout=system \
+ --prefix=${PREFIX}
+
+.if ${ARCH} == amd64
+BJAM_ARGS+= cxxflags=-fPIC
+.endif
+
+NO_CCACHE= yes
+.if ${CC:T:Mgcc*}
+BOOST_TOOLSET:= gcc
+.elif ${CC:T:Mclang}
+BOOST_TOOLSET:= clang
+.else
+_COMPILER_VERSION!= ${CC} --version
+. if ${_COMPILER_VERSION:Mgcc}
+BOOST_TOOLSET:= gcc
+. elif ${_COMPILER_VERSION:M\(GCC\)}
+BOOST_TOOLSET:= gcc
+. elif ${_COMPILER_VERSION:Mclang}
+BOOST_TOOLSET:= clang
+. else
+.error Unable to determine compiler type for ${CC}
+. endif
+. undef _COMPILER_VERSION
+.endif
-BJAM_OPTIONS= --layout=system --disable-long-double
-BJAM_OPTIONS+= ${_MAKE_JOBS}
-.if defined (WITH_VERBOSE_BUILD)
-BJAM_OPTIONS+= -d2
+BJAM_ARGS+= --toolset=${BOOST_TOOLSET} \
+ ${_MAKE_JOBS}
+.if ${PORT_OPTIONS:MVERBOSE_BUILD}
+BJAM_ARGS+= -d2
.endif
-.if defined (WITHOUT_DEBUG)
-BJAM_OPTIONS+= variant=release
+.if ${PORT_OPTIONS:MDEBUG}
+BJAM_ARGS+= debug
.else
-BJAM_OPTIONS+= variant=debug
+BJAM_ARGS+= release
.endif
-BJAM_OPTIONS+= threading=multi
+BJAM_ARGS+= threading=multi \
+ link=shared,static
-# Unless WITH_OPTIMIZED_CFLAGS is defined, the port uses
-# CXXFLAGS as defined by the user (overridng Boost's 'speed'
-# configuration scheme
-BJAM_OPTIONS+= optimization=speed
-.if defined (WITH_OPTIMIZED_CFLAGS)
-BJAM_OPTIONS+= inlining=full
-CXXFLAGS+= -O3
+BJAM_ARGS+= optimization=speed
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+BJAM_ARGS+= inlining=full
.endif
-customize-boost-build:
-# Do the right thing(tm) for pthread support and respect CXX
- @${REINPLACE_CMD}\
- -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|'\
- -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|'\
- -e 's|%%CXX%%|${CXX}|'\
- -e 's|%%CXXFLAGS%%|${CXXFLAGS}|'\
- ${WRKSRC}/tools/build/v2/tools/gcc.jam
-
- @${REINPLACE_CMD}\
- -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:S/-//}|'\
- ${WRKSRC}/tools/build/v2/tools/python.jam
+post-patch:
+ @${REINPLACE_CMD} -e 's|${PORTVERSION}|${BOOST_SHARED_LIB_VER}|g' \
+ ${WRKSRC}/Jamroot