aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-all
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2013-05-10 23:15:18 +0000
committerMikhail Teterin <mi@FreeBSD.org>2013-05-10 23:15:18 +0000
commit74be8bc94a0a3c4cbef51d5e49a506aa4ac9c45f (patch)
tree5bb93c5309acf03790f97a88105de849c28269c0 /devel/boost-all
parent385f91fb502496881ff288ee579a4ea1136d3c54 (diff)
downloadports-74be8bc94a0a3c4cbef51d5e49a506aa4ac9c45f.tar.gz
ports-74be8bc94a0a3c4cbef51d5e49a506aa4ac9c45f.zip
Notes
Diffstat (limited to 'devel/boost-all')
-rw-r--r--devel/boost-all/compiled.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index 50f7e7ef72ad..4166ceca6670 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -16,6 +16,11 @@ BJAM_ARGS= --layout=system \
BJAM_ARGS+= cxxflags=-fPIC
.endif
+# Our compiler-flags will be added AFTER those set by bjam. We remove
+# the optimization level, because Boost sets it itself (to -O3 in case
+# of gcc/g++):
+BJAM_ARGS+= cxxflags="${CXXFLAGS:N-O*}" cflags="${CFLAGS:N-O*}"
+
NO_CCACHE= yes
.if ${CC:T:Mgcc*}
BOOST_TOOLSET:= gcc