aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2015-09-10 15:21:05 +0000
committerDon Lewis <truckman@FreeBSD.org>2015-09-10 15:21:05 +0000
commit5286605cc47477f7b4b33abacdfebafcaaaed4d2 (patch)
tree35af0676a6b51714b1eebeafd9e61de4acaba1d1 /devel/boost-libs
parent9b9d541db43632b2492fb870de45baf9debc9b01 (diff)
Notes
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/boost-libs/files/patch-boost_static__assert.hpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 046ed685886a..d181ccdc6933 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -4,7 +4,7 @@
PORTNAME= boost-libs
COMMENT= Free portable C++ libraries (without Boost.Python)
-PORTREVISION= 6
+PORTREVISION= 7
BUILD_DEPENDS+= bjam:${PORTSDIR}/devel/boost-jam
diff --git a/devel/boost-libs/files/patch-boost_static__assert.hpp b/devel/boost-libs/files/patch-boost_static__assert.hpp
new file mode 100644
index 000000000000..2c283f96ccdb
--- /dev/null
+++ b/devel/boost-libs/files/patch-boost_static__assert.hpp
@@ -0,0 +1,11 @@
+--- boost/static_assert.hpp.orig 2013-09-21 20:17:00 UTC
++++ boost/static_assert.hpp
+@@ -67,7 +67,7 @@
+ //
+ // If the compiler warns about unused typedefs then enable this:
+ //
+-#if defined(__GNUC__) && ((__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 7)))
++#if defined(__GNUC__) && ((__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 7))) || defined(__clang__)
+ # define BOOST_STATIC_ASSERT_UNUSED_ATTRIBUTE __attribute__((unused))
+ #else
+ # define BOOST_STATIC_ASSERT_UNUSED_ATTRIBUTE