aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-07-13 20:09:11 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-07-13 20:09:11 +0000
commite77a8c104f583c7c2a60212e98dfa78d088cb143 (patch)
tree257d27d4471e49f8aee1c514b68681449295fae9 /devel/boost-libs
parentcd57934a7090fba69f8cd78e4c37fefbc3322430 (diff)
Notes
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile5
-rw-r--r--devel/boost-libs/files/patch-boost-interprocess-shared_memory_object.hpp37
-rw-r--r--devel/boost-libs/files/patch-boost_asio-ioctl18
3 files changed, 53 insertions, 7 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index e37832c6d573..8b0632e13594 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -26,9 +26,12 @@ BOOST_LIBS= date_time filesystem graph iostreams\
.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk"
-.if defined (WITH_ICU)
+.if defined(WITH_ICU)
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu
BJAM_OPTIONS+= -sICU_PATH=${LOCALBASE}
+.else
+USE_ICONV= yes
+BJAM_OPTIONS+= -sICONV_PATH=${LOCALBASE}
.endif
.if ${ARCH} == "sparc64"
diff --git a/devel/boost-libs/files/patch-boost-interprocess-shared_memory_object.hpp b/devel/boost-libs/files/patch-boost-interprocess-shared_memory_object.hpp
new file mode 100644
index 000000000000..7e4f792dfb13
--- /dev/null
+++ b/devel/boost-libs/files/patch-boost-interprocess-shared_memory_object.hpp
@@ -0,0 +1,37 @@
+--- boost/interprocess/shared_memory_object.hpp.orig 2012-07-12 15:27:30.607506166 +0200
++++ boost/interprocess/shared_memory_object.hpp 2012-07-12 15:30:22.481507868 +0200
+@@ -1,6 +1,6 @@
+ //////////////////////////////////////////////////////////////////////////////
+ //
+-// (C) Copyright Ion Gaztanaga 2005-2009. Distributed under the Boost
++// (C) Copyright Ion Gaztanaga 2005-2011. Distributed under the Boost
+ // Software License, Version 1.0. (See accompanying file
+ // LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
+ //
+@@ -251,7 +251,7 @@
+
+ #if defined(__FreeBSD__)
+
+-inline bool use_filesistem_based_posix()
++inline bool use_filesystem_based_posix()
+ {
+ int jailed = 0;
+ std::size_t len = sizeof(jailed);
+@@ -275,7 +275,7 @@
+ #if defined(BOOST_INTERPROCESS_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
+ const bool add_leading_slash = false;
+ #elif defined(BOOST_INTERPROCESS_RUNTIME_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
+- const bool add_leading_slash = !shared_memory_object_ipcdetail::use_filesistem_based_posix();
++ const bool add_leading_slash = !shared_memory_object_detail::use_filesystem_based_posix();
+ #else
+ const bool add_leading_slash = true;
+ #endif
+@@ -361,7 +361,7 @@
+ #if defined(BOOST_INTERPROCESS_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
+ const bool add_leading_slash = false;
+ #elif defined(BOOST_INTERPROCESS_RUNTIME_FILESYSTEM_BASED_POSIX_SHARED_MEMORY)
+- const bool add_leading_slash = !shared_memory_object_ipcdetail::use_filesistem_based_posix();
++ const bool add_leading_slash = !shared_memory_object_detail::use_filesystem_based_posix();
+ #else
+ const bool add_leading_slash = true;
+ #endif \ No newline at end of file
diff --git a/devel/boost-libs/files/patch-boost_asio-ioctl b/devel/boost-libs/files/patch-boost_asio-ioctl
index 0edf91fb60e4..2422f44875af 100644
--- a/devel/boost-libs/files/patch-boost_asio-ioctl
+++ b/devel/boost-libs/files/patch-boost_asio-ioctl
@@ -1,23 +1,29 @@
---- boost/asio/detail/io_control.hpp.orig 2010-12-06 01:32:39.000000000 +0300
-+++ boost/asio/detail/io_control.hpp 2010-12-06 01:37:34.000000000 +0300
-@@ -44,7 +44,7 @@
+--- boost/asio/detail/io_control.hpp.orig 2011-06-06 03:21:43.000000000 +0400
++++ boost/asio/detail/io_control.hpp 2012-07-10 13:24:45.000000000 +0400
+@@ -44,9 +44,9 @@
}
// Get the name of the IO control command.
- int name() const
+ ioctl_cmd_type name() const
{
- return FIONBIO;
+- return static_cast<int>(FIONBIO);
++ return static_cast<ioctl_cmd_type>(FIONBIO);
}
-@@ -94,7 +94,7 @@
+
+ // Set the value of the I/O control command.
+@@ -94,9 +94,9 @@
}
// Get the name of the IO control command.
- int name() const
+ ioctl_cmd_type name() const
{
- return FIONREAD;
+- return static_cast<int>(FIONREAD);
++ return static_cast<ioctl_cmd_type>(FIONREAD);
}
+
+ // Set the value of the I/O control command.
--- boost/asio/detail/descriptor_ops.hpp.orig 2010-12-06 01:55:08.000000000 +0300
+++ boost/asio/detail/descriptor_ops.hpp 2010-12-06 01:55:39.000000000 +0300
@@ -79,7 +79,7 @@