aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-01-08 07:46:42 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-01-08 07:46:42 +0000
commitd5f12424bd3a9d9467f2e3380b24a202d716bb6e (patch)
tree45c10929ca6d64db4de86c3f54c184bab69cdc1c /devel/boost-libs
parent3c608a1d3f39905ba24a470a1416f575da34394c (diff)
downloadports-d5f12424bd3a9d9467f2e3380b24a202d716bb6e.tar.gz
ports-d5f12424bd3a9d9467f2e3380b24a202d716bb6e.zip
Notes
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile1
-rw-r--r--devel/boost-libs/files/patch-libs_filesystem__v2__src__v2_path.cpp11
-rw-r--r--devel/boost-libs/files/patch-libs_filesystem__v3__src__path.cpp11
3 files changed, 23 insertions, 0 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 6e39642beffc..c9d3bd2e023f 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= boost-libs
+PORTREVISION= 1
COMMENT= Free portable C++ libraries (without Boost.Python)
USE_BZIP2= yes
diff --git a/devel/boost-libs/files/patch-libs_filesystem__v2__src__v2_path.cpp b/devel/boost-libs/files/patch-libs_filesystem__v2__src__v2_path.cpp
new file mode 100644
index 000000000000..b459631b2845
--- /dev/null
+++ b/devel/boost-libs/files/patch-libs_filesystem__v2__src__v2_path.cpp
@@ -0,0 +1,11 @@
+--- libs/filesystem/v2/src/v2_path.cpp.orig 2010-12-29 19:23:18.000000000 +0100
++++ libs/filesystem/v2/src/v2_path.cpp 2010-12-29 19:23:54.000000000 +0100
+@@ -45,7 +45,7 @@
+ {
+ #if !defined(macintosh) && !defined(__APPLE__) && !defined(__APPLE_CC__)
+ // ISO C calls this "the locale-specific native environment":
+- static std::locale lc("");
++ static std::locale lc;
+ #else // Mac OS
+ // "All BSD system functions expect their string parameters to be in UTF-8 encoding
+ // and nothing else." \ No newline at end of file
diff --git a/devel/boost-libs/files/patch-libs_filesystem__v3__src__path.cpp b/devel/boost-libs/files/patch-libs_filesystem__v3__src__path.cpp
new file mode 100644
index 000000000000..6631d8bcddd1
--- /dev/null
+++ b/devel/boost-libs/files/patch-libs_filesystem__v3__src__path.cpp
@@ -0,0 +1,11 @@
+--- libs/filesystem/v3/src/path.cpp.orig 2010-12-29 19:30:47.000000000 +0100
++++ libs/filesystem/v3/src/path.cpp 2010-12-29 19:31:36.000000000 +0100
+@@ -760,7 +760,7 @@
+
+ # else
+ // ISO C calls this "the locale-specific native environment":
+- return std::locale("");
++ return std::locale();
+
+ # endif
+ }