aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-libs
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-12-12 00:15:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-12-12 00:15:49 +0000
commit7c879267dc47bb7723011ce7fd8f8cb518739c8c (patch)
treed48522d464e1ff041584b2a31f9ed94d0a22776f /devel/boost-libs
parentc96bb1299df44dcc114eb2c2be07deefb39984b6 (diff)
downloadports-7c879267dc47bb7723011ce7fd8f8cb518739c8c.tar.gz
ports-7c879267dc47bb7723011ce7fd8f8cb518739c8c.zip
Notes
Diffstat (limited to 'devel/boost-libs')
-rw-r--r--devel/boost-libs/Makefile2
-rw-r--r--devel/boost-libs/distinfo6
-rw-r--r--devel/boost-libs/files/patch-boost_asio_detail_config.hpp13
-rw-r--r--devel/boost-libs/files/patch-boost_regex_config.hpp13
-rw-r--r--devel/boost-libs/files/patch-boost_system_error__code.hpp35
-rw-r--r--devel/boost-libs/files/patch-libs_filesystem_src_operations.cpp29
-rw-r--r--devel/boost-libs/files/patch-tools_build_src_tools_clang-linux.jam89
-rw-r--r--devel/boost-libs/pkg-plist146
8 files changed, 93 insertions, 240 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index 4d9193e7900b..62f615e7518e 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= boost-libs
-PORTREVISION= 3
+PORTREVISION= 0
COMMENT= Free portable C++ libraries (without Boost.Python)
diff --git a/devel/boost-libs/distinfo b/devel/boost-libs/distinfo
index 8653f3ea361d..9f49d54aa993 100644
--- a/devel/boost-libs/distinfo
+++ b/devel/boost-libs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533158517
-SHA256 (boost_1_68_0.tar.bz2) = 7f6130bc3cf65f56a618888ce9d5ea704fa10b462be126ad053e80e553d6d8b7
-SIZE (boost_1_68_0.tar.bz2) = 92155315
+TIMESTAMP = 1544042264
+SHA256 (boost_1_69_0.tar.bz2) = 8f32d4617390d1c2d16f26a27ab60d97807b35440d45891fa340fc2648b04406
+SIZE (boost_1_69_0.tar.bz2) = 95078138
diff --git a/devel/boost-libs/files/patch-boost_asio_detail_config.hpp b/devel/boost-libs/files/patch-boost_asio_detail_config.hpp
deleted file mode 100644
index 74a49b077794..000000000000
--- a/devel/boost-libs/files/patch-boost_asio_detail_config.hpp
+++ /dev/null
@@ -1,13 +0,0 @@
-https://github.com/boostorg/asio/pull/135
-
---- boost/asio/detail/config.hpp.orig 2018-04-11 13:49:00 UTC
-+++ boost/asio/detail/config.hpp
-@@ -777,7 +777,7 @@
- #if !defined(BOOST_ASIO_HAS_STD_STRING_VIEW)
- # if !defined(BOOST_ASIO_DISABLE_STD_STRING_VIEW)
- # if defined(__clang__)
--# if (__cplusplus >= 201703)
-+# if defined(BOOST_ASIO_HAS_CLANG_LIBCXX) || (__cplusplus >= 201703)
- # if __has_include(<string_view>)
- # define BOOST_ASIO_HAS_STD_STRING_VIEW 1
- # endif // __has_include(<string_view>)
diff --git a/devel/boost-libs/files/patch-boost_regex_config.hpp b/devel/boost-libs/files/patch-boost_regex_config.hpp
new file mode 100644
index 000000000000..635aa122f449
--- /dev/null
+++ b/devel/boost-libs/files/patch-boost_regex_config.hpp
@@ -0,0 +1,13 @@
+https://github.com/boostorg/regex/issues/72
+
+--- boost/regex/config.hpp.orig 2018-10-30 22:45:30 UTC
++++ boost/regex/config.hpp
+@@ -117,7 +117,7 @@
+ * Clang fails to export template instances with -fvisibility=hidden, see
+ * https://github.com/boostorg/regex/issues/49
+ */
+-#ifdef __clang__
++#if defined(__clang__) || defined(_LIBCPP_VERSION)
+ # define BOOST_REGEX_NO_EXTERNAL_TEMPLATES
+ #endif
+
diff --git a/devel/boost-libs/files/patch-boost_system_error__code.hpp b/devel/boost-libs/files/patch-boost_system_error__code.hpp
deleted file mode 100644
index 11091c0a62ea..000000000000
--- a/devel/boost-libs/files/patch-boost_system_error__code.hpp
+++ /dev/null
@@ -1,35 +0,0 @@
-Boost.System built in C++ >= 17 doesn't support C++14 consumers with GCC 7.3
-
-$ cat >a.cc
-#include <boost/system/error_code.hpp>
-
-int main()
-{
- boost::system::error_code e;
- e.clear();
- return 0;
-}
-
-$ g++7 -std=gnu++98 -lboost_system a.cc
-$ g++7 -std=gnu++03 -lboost_system a.cc
-$ g++7 -std=gnu++11 -lboost_system a.cc
-$ g++7 -std=gnu++17 -lboost_system a.cc
-$ g++7 -std=gnu++14 -lboost_system a.cc
-/tmp//cciZnzeq.o: In function `main':
-a.cc:(.text+0x24): undefined reference to `boost::system::detail::system_category_instance'
-/tmp//cciZnzeq.o: In function `boost::system::system_category()':
-a.cc:(.text._ZN5boost6system15system_categoryEv[_ZN5boost6system15system_categoryEv]+0x5): undefined reference to `boost::system::detail::system_category_instance'
-/tmp//cciZnzeq.o: In function `boost::system::generic_category()':
-a.cc:(.text._ZN5boost6system16generic_categoryEv[_ZN5boost6system16generic_categoryEv]+0x5): undefined reference to `boost::system::detail::generic_category_instance'
-
---- boost/system/error_code.hpp.orig 2018-08-01 20:50:53 UTC
-+++ boost/system/error_code.hpp
-@@ -43,7 +43,7 @@
- # define BOOST_SYSTEM_HAS_CONSTEXPR
- #endif
-
--#if defined(__GNUC__) && (__GNUC__ == 7 && __GNUC_MINOR__ < 4) && __cplusplus >= 201700L
-+#if defined(__GNUC__) && (__GNUC__ == 7 && __GNUC_MINOR__ < 4)
- // https://gcc.gnu.org/bugzilla/show_bug.cgi?id=83835
- # undef BOOST_SYSTEM_HAS_CONSTEXPR
- #endif
diff --git a/devel/boost-libs/files/patch-libs_filesystem_src_operations.cpp b/devel/boost-libs/files/patch-libs_filesystem_src_operations.cpp
deleted file mode 100644
index 42931729b3ab..000000000000
--- a/devel/boost-libs/files/patch-libs_filesystem_src_operations.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
-Fixes a null pointer dereference, patch origin:
-https://github.com/boostorg/filesystem/pull/71
---- libs/filesystem/src/operations.cpp.orig 2018-04-11 13:49:02 UTC
-+++ libs/filesystem/src/operations.cpp
-@@ -890,20 +890,20 @@ namespace detail
- BOOST_FILESYSTEM_DECL
- void copy(const path& from, const path& to, system::error_code* ec)
- {
-- file_status s(symlink_status(from, *ec));
-+ file_status s(detail::symlink_status(from, ec));
- if (ec != 0 && *ec) return;
-
- if(is_symlink(s))
- {
-- copy_symlink(from, to, *ec);
-+ detail::copy_symlink(from, to, ec);
- }
- else if(is_directory(s))
- {
-- copy_directory(from, to, *ec);
-+ detail::copy_directory(from, to, ec);
- }
- else if(is_regular_file(s))
- {
-- copy_file(from, to, fs::copy_option::fail_if_exists, *ec);
-+ detail::copy_file(from, to, detail::fail_if_exists, ec);
- }
- else
- {
diff --git a/devel/boost-libs/files/patch-tools_build_src_tools_clang-linux.jam b/devel/boost-libs/files/patch-tools_build_src_tools_clang-linux.jam
deleted file mode 100644
index 9fd189a6b05c..000000000000
--- a/devel/boost-libs/files/patch-tools_build_src_tools_clang-linux.jam
+++ /dev/null
@@ -1,89 +0,0 @@
---- tools/build/src/tools/clang-linux.jam.orig 2017-11-19 12:12:37 UTC
-+++ tools/build/src/tools/clang-linux.jam
-@@ -32,7 +32,7 @@ generators.override clang-linux.compile.c.pch : pch.
- generators.override clang-linux.compile.c++.pch : pch.default-cpp-pch-generator ;
-
- type.set-generated-target-suffix PCH
-- : <toolset>clang <toolset-clang:platform>linux : pth ;
-+ : <toolset>clang <toolset-clang:platform>linux : pch ;
-
- toolset.inherit-rules clang-linux : gcc ;
- toolset.inherit-flags clang-linux : gcc
-@@ -101,47 +101,47 @@ toolset.flags clang-linux.compile OPTIONS <rtti>off :
- # C and C++ compilation
-
- rule compile.c++ ( targets * : sources * : properties * ) {
-- local pth-file = [ on $(<) return $(PCH_FILE) ] ;
-+ local pch-file = [ on $(<) return $(PCH_FILE) ] ;
-
-- if $(pth-file) {
-- DEPENDS $(<) : $(pth-file) ;
-+ if $(pch-file) {
-+ DEPENDS $(<) : $(pch-file) ;
- clang-linux.compile.c++.with-pch $(targets) : $(sources) ;
- }
- else {
-- clang-linux.compile.c++.without-pth $(targets) : $(sources) ;
-+ clang-linux.compile.c++.without-pch $(targets) : $(sources) ;
- }
- }
-
--actions compile.c++.without-pth {
-+actions compile.c++.without-pch {
- "$(CONFIG_COMMAND)" -c -x c++ $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -o "$(<)" "$(>)"
- }
-
- actions compile.c++.with-pch bind PCH_FILE
- {
-- "$(CONFIG_COMMAND)" -c -x c++ $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -include-pth -Xclang "$(PCH_FILE)" -o "$(<)" "$(>)"
-+ "$(CONFIG_COMMAND)" -c -x c++ $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -include-pch -Xclang "$(PCH_FILE)" -o "$(<)" "$(>)"
- }
-
- rule compile.c ( targets * : sources * : properties * )
- {
-- local pth-file = [ on $(<) return $(PCH_FILE) ] ;
-+ local pch-file = [ on $(<) return $(PCH_FILE) ] ;
-
-- if $(pth-file) {
-- DEPENDS $(<) : $(pth-file) ;
-+ if $(pch-file) {
-+ DEPENDS $(<) : $(pch-file) ;
- clang-linux.compile.c.with-pch $(targets) : $(sources) ;
- }
- else {
-- clang-linux.compile.c.without-pth $(targets) : $(sources) ;
-+ clang-linux.compile.c.without-pch $(targets) : $(sources) ;
- }
- }
-
--actions compile.c.without-pth
-+actions compile.c.without-pch
- {
- "$(CONFIG_COMMAND)" -c -x c $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -c -o "$(<)" "$(>)"
- }
-
- actions compile.c.with-pch bind PCH_FILE
- {
-- "$(CONFIG_COMMAND)" -c -x c $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -include-pth -Xclang "$(PCH_FILE)" -c -o "$(<)" "$(>)"
-+ "$(CONFIG_COMMAND)" -c -x c $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -include-pch -Xclang "$(PCH_FILE)" -c -o "$(<)" "$(>)"
- }
-
- ###############################################################################
-@@ -153,7 +153,7 @@ rule compile.c++.pch ( targets * : sources * : propert
- }
-
- actions compile.c++.pch {
-- $(RM) -f "$(<)" && "$(CONFIG_COMMAND)" -c -x c++-header $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -emit-pth -o "$(<)" "$(>)"
-+ $(RM) -f "$(<)" && "$(CONFIG_COMMAND)" -c -x c++-header $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -emit-pch -o "$(<)" "$(>)"
- }
-
- rule compile.c.pch ( targets * : sources * : properties * ) {
-@@ -161,7 +161,7 @@ rule compile.c.pch ( targets * : sources * : propertie
-
- actions compile.c.pch
- {
-- $(RM) -f "$(<)" && "$(CONFIG_COMMAND)" -c -x c-header $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -emit-pth -o "$(<)" "$(>)"
-+ $(RM) -f "$(<)" && "$(CONFIG_COMMAND)" -c -x c-header $(OPTIONS) $(USER_OPTIONS) -D$(DEFINES) -I"$(INCLUDES)" -Xclang -emit-pch -o "$(<)" "$(>)"
- }
-
- ###############################################################################
diff --git a/devel/boost-libs/pkg-plist b/devel/boost-libs/pkg-plist
index acf048d27f8d..5af41d51908f 100644
--- a/devel/boost-libs/pkg-plist
+++ b/devel/boost-libs/pkg-plist
@@ -397,6 +397,7 @@ include/boost/asio/detail/executor_op.hpp
include/boost/asio/detail/fd_set_adapter.hpp
include/boost/asio/detail/fenced_block.hpp
include/boost/asio/detail/functional.hpp
+include/boost/asio/detail/future.hpp
include/boost/asio/detail/gcc_arm_fenced_block.hpp
include/boost/asio/detail/gcc_hppa_fenced_block.hpp
include/boost/asio/detail/gcc_sync_fenced_block.hpp
@@ -916,12 +917,12 @@ include/boost/beast/core/buffers_to_string.hpp
include/boost/beast/core/detail/allocator.hpp
include/boost/beast/core/detail/base64.hpp
include/boost/beast/core/detail/bind_handler.hpp
+include/boost/beast/core/detail/buffer.hpp
include/boost/beast/core/detail/buffers_ref.hpp
include/boost/beast/core/detail/chacha.hpp
include/boost/beast/core/detail/clamp.hpp
include/boost/beast/core/detail/config.hpp
include/boost/beast/core/detail/cpu_info.hpp
-include/boost/beast/core/detail/empty_base_optimization.hpp
include/boost/beast/core/detail/integer_sequence.hpp
include/boost/beast/core/detail/ostream.hpp
include/boost/beast/core/detail/sha1.hpp
@@ -965,9 +966,17 @@ include/boost/beast/core/string.hpp
include/boost/beast/core/string_param.hpp
include/boost/beast/core/type_traits.hpp
include/boost/beast/experimental/core/detail/flat_stream.hpp
+include/boost/beast/experimental/core/detail/impl/timeout_service.ipp
+include/boost/beast/experimental/core/detail/service_base.hpp
+include/boost/beast/experimental/core/detail/timeout_service.hpp
+include/boost/beast/experimental/core/detail/timeout_work_guard.hpp
include/boost/beast/experimental/core/flat_stream.hpp
include/boost/beast/experimental/core/impl/flat_stream.ipp
+include/boost/beast/experimental/core/impl/timeout_service.ipp
+include/boost/beast/experimental/core/impl/timeout_socket.hpp
include/boost/beast/experimental/core/ssl_stream.hpp
+include/boost/beast/experimental/core/timeout_service.hpp
+include/boost/beast/experimental/core/timeout_socket.hpp
include/boost/beast/experimental/http/icy_stream.hpp
include/boost/beast/experimental/http/impl/icy_stream.ipp
include/boost/beast/experimental/test/detail/error.hpp
@@ -1293,39 +1302,13 @@ include/boost/chrono/io/utility/to_string.hpp
include/boost/chrono/io_v1/chrono_io.hpp
include/boost/chrono/process_cpu_clocks.hpp
include/boost/chrono/round.hpp
-include/boost/chrono/stopwatches.hpp
-include/boost/chrono/stopwatches/collectors/laps_accumulator_set.hpp
-include/boost/chrono/stopwatches/collectors/laps_sequence_container.hpp
-include/boost/chrono/stopwatches/collectors/last_lap.hpp
-include/boost/chrono/stopwatches/collectors/no_memory.hpp
-include/boost/chrono/stopwatches/dont_start.hpp
-include/boost/chrono/stopwatches/formatters/accumulator_set_formatter.hpp
-include/boost/chrono/stopwatches/formatters/base_formatter.hpp
-include/boost/chrono/stopwatches/formatters/elapsed_formatter.hpp
-include/boost/chrono/stopwatches/formatters/times_formatter.hpp
-include/boost/chrono/stopwatches/laps_stopwatch.hpp
-include/boost/chrono/stopwatches/reporters/clock_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/laps_accumulator_set_stopwatch_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/laps_stopclock.hpp
-include/boost/chrono/stopwatches/reporters/laps_stopwatch_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/process_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/stopclock.hpp
-include/boost/chrono/stopwatches/reporters/stopwatch_reporter.hpp
-include/boost/chrono/stopwatches/reporters/stopwatch_reporter_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/strict_stopclock.hpp
-include/boost/chrono/stopwatches/reporters/system_default_formatter.hpp
-include/boost/chrono/stopwatches/reporters/thread_default_formatter.hpp
-include/boost/chrono/stopwatches/simple_stopwatch.hpp
-include/boost/chrono/stopwatches/stopwatch.hpp
-include/boost/chrono/stopwatches/stopwatch_scoped.hpp
-include/boost/chrono/stopwatches/strict_stopwatch.hpp
-include/boost/chrono/stopwatches/suspendable_stopwatch.hpp
include/boost/chrono/system_clocks.hpp
include/boost/chrono/thread_clock.hpp
include/boost/chrono/time_point.hpp
include/boost/chrono/typeof/boost/chrono/chrono.hpp
include/boost/chrono/typeof/boost/ratio.hpp
include/boost/circular_buffer.hpp
+include/boost/circular_buffer/allocators.hpp
include/boost/circular_buffer/base.hpp
include/boost/circular_buffer/debug.hpp
include/boost/circular_buffer/details.hpp
@@ -1959,7 +1942,6 @@ include/boost/contract/public_function.hpp
include/boost/contract_macro.hpp
include/boost/convert.hpp
include/boost/convert/base.hpp
-include/boost/convert/detail/boost_parameter_ext.hpp
include/boost/convert/detail/char.hpp
include/boost/convert/detail/config.hpp
include/boost/convert/detail/has_member.hpp
@@ -1977,6 +1959,7 @@ include/boost/convert/strtol.hpp
include/boost/core/addressof.hpp
include/boost/core/checked_delete.hpp
include/boost/core/demangle.hpp
+include/boost/core/empty_value.hpp
include/boost/core/enable_if.hpp
include/boost/core/exchange.hpp
include/boost/core/explicit_operator_bool.hpp
@@ -1988,6 +1971,7 @@ include/boost/core/no_exceptions_support.hpp
include/boost/core/noncopyable.hpp
include/boost/core/null_deleter.hpp
include/boost/core/pointer_traits.hpp
+include/boost/core/quick_exit.hpp
include/boost/core/ref.hpp
include/boost/core/scoped_enum.hpp
include/boost/core/swap.hpp
@@ -2172,7 +2156,6 @@ include/boost/detail/call_traits.hpp
include/boost/detail/catch_exceptions.hpp
include/boost/detail/compressed_pair.hpp
include/boost/detail/container_fwd.hpp
-include/boost/detail/dynamic_bitset.hpp
include/boost/detail/endian.hpp
include/boost/detail/fenv.hpp
include/boost/detail/has_default_constructor.hpp
@@ -2290,6 +2273,8 @@ include/boost/dll/shared_library_load_mode.hpp
include/boost/dll/smart_library.hpp
include/boost/dynamic_bitset.hpp
include/boost/dynamic_bitset/config.hpp
+include/boost/dynamic_bitset/detail/dynamic_bitset.hpp
+include/boost/dynamic_bitset/detail/lowest_bit.hpp
include/boost/dynamic_bitset/dynamic_bitset.hpp
include/boost/dynamic_bitset/serialization.hpp
include/boost/dynamic_bitset_fwd.hpp
@@ -2297,7 +2282,6 @@ include/boost/enable_shared_from_this.hpp
include/boost/endian/arithmetic.hpp
include/boost/endian/buffers.hpp
include/boost/endian/conversion.hpp
-include/boost/endian/detail/config.hpp
include/boost/endian/detail/cover_operators.hpp
include/boost/endian/detail/disable_warnings.hpp
include/boost/endian/detail/disable_warnings_pop.hpp
@@ -2352,6 +2336,7 @@ include/boost/fiber/detail/cpu_relax.hpp
include/boost/fiber/detail/data.hpp
include/boost/fiber/detail/decay_copy.hpp
include/boost/fiber/detail/disable_overload.hpp
+include/boost/fiber/detail/exchange.hpp
include/boost/fiber/detail/fss.hpp
include/boost/fiber/detail/futex.hpp
include/boost/fiber/detail/is_all_same.hpp
@@ -2363,6 +2348,7 @@ include/boost/fiber/detail/spinlock_ttas.hpp
include/boost/fiber/detail/spinlock_ttas_adaptive.hpp
include/boost/fiber/detail/spinlock_ttas_adaptive_futex.hpp
include/boost/fiber/detail/spinlock_ttas_futex.hpp
+include/boost/fiber/detail/thread_barrier.hpp
include/boost/fiber/exceptions.hpp
include/boost/fiber/fiber.hpp
include/boost/fiber/fixedsize_stack.hpp
@@ -3838,6 +3824,8 @@ include/boost/geometry/algorithms/detail/within/multi_point.hpp
include/boost/geometry/algorithms/detail/within/point_in_geometry.hpp
include/boost/geometry/algorithms/detail/within/within_no_turns.hpp
include/boost/geometry/algorithms/difference.hpp
+include/boost/geometry/algorithms/discrete_frechet_distance.hpp
+include/boost/geometry/algorithms/discrete_hausdorff_distance.hpp
include/boost/geometry/algorithms/disjoint.hpp
include/boost/geometry/algorithms/dispatch/disjoint.hpp
include/boost/geometry/algorithms/dispatch/distance.hpp
@@ -3916,6 +3904,7 @@ include/boost/geometry/formulas/flattening.hpp
include/boost/geometry/formulas/geographic.hpp
include/boost/geometry/formulas/gnomonic_intersection.hpp
include/boost/geometry/formulas/gnomonic_spheroid.hpp
+include/boost/geometry/formulas/karney_direct.hpp
include/boost/geometry/formulas/mean_radius.hpp
include/boost/geometry/formulas/meridian_direct.hpp
include/boost/geometry/formulas/meridian_inverse.hpp
@@ -4187,6 +4176,7 @@ include/boost/geometry/srs/iau2000.hpp
include/boost/geometry/srs/projection.hpp
include/boost/geometry/srs/projections/code.hpp
include/boost/geometry/srs/projections/constants.hpp
+include/boost/geometry/srs/projections/dpar.hpp
include/boost/geometry/srs/projections/epsg.hpp
include/boost/geometry/srs/projections/epsg_params.hpp
include/boost/geometry/srs/projections/epsg_traits.hpp
@@ -4195,6 +4185,7 @@ include/boost/geometry/srs/projections/esri_params.hpp
include/boost/geometry/srs/projections/esri_traits.hpp
include/boost/geometry/srs/projections/exception.hpp
include/boost/geometry/srs/projections/factory.hpp
+include/boost/geometry/srs/projections/factory_key.hpp
include/boost/geometry/srs/projections/grids.hpp
include/boost/geometry/srs/projections/iau2000.hpp
include/boost/geometry/srs/projections/iau2000_params.hpp
@@ -4234,7 +4225,7 @@ include/boost/geometry/srs/projections/impl/pj_zpoly1.hpp
include/boost/geometry/srs/projections/impl/proj_mdist.hpp
include/boost/geometry/srs/projections/impl/projects.hpp
include/boost/geometry/srs/projections/invalid_point.hpp
-include/boost/geometry/srs/projections/par4.hpp
+include/boost/geometry/srs/projections/par_data.hpp
include/boost/geometry/srs/projections/proj/aea.hpp
include/boost/geometry/srs/projections/proj/aeqd.hpp
include/boost/geometry/srs/projections/proj/airy.hpp
@@ -4335,6 +4326,7 @@ include/boost/geometry/srs/projections/proj/wink1.hpp
include/boost/geometry/srs/projections/proj/wink2.hpp
include/boost/geometry/srs/projections/proj4.hpp
include/boost/geometry/srs/projections/shared_grids.hpp
+include/boost/geometry/srs/projections/spar.hpp
include/boost/geometry/srs/projections/srid_traits.hpp
include/boost/geometry/srs/projections/str_cast.hpp
include/boost/geometry/srs/shared_grids.hpp
@@ -4486,6 +4478,7 @@ include/boost/geometry/util/select_calculation_type.hpp
include/boost/geometry/util/select_coordinate_type.hpp
include/boost/geometry/util/select_most_precise.hpp
include/boost/geometry/util/select_sequence_element.hpp
+include/boost/geometry/util/series_expansion.hpp
include/boost/geometry/util/transform_variant.hpp
include/boost/geometry/views/box_view.hpp
include/boost/geometry/views/closeable_view.hpp
@@ -4511,6 +4504,7 @@ include/boost/gil/cmyk.hpp
include/boost/gil/color_base.hpp
include/boost/gil/color_base_algorithm.hpp
include/boost/gil/color_convert.hpp
+include/boost/gil/concepts.hpp
include/boost/gil/deprecated.hpp
include/boost/gil/device_n.hpp
include/boost/gil/extension/dynamic_image/algorithm.hpp
@@ -4635,15 +4629,11 @@ include/boost/gil/extension/toolbox/metafunctions/channel_type.hpp
include/boost/gil/extension/toolbox/metafunctions/channel_view.hpp
include/boost/gil/extension/toolbox/metafunctions/get_num_bits.hpp
include/boost/gil/extension/toolbox/metafunctions/get_pixel_type.hpp
-include/boost/gil/extension/toolbox/metafunctions/gil_extensions.hpp
include/boost/gil/extension/toolbox/metafunctions/is_bit_aligned.hpp
include/boost/gil/extension/toolbox/metafunctions/is_homogeneous.hpp
include/boost/gil/extension/toolbox/metafunctions/is_similar.hpp
include/boost/gil/extension/toolbox/metafunctions/pixel_bit_size.hpp
include/boost/gil/extension/toolbox/toolbox.hpp
-include/boost/gil/gil_all.hpp
-include/boost/gil/gil_concept.hpp
-include/boost/gil/gil_config.hpp
include/boost/gil/gray.hpp
include/boost/gil/image.hpp
include/boost/gil/image_view.hpp
@@ -4685,6 +4675,7 @@ include/boost/gil/pixel_iterator.hpp
include/boost/gil/pixel_iterator_adaptor.hpp
include/boost/gil/planar_pixel_iterator.hpp
include/boost/gil/planar_pixel_reference.hpp
+include/boost/gil/point.hpp
include/boost/gil/position_iterator.hpp
include/boost/gil/premultiply.hpp
include/boost/gil/promote_integral.hpp
@@ -5963,6 +5954,7 @@ include/boost/iostreams/filter/stdio.hpp
include/boost/iostreams/filter/symmetric.hpp
include/boost/iostreams/filter/test.hpp
include/boost/iostreams/filter/zlib.hpp
+include/boost/iostreams/filter/zstd.hpp
include/boost/iostreams/filtering_stream.hpp
include/boost/iostreams/filtering_streambuf.hpp
include/boost/iostreams/flush.hpp
@@ -6053,7 +6045,6 @@ include/boost/lambda/lambda.hpp
include/boost/lambda/loops.hpp
include/boost/lambda/numeric.hpp
include/boost/lambda/switch.hpp
-include/boost/last_value.hpp
include/boost/lexical_cast.hpp
include/boost/lexical_cast/bad_lexical_cast.hpp
include/boost/lexical_cast/detail/converter_lexical.hpp
@@ -6554,6 +6545,7 @@ include/boost/math/special_functions/detail/ibeta_inverse.hpp
include/boost/math/special_functions/detail/iconv.hpp
include/boost/math/special_functions/detail/igamma_inverse.hpp
include/boost/math/special_functions/detail/igamma_large.hpp
+include/boost/math/special_functions/detail/lambert_w_lookup_table.ipp
include/boost/math/special_functions/detail/lanczos_sse2.hpp
include/boost/math/special_functions/detail/lgamma_small.hpp
include/boost/math/special_functions/detail/polygamma.hpp
@@ -6584,6 +6576,7 @@ include/boost/math/special_functions/hypot.hpp
include/boost/math/special_functions/jacobi_elliptic.hpp
include/boost/math/special_functions/jacobi_zeta.hpp
include/boost/math/special_functions/laguerre.hpp
+include/boost/math/special_functions/lambert_w.hpp
include/boost/math/special_functions/lanczos.hpp
include/boost/math/special_functions/legendre.hpp
include/boost/math/special_functions/legendre_stieltjes.hpp
@@ -6611,6 +6604,7 @@ include/boost/math/special_functions/ulp.hpp
include/boost/math/special_functions/zeta.hpp
include/boost/math/tools/atomic.hpp
include/boost/math/tools/big_constant.hpp
+include/boost/math/tools/complex.hpp
include/boost/math/tools/config.hpp
include/boost/math/tools/convert_from_string.hpp
include/boost/math/tools/detail/polynomial_horner1_10.hpp
@@ -6739,6 +6733,7 @@ include/boost/math/tools/real_cast.hpp
include/boost/math/tools/roots.hpp
include/boost/math/tools/series.hpp
include/boost/math/tools/stats.hpp
+include/boost/math/tools/test_value.hpp
include/boost/math/tools/toms748_solve.hpp
include/boost/math/tools/traits.hpp
include/boost/math/tools/tuple.hpp
@@ -7166,7 +7161,6 @@ include/boost/mpi/python/config.hpp
include/boost/mpi/python/serialize.hpp
include/boost/mpi/python/skeleton_and_content.hpp
include/boost/mpi/request.hpp
-include/boost/mpi/seq.hpp
include/boost/mpi/skeleton_and_content.hpp
include/boost/mpi/skeleton_and_content_fwd.hpp
include/boost/mpi/status.hpp
@@ -8273,6 +8267,7 @@ include/boost/msm/proto_config.hpp
include/boost/msm/row_tags.hpp
include/boost/multi_array.hpp
include/boost/multi_array/algorithm.hpp
+include/boost/multi_array/allocators.hpp
include/boost/multi_array/base.hpp
include/boost/multi_array/collection_concept.hpp
include/boost/multi_array/concept_checks.hpp
@@ -8348,6 +8343,7 @@ include/boost/multi_index/hashed_index_fwd.hpp
include/boost/multi_index/identity.hpp
include/boost/multi_index/identity_fwd.hpp
include/boost/multi_index/indexed_by.hpp
+include/boost/multi_index/key.hpp
include/boost/multi_index/key_extractors.hpp
include/boost/multi_index/mem_fun.hpp
include/boost/multi_index/member.hpp
@@ -8402,6 +8398,7 @@ include/boost/multiprecision/detail/min_max.hpp
include/boost/multiprecision/detail/no_et_ops.hpp
include/boost/multiprecision/detail/number_base.hpp
include/boost/multiprecision/detail/number_compare.hpp
+include/boost/multiprecision/detail/precision.hpp
include/boost/multiprecision/detail/rebind.hpp
include/boost/multiprecision/detail/ublas_interop.hpp
include/boost/multiprecision/detail/utype_helper.hpp
@@ -8423,6 +8420,7 @@ include/boost/multiprecision/traits/extract_exponent_type.hpp
include/boost/multiprecision/traits/is_backend.hpp
include/boost/multiprecision/traits/is_byte_container.hpp
include/boost/multiprecision/traits/is_restricted_conversion.hpp
+include/boost/multiprecision/traits/is_variable_precision.hpp
include/boost/next_prior.hpp
include/boost/non_type.hpp
include/boost/noncopyable.hpp
@@ -8777,7 +8775,6 @@ include/boost/pending/integer_log2.hpp
include/boost/pending/is_heap.hpp
include/boost/pending/iterator_adaptors.hpp
include/boost/pending/iterator_tests.hpp
-include/boost/pending/lowest_bit.hpp
include/boost/pending/mutable_heap.hpp
include/boost/pending/mutable_queue.hpp
include/boost/pending/property.hpp
@@ -10670,6 +10667,31 @@ include/boost/regex/v4/u32regex_iterator.hpp
include/boost/regex/v4/u32regex_token_iterator.hpp
include/boost/regex/v4/w32_regex_traits.hpp
include/boost/regex_fwd.hpp
+include/boost/safe_numerics/automatic.hpp
+include/boost/safe_numerics/checked_default.hpp
+include/boost/safe_numerics/checked_float.hpp
+include/boost/safe_numerics/checked_integer.hpp
+include/boost/safe_numerics/checked_result.hpp
+include/boost/safe_numerics/checked_result_operations.hpp
+include/boost/safe_numerics/concept/exception_policy.hpp
+include/boost/safe_numerics/concept/integer.hpp
+include/boost/safe_numerics/concept/numeric.hpp
+include/boost/safe_numerics/concept/promotion_policy.hpp
+include/boost/safe_numerics/concept/safe_numeric.hpp
+include/boost/safe_numerics/cpp.hpp
+include/boost/safe_numerics/exception.hpp
+include/boost/safe_numerics/exception_policies.hpp
+include/boost/safe_numerics/interval.hpp
+include/boost/safe_numerics/native.hpp
+include/boost/safe_numerics/range_value.hpp
+include/boost/safe_numerics/safe_base.hpp
+include/boost/safe_numerics/safe_base_operations.hpp
+include/boost/safe_numerics/safe_common.hpp
+include/boost/safe_numerics/safe_compare.hpp
+include/boost/safe_numerics/safe_integer.hpp
+include/boost/safe_numerics/safe_integer_literal.hpp
+include/boost/safe_numerics/safe_integer_range.hpp
+include/boost/safe_numerics/utility.hpp
include/boost/scope_exit.hpp
include/boost/scoped_array.hpp
include/boost/scoped_ptr.hpp
@@ -10759,28 +10781,6 @@ include/boost/serialization/wrapper.hpp
include/boost/shared_array.hpp
include/boost/shared_container_iterator.hpp
include/boost/shared_ptr.hpp
-include/boost/signal.hpp
-include/boost/signals.hpp
-include/boost/signals/connection.hpp
-include/boost/signals/detail/config.hpp
-include/boost/signals/detail/named_slot_map.hpp
-include/boost/signals/detail/signal_base.hpp
-include/boost/signals/detail/signals_common.hpp
-include/boost/signals/detail/slot_call_iterator.hpp
-include/boost/signals/signal0.hpp
-include/boost/signals/signal1.hpp
-include/boost/signals/signal10.hpp
-include/boost/signals/signal2.hpp
-include/boost/signals/signal3.hpp
-include/boost/signals/signal4.hpp
-include/boost/signals/signal5.hpp
-include/boost/signals/signal6.hpp
-include/boost/signals/signal7.hpp
-include/boost/signals/signal8.hpp
-include/boost/signals/signal9.hpp
-include/boost/signals/signal_template.hpp
-include/boost/signals/slot.hpp
-include/boost/signals/trackable.hpp
include/boost/signals2.hpp
include/boost/signals2/connection.hpp
include/boost/signals2/deconstruct.hpp
@@ -11479,9 +11479,6 @@ include/boost/spirit/home/support/detail/lexer/state_machine.hpp
include/boost/spirit/home/support/detail/lexer/string_token.hpp
include/boost/spirit/home/support/detail/make_cons.hpp
include/boost/spirit/home/support/detail/make_vector.hpp
-include/boost/spirit/home/support/detail/math/detail/fp_traits.hpp
-include/boost/spirit/home/support/detail/math/fpclassify.hpp
-include/boost/spirit/home/support/detail/math/signbit.hpp
include/boost/spirit/home/support/detail/pow10.hpp
include/boost/spirit/home/support/detail/scoped_enum_emulation.hpp
include/boost/spirit/home/support/detail/sign.hpp
@@ -12074,8 +12071,11 @@ include/boost/swap.hpp
include/boost/system/api_config.hpp
include/boost/system/config.hpp
include/boost/system/cygwin_error.hpp
-include/boost/system/detail/error_code.ipp
-include/boost/system/detail/local_free_on_destruction.hpp
+include/boost/system/detail/config.hpp
+include/boost/system/detail/generic_category.hpp
+include/boost/system/detail/std_interoperability.hpp
+include/boost/system/detail/system_category_posix.hpp
+include/boost/system/detail/system_category_win32.hpp
include/boost/system/error_code.hpp
include/boost/system/linux_error.hpp
include/boost/system/system_error.hpp
@@ -12227,7 +12227,6 @@ include/boost/test/utils/runtime/modifier.hpp
include/boost/test/utils/runtime/parameter.hpp
include/boost/test/utils/setcolor.hpp
include/boost/test/utils/string_cast.hpp
-include/boost/test/utils/trivial_singleton.hpp
include/boost/test/utils/wrap_stringstream.hpp
include/boost/test/utils/xml_printer.hpp
include/boost/thread.hpp
@@ -12290,6 +12289,7 @@ include/boost/thread/detail/thread.hpp
include/boost/thread/detail/thread_group.hpp
include/boost/thread/detail/thread_heap_alloc.hpp
include/boost/thread/detail/thread_interruption.hpp
+include/boost/thread/detail/thread_safety.hpp
include/boost/thread/detail/tss_hooks.hpp
include/boost/thread/detail/variadic_footer.hpp
include/boost/thread/detail/variadic_header.hpp
@@ -12556,16 +12556,23 @@ include/boost/type_traits/detail/ice_and.hpp
include/boost/type_traits/detail/ice_eq.hpp
include/boost/type_traits/detail/ice_not.hpp
include/boost/type_traits/detail/ice_or.hpp
+include/boost/type_traits/detail/is_function_cxx_03.hpp
+include/boost/type_traits/detail/is_function_cxx_11.hpp
+include/boost/type_traits/detail/is_function_msvc10_fix.hpp
include/boost/type_traits/detail/is_function_ptr_helper.hpp
include/boost/type_traits/detail/is_function_ptr_tester.hpp
include/boost/type_traits/detail/is_likely_lambda.hpp
include/boost/type_traits/detail/is_mem_fun_pointer_impl.hpp
include/boost/type_traits/detail/is_mem_fun_pointer_tester.hpp
+include/boost/type_traits/detail/is_member_function_pointer_cxx_03.hpp
+include/boost/type_traits/detail/is_member_function_pointer_cxx_11.hpp
+include/boost/type_traits/detail/is_rvalue_reference_msvc10_fix.hpp
include/boost/type_traits/detail/mp_defer.hpp
include/boost/type_traits/detail/template_arity_spec.hpp
include/boost/type_traits/detail/yes_no_type.hpp
include/boost/type_traits/detected.hpp
include/boost/type_traits/detected_or.hpp
+include/boost/type_traits/enable_if.hpp
include/boost/type_traits/extent.hpp
include/boost/type_traits/floating_point_promotion.hpp
include/boost/type_traits/function_traits.hpp
@@ -12658,6 +12665,7 @@ include/boost/type_traits/is_lvalue_reference.hpp
include/boost/type_traits/is_member_function_pointer.hpp
include/boost/type_traits/is_member_object_pointer.hpp
include/boost/type_traits/is_member_pointer.hpp
+include/boost/type_traits/is_noncopyable.hpp
include/boost/type_traits/is_nothrow_move_assignable.hpp
include/boost/type_traits/is_nothrow_move_constructible.hpp
include/boost/type_traits/is_nothrow_swappable.hpp
@@ -12697,6 +12705,7 @@ include/boost/type_traits/same_traits.hpp
include/boost/type_traits/transform_traits.hpp
include/boost/type_traits/type_identity.hpp
include/boost/type_traits/type_with_alignment.hpp
+include/boost/typeof/constant.hpp
include/boost/typeof/decltype.hpp
include/boost/typeof/dmc/typeof_impl.hpp
include/boost/typeof/encode_decode.hpp
@@ -13648,9 +13657,6 @@ lib/libboost_regex.so.%%BOOST_SHARED_LIB_VER%%
lib/libboost_serialization.a
lib/libboost_serialization.so
lib/libboost_serialization.so.%%BOOST_SHARED_LIB_VER%%
-lib/libboost_signals.a
-lib/libboost_signals.so
-lib/libboost_signals.so.%%BOOST_SHARED_LIB_VER%%
lib/libboost_stacktrace_addr2line.a
lib/libboost_stacktrace_addr2line.so
lib/libboost_stacktrace_addr2line.so.%%BOOST_SHARED_LIB_VER%%