aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-python-libs
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2012-11-20 11:12:25 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2012-11-20 11:12:25 +0000
commit30dd59bf09703deb7cb5f0a6843500f0c1c0f49b (patch)
treed279b76c7b7172fb334f0221921e873e6a80f7f7 /devel/boost-python-libs
parentfc4331579f320269ff44d409b21fc88a8409cebf (diff)
downloadports-30dd59bf09703deb7cb5f0a6843500f0c1c0f49b.tar.gz
ports-30dd59bf09703deb7cb5f0a6843500f0c1c0f49b.zip
Notes
Diffstat (limited to 'devel/boost-python-libs')
-rw-r--r--devel/boost-python-libs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index 03fe4879bbce..ab32735afab1 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -9,7 +9,7 @@ PORTNAME= boost-python-libs
COMMENT= Framework for interfacing Python and C++
USE_BZIP2= yes
-USE_PYTHON= 2.5-3.1
+USE_PYTHON= yes
OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
DEBUG "Build debugging symbols" off \
@@ -35,7 +35,7 @@ BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
post-patch: customize-boost-build
do-build:
- ${ECHO_CMD} "using python : " ${PYTHON_VER} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
+ ${ECHO_CMD} "using python : " ${PYTHON_VER} " : " ${PYTHON_CMD} " : " ${PYTHON_INCLUDEDIR} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
# build the library
cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\