aboutsummaryrefslogtreecommitdiff
path: root/devel/boost
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2006-07-20 19:18:30 +0000
committerSimon Barner <barner@FreeBSD.org>2006-07-20 19:18:30 +0000
commit9449dc499560be14e7a4793708b669716586de8b (patch)
tree5cd9d2a94f194b9e0ceb0aac3563ed967b3c9943 /devel/boost
parenteba28cfd74bcd6ee1a8cf54d9cfcbc5f35d36cc2 (diff)
Notes
Diffstat (limited to 'devel/boost')
-rw-r--r--devel/boost/Makefile12
-rw-r--r--devel/boost/files/patch-libs_random_random_device.cpp20
-rw-r--r--devel/boost/pkg-descr2
-rw-r--r--devel/boost/pkg-plist2
4 files changed, 34 insertions, 2 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index 6519d4157cff..f5a3466576de 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -7,6 +7,7 @@
PORTNAME= boost
PORTVERSION= 1.33.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:boost_site,spirit_site/}
MASTER_SITE_SUBDIR=boost/:boost_site
@@ -282,6 +283,17 @@ do-build:
"-sTOOLS=${BOOST_TOOLS}" "-sBUILD=${BJAM_BUILD}"\
${BOOST_STL_OPTS} ${BOOST_ICU_OPTS}
+# build bgl-viz library
+ cd ${WRKSRC}/libs/graph/build && \
+ ${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\
+ "-sTOOLS=${BOOST_TOOLS}" "-sBUILD=${BJAM_BUILD}"\
+ ${BOOST_STL_OPTS} ${BOOST_ICU_OPTS}
+
+# build random device code
+ cd ${WRKSRC}/libs/random && \
+ ${CXX} ${CXXCFLAGS} ${CFLAGS} -c -I${WRKSRC} random_device.cpp && \
+ ${AR} rc ${WRKSRC}/bin/boost/libs/libboost_random.a random_device.o
+
# Build pyste, the Boost.Python code generator
.if defined(WITH_PYSTE)
cd ${BUILD_WRKSRC}/libs/python/pyste/install && \
diff --git a/devel/boost/files/patch-libs_random_random_device.cpp b/devel/boost/files/patch-libs_random_random_device.cpp
new file mode 100644
index 000000000000..0e0dbf9ef166
--- /dev/null
+++ b/devel/boost/files/patch-libs_random_random_device.cpp
@@ -0,0 +1,20 @@
+--- libs/random/random_device.cpp.orig Tue Jul 18 12:48:49 2006
++++ libs/random/random_device.cpp Tue Jul 18 12:49:59 2006
+@@ -22,7 +22,7 @@
+ #endif
+
+
+-#ifdef __linux__
++#if defined(__linux__) || defined (__FreeBSD__)
+
+ // the default is the unlimited capacity device, using some secure hash
+ // try "/dev/random" for blocking when the entropy pool has drained
+@@ -90,7 +90,7 @@
+ int fd;
+ };
+
+-#endif // __linux__
++#endif // __linux__ || __FreeBSD__
+
+
+ boost::random_device::random_device(const std::string& token)
diff --git a/devel/boost/pkg-descr b/devel/boost/pkg-descr
index 5416f7cfd73a..e9e5f7fa6277 100644
--- a/devel/boost/pkg-descr
+++ b/devel/boost/pkg-descr
@@ -7,5 +7,3 @@ already been proposed for inclusion in the C++ Standards Committee's
upcoming C++ Standard Library Technical Report.
WWW: http://www.boost.org/
-
--- Paul Marquis <pmarquis@pobox.com>
diff --git a/devel/boost/pkg-plist b/devel/boost/pkg-plist
index 5e4657780e51..dc5120e59383 100644
--- a/devel/boost/pkg-plist
+++ b/devel/boost/pkg-plist
@@ -3366,6 +3366,7 @@ lib/libboost_date_time.so.3
lib/libboost_filesystem.a
lib/libboost_filesystem.so
lib/libboost_filesystem.so.3
+lib/libbgl-viz.a
lib/libboost_prg_exec_monitor.a
lib/libboost_prg_exec_monitor.so
lib/libboost_prg_exec_monitor.so.3
@@ -3378,6 +3379,7 @@ lib/libboost_program_options.so.3
lib/libboost_iostreams.a
lib/libboost_iostreams.so
lib/libboost_iostreams.so.3
+lib/libboost_random.a
lib/libboost_regex.a
lib/libboost_regex.so
lib/libboost_regex.so.3