aboutsummaryrefslogtreecommitdiff
path: root/devel/boost
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-03-21 18:04:49 +0000
committerSimon Barner <barner@FreeBSD.org>2005-03-21 18:04:49 +0000
commit72058ac597c1708fdbd0eaf870c3307ef945933a (patch)
tree7b76b78b8facef37c86a0998cd2e24486722e05a /devel/boost
parentb63effc0bcbfb8827103865658b56ca18c1095df (diff)
- Don't install symlinks to shared libraries that are not installed.
Specifically, this is about the !WITH_PYTHON and !WITH_THREADS cases. - This fixes the plist again. Reported by: kris via pointyhat Approved by: arved (mentor)
Notes
Notes: svn path=/head/; revision=131853
Diffstat (limited to 'devel/boost')
-rw-r--r--devel/boost/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/boost/Makefile b/devel/boost/Makefile
index d428adb4a1a2..e57da1f2f1b8 100644
--- a/devel/boost/Makefile
+++ b/devel/boost/Makefile
@@ -32,8 +32,7 @@ OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
UNIQ= /usr/bin/uniq
BOOST_LIBS= date_time filesystem prg_exec_monitor program_options \
- python regex signals test_exec_monitor thread \
- unit_test_framework
+ regex signals test_exec_monitor unit_test_framework
BOOST_SHARED_LIB_VER= 2
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -61,6 +60,7 @@ MAKE_ENV+= PYTHON_ROOT="${LOCALBASE}"\
PYTHON_VERSION="${PYTHON_VERSION}"\
PYTHON_INCLUDES="${PYTHON_INCLUDEDIR}"\
PYTHON_LIB_PATH="${PYTHON_LIBDIR}"
+BOOST_LIBS+= python
.if defined(WITH_PYSTE)
RUN_DEPENDS+= gccxml:${PORTSDIR}/devel/gccxml \
${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
@@ -129,6 +129,7 @@ PLIST_SUB+= BOOST_THREADS="@comment "
.else
BJAM_BUILD+= <threading>multi
PLIST_SUB+= BOOST_THREADS=""
+BOOST_LIBS+= thread
.endif
.if defined (WITHOUT_OPTIMIZED_CFLAGS)