aboutsummaryrefslogtreecommitdiff
path: root/devel/bsdbuild/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-02-28 13:18:48 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-02-28 13:18:48 +0000
commitbce91b5e80cf9cd1e62a7522c949bbd698b0d624 (patch)
tree416f9b9bda5b1ecd19bf354bc8984e6054af632c /devel/bsdbuild/Makefile
parentacf9c9450db1bae749a388be3b87e94486efb443 (diff)
downloadports-bce91b5e80cf9cd1e62a7522c949bbd698b0d624.tar.gz
ports-bce91b5e80cf9cd1e62a7522c949bbd698b0d624.zip
Notes
Diffstat (limited to 'devel/bsdbuild/Makefile')
-rw-r--r--devel/bsdbuild/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/bsdbuild/Makefile b/devel/bsdbuild/Makefile
new file mode 100644
index 000000000000..36c96587cda8
--- /dev/null
+++ b/devel/bsdbuild/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: bsdbuild
+# Date created: 2011-02-28
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdbuild
+PORTVERSION= 2.8
+CATEGORIES= devel
+MASTER_SITES= http://stable.hypertriton.com/bsdbuild/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= BSD-licensed portable build system
+
+USE_PERL= yes
+GNU_CONFIGURE= yes
+
+LICENSE= BSD
+
+CONFIGURE_ARGS= --with-catman=no
+
+MAN1= uman.1 \
+ man2mediawiki.1 \
+ man2wiki.1 \
+ mkconfigure.1 \
+ mkify.1
+
+MAN5= build.www.mk.5 \
+ build.proj.mk.5 \
+ build.prog.mk.5 \
+ build.lib.mk.5 \
+ build.dep.mk.5 \
+ build.den.mk.5 \
+ build.common.mk.5
+
+.include <bsd.port.mk>