aboutsummaryrefslogtreecommitdiff
path: root/devel/bug-buddy
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-04-10 05:56:28 +0000
commitae52bc80895a23ddbe33b86e75a9cf331ae32ba9 (patch)
tree5538a7d3541f6d56e4bbab9c6329f5b9db64dafb /devel/bug-buddy
parent7934df773e0cc2a9924de75dd7cad9cc3d79d4ee (diff)
Notes
Diffstat (limited to 'devel/bug-buddy')
-rw-r--r--devel/bug-buddy/Makefile4
-rw-r--r--devel/bug-buddy/distinfo6
-rw-r--r--devel/bug-buddy/files/patch-gnome-breakpad_gnome-breakpad.cc37
-rw-r--r--devel/bug-buddy/pkg-plist11
4 files changed, 25 insertions, 33 deletions
diff --git a/devel/bug-buddy/Makefile b/devel/bug-buddy/Makefile
index 5362c457bcf7..c38fb093c727 100644
--- a/devel/bug-buddy/Makefile
+++ b/devel/bug-buddy/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/bug-buddy/Makefile,v 1.71 2008/11/25 17:43:11 mezz Exp $
+# $MCom: ports/devel/bug-buddy/Makefile,v 1.74 2009/03/18 00:35:01 kwm Exp $
#
PORTNAME= bug-buddy
-PORTVERSION= 2.24.2
+PORTVERSION= 2.26.0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/devel/bug-buddy/distinfo b/devel/bug-buddy/distinfo
index b4d410c17103..a00a22b53d8d 100644
--- a/devel/bug-buddy/distinfo
+++ b/devel/bug-buddy/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/bug-buddy-2.24.2.tar.bz2) = faeeb2351398b9284eee794ff6ea9588
-SHA256 (gnome2/bug-buddy-2.24.2.tar.bz2) = d64125505546183d44727e812b0ac7e9c60f0fff0eaf164b874974647067cbb4
-SIZE (gnome2/bug-buddy-2.24.2.tar.bz2) = 1109562
+MD5 (gnome2/bug-buddy-2.26.0.tar.bz2) = f92663a1a819f83e3eb3004f9e8a687a
+SHA256 (gnome2/bug-buddy-2.26.0.tar.bz2) = 91780659fb3f360ed2f2b0804ceb619d9cbc7754115bf50f442bdd2c7dca224c
+SIZE (gnome2/bug-buddy-2.26.0.tar.bz2) = 1051956
diff --git a/devel/bug-buddy/files/patch-gnome-breakpad_gnome-breakpad.cc b/devel/bug-buddy/files/patch-gnome-breakpad_gnome-breakpad.cc
index 801be10640bf..7007a9101cb3 100644
--- a/devel/bug-buddy/files/patch-gnome-breakpad_gnome-breakpad.cc
+++ b/devel/bug-buddy/files/patch-gnome-breakpad_gnome-breakpad.cc
@@ -1,6 +1,6 @@
---- gnome-breakpad/gnome-breakpad.cc.orig 2007-08-16 13:55:38.000000000 -0400
-+++ gnome-breakpad/gnome-breakpad.cc 2007-09-02 19:21:10.000000000 -0400
-@@ -6,8 +6,14 @@
+--- gnome-breakpad/gnome-breakpad.cc.orig 2009-02-16 15:24:48.000000000 +0100
++++ gnome-breakpad/gnome-breakpad.cc 2009-02-22 16:25:50.000000000 +0100
+@@ -25,8 +25,14 @@
#include <cassert>
#include <cstring>
@@ -15,15 +15,15 @@
#include <sys/types.h>
#include <sys/stat.h>
-@@ -114,6 +120,7 @@ find_in_debug_path (const char *filename
+@@ -264,6 +270,7 @@ find_in_debug_path (const char *filename
}
-
+
+#if !defined(__FreeBSD__) || __FreeBSD_version > 700024
static gboolean
elf_has_debug_symbols (const char *filename)
{
-@@ -166,7 +173,7 @@ elf_has_debug_symbols (const char *filen
+@@ -316,7 +323,7 @@ elf_has_debug_symbols (const char *filen
elf_end (elf);
return false;
}
@@ -32,21 +32,24 @@
-@@ -269,9 +276,17 @@ check_if_gdb (void *callback_context)
+@@ -429,11 +436,18 @@ check_if_gdb ()
+ _exit (1);
_exit(0);
}
-
-+#if !defined(__FreeBSD__) || __FreeBSD_version > 700024
- memset(mypath, 0, sizeof(mypath));
-+#ifndef __FreeBSD__
- readlink ("/proc/self/exe", mypath, sizeof(mypath));
+-
++
++#if !defined(__FreeBSD__)
+ mypath = g_file_read_link ("/proc/self/exe", NULL);
+#else
-+ readlink ("/proc/curproc/file", mypath, sizeof(mypath));
++ mypath = g_file_read_link ("/proc/curproc/file", NULL);
+#endif
- has_debug_symbols = elf_has_debug_symbols (mypath);
-+#else
-+ has_debug_symbols = TRUE;
+ if (mypath)
++#if !defined(__FreeBSD__) || __FreeBSD_version > 700024
+ has_debug_symbols = elf_has_debug_symbols (mypath);
+-
++#else
++ has_debug_symbols = TRUE;
+#endif
-
+ g_free (mypath);
if (bugbuddy && gdb && has_debug_symbols) {
diff --git a/devel/bug-buddy/pkg-plist b/devel/bug-buddy/pkg-plist
index 7655acd7ebcb..641480473ee2 100644
--- a/devel/bug-buddy/pkg-plist
+++ b/devel/bug-buddy/pkg-plist
@@ -4,14 +4,6 @@ lib/gtk-2.0/modules/libgnomebreakpad.so
share/applications/bug-buddy.desktop
%%DATADIR%%/bug-buddy.gtkbuilder
%%DATADIR%%/bug-buddy.menu
-%%DATADIR%%/bugzilla/gnome.bugzilla
-%%DATADIR%%/bugzilla/gnome/config
-%%DATADIR%%/bugzilla/gnome/mostfreq
-%%DATADIR%%/bugzilla/gnome/products
-%%DATADIR%%/bugzilla/ximian.bugzilla
-%%DATADIR%%/bugzilla/ximian/config
-%%DATADIR%%/bugzilla/ximian/mostfreq
-%%DATADIR%%/bugzilla/ximian/products
%%DATADIR%%/gdb-cmd
share/icons/HighContrastLargePrint/48x48/apps/bug-buddy.png
share/icons/hicolor/16x16/apps/bug-buddy.png
@@ -107,9 +99,6 @@ share/locale/zh_TW/LC_MESSAGES/bug-buddy.mo
@dirrmtry share/icons/HighContrastLargePrint/48x48/apps
@dirrmtry share/icons/HighContrastLargePrint/48x48
@dirrmtry share/icons/HighContrastLargePrint
-@dirrm %%DATADIR%%/bugzilla/ximian
-@dirrm %%DATADIR%%/bugzilla/gnome
-@dirrm %%DATADIR%%/bugzilla
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES