aboutsummaryrefslogtreecommitdiff
path: root/devel/bugbuddy2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-15 03:50:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-15 03:50:09 +0000
commit0d4f65750d96d0d9069ccf756e7c08441a937b67 (patch)
tree3e9a5e1e989b4e7787e4f02096962d55964938e0 /devel/bugbuddy2
parent529073a9e6d848a4b8640189dc294805cb87c7bf (diff)
downloadports-0d4f65750d96d0d9069ccf756e7c08441a937b67.tar.gz
ports-0d4f65750d96d0d9069ccf756e7c08441a937b67.zip
Notes
Diffstat (limited to 'devel/bugbuddy2')
-rw-r--r--devel/bugbuddy2/Makefile17
-rw-r--r--devel/bugbuddy2/distinfo2
-rw-r--r--devel/bugbuddy2/files/patch-ad8
-rw-r--r--devel/bugbuddy2/files/patch-configure37
-rw-r--r--devel/bugbuddy2/files/patch-po::Makefile.in.in12
-rw-r--r--devel/bugbuddy2/pkg-comment2
-rw-r--r--devel/bugbuddy2/pkg-plist62
7 files changed, 32 insertions, 108 deletions
diff --git a/devel/bugbuddy2/Makefile b/devel/bugbuddy2/Makefile
index 323fe558b701..f09f2b936b73 100644
--- a/devel/bugbuddy2/Makefile
+++ b/devel/bugbuddy2/Makefile
@@ -1,26 +1,29 @@
-# New ports collection makefile for: bugbuddy
-# Date created: 23rd February 2000
-# Whom: Ade Lovett <ade@FreeBSD.org>
+# New ports collection makefile for: bugbuddy2
+# Date created: 14 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= bugbuddy
-PORTVERSION= 2.0.8
-PORTREVISION= 1
+PORTVERSION= 2.1.5
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/bug-buddy
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020509
DISTNAME= bug-buddy-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui
+
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/devel/bugbuddy2/distinfo b/devel/bugbuddy2/distinfo
index 75f64e7dfb4f..094b83278714 100644
--- a/devel/bugbuddy2/distinfo
+++ b/devel/bugbuddy2/distinfo
@@ -1 +1 @@
-MD5 (bug-buddy-2.0.8.tar.gz) = 1bb7ec7386cb7f34c2ff4fb8d58cdac4
+MD5 (bug-buddy-2.1.5.tar.gz) = c604da57a1194dba0477a123d9e3c6b3
diff --git a/devel/bugbuddy2/files/patch-ad b/devel/bugbuddy2/files/patch-ad
deleted file mode 100644
index c9c2e2d68103..000000000000
--- a/devel/bugbuddy2/files/patch-ad
+++ /dev/null
@@ -1,8 +0,0 @@
---- docs/app-docs.make.orig Mon Apr 17 06:28:43 2000
-+++ docs/app-docs.make Fri Apr 21 12:15:52 2000
-@@ -1,4 +1,4 @@
--helpdir = $(datadir)/gnome/help/$(app)/$(lang)
-+helpdir = $(datadir)/help/$(app)/$(lang)
- help_DATA = \
- index.html \
- topic.dat \
diff --git a/devel/bugbuddy2/files/patch-configure b/devel/bugbuddy2/files/patch-configure
index 76e04f71c15f..f3505cd6e26d 100644
--- a/devel/bugbuddy2/files/patch-configure
+++ b/devel/bugbuddy2/files/patch-configure
@@ -1,35 +1,10 @@
---- configure.orig Fri Jun 15 10:20:23 2001
-+++ configure Tue Jun 19 05:49:49 2001
-@@ -5679,2 +5679,19 @@
+--- configure.orig Tue May 14 23:25:15 2002
++++ configure Tue May 14 23:25:40 2002
+@@ -6203,6 +6203,7 @@
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-+
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5682,3 +5699,3 @@
# This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-@@ -5686,2 +5703,7 @@
+ # Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+
-+# Redirect the config.log output again, so that the ltconfig log is not
-+# clobbered by the next message.
-+exec 5>>./config.log
-+
-
diff --git a/devel/bugbuddy2/files/patch-po::Makefile.in.in b/devel/bugbuddy2/files/patch-po::Makefile.in.in
deleted file mode 100644
index 27f3358e04a0..000000000000
--- a/devel/bugbuddy2/files/patch-po::Makefile.in.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- po/Makefile.in.in.orig Fri Jun 15 10:20:15 2001
-+++ po/Makefile.in.in Tue Jun 19 05:56:13 2001
-@@ -25,3 +25,3 @@
- datadir = @datadir@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gettextsrcdir = $(datadir)/gettext/po
-@@ -108,3 +108,3 @@
- cat=`basename $$cat`; \
-- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
-+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
- dir=$(localedir)/$$lang/LC_MESSAGES; \
diff --git a/devel/bugbuddy2/pkg-comment b/devel/bugbuddy2/pkg-comment
index bf6ab260074b..7acf78530e7c 100644
--- a/devel/bugbuddy2/pkg-comment
+++ b/devel/bugbuddy2/pkg-comment
@@ -1 +1 @@
-A bug reporting tool for GNOME
+A bug reporting tool for GNOME 2.0
diff --git a/devel/bugbuddy2/pkg-plist b/devel/bugbuddy2/pkg-plist
index 2e9a40bec201..6cb678148d5d 100644
--- a/devel/bugbuddy2/pkg-plist
+++ b/devel/bugbuddy2/pkg-plist
@@ -1,57 +1,23 @@
bin/bug-buddy
-share/gnome/apps/Utilities/bug-buddy.desktop
-share/gnome/bug-buddy/bug-anim.png
+share/gnome/applications/bug-buddy.desktop
share/gnome/bug-buddy/bug-buddy.glade
share/gnome/bug-buddy/bug-buddy.png
-share/gnome/bug-buddy/bug-core.png
-share/gnome/bug-buddy/bug-flower.png
share/gnome/bug-buddy/bugzilla/gnome.bugzilla
share/gnome/bug-buddy/bugzilla/gnome/config
+share/gnome/bug-buddy/bugzilla/gnome/mostfreq
share/gnome/bug-buddy/bugzilla/gnome/products
-share/gnome/bug-buddy/bugzilla/ximian.bugzilla
+share/gnome/bug-buddy/bugzilla/ximian.bugzilla
share/gnome/bug-buddy/bugzilla/ximian/config
+share/gnome/bug-buddy/bugzilla/ximian/mostfreq
share/gnome/bug-buddy/bugzilla/ximian/products
share/gnome/bug-buddy/gdb-cmd
share/gnome/bug-buddy/gnome.png
share/gnome/bug-buddy/ximian.png
-share/gnome/help/bug-buddy/C/authors.html
-share/gnome/help/bug-buddy/C/bugs.html
-share/gnome/help/bug-buddy/C/component.html
-share/gnome/help/bug-buddy/C/contact-info.html
-share/gnome/help/bug-buddy/C/debug-info.html
-share/gnome/help/bug-buddy/C/description.html
-share/gnome/help/bug-buddy/C/docbook.css
-share/gnome/help/bug-buddy/C/index.html
-share/gnome/help/bug-buddy/C/license.html
-share/gnome/help/bug-buddy/C/ln10.html
-share/gnome/help/bug-buddy/C/product.html
-share/gnome/help/bug-buddy/C/stylesheet-images/caution.png
-share/gnome/help/bug-buddy/C/stylesheet-images/important.png
-share/gnome/help/bug-buddy/C/stylesheet-images/note.png
-share/gnome/help/bug-buddy/C/stylesheet-images/tip.png
-share/gnome/help/bug-buddy/C/stylesheet-images/warning.png
-share/gnome/help/bug-buddy/C/submit-report.html
-share/gnome/help/bug-buddy/C/summary.html
-share/gnome/help/bug-buddy/C/updating.html
-share/gnome/help/bug-buddy/it/authors.html
-share/gnome/help/bug-buddy/it/bugs.html
-share/gnome/help/bug-buddy/it/collect-debug-info.html
-share/gnome/help/bug-buddy/it/contact-info.html
-share/gnome/help/bug-buddy/it/debug-info.html
-share/gnome/help/bug-buddy/it/description.html
-share/gnome/help/bug-buddy/it/index.html
-share/gnome/help/bug-buddy/it/ln13.html
-share/gnome/help/bug-buddy/it/report-info.html
-share/gnome/help/bug-buddy/it/stylesheet-images/caution.png
-share/gnome/help/bug-buddy/it/stylesheet-images/important.png
-share/gnome/help/bug-buddy/it/stylesheet-images/note.png
-share/gnome/help/bug-buddy/it/stylesheet-images/tip.png
-share/gnome/help/bug-buddy/it/stylesheet-images/warning.png
-share/gnome/help/bug-buddy/it/submit-report.html
-share/gnome/help/bug-buddy/it/summary.html
-share/gnome/help/bug-buddy/it/system-config.html
+share/gnome/help/bug-buddy/C/bug-buddy.xml
+share/gnome/help/bug-buddy/C/legal.xml
share/gnome/mime-info/bug-buddy.keys
share/gnome/mime-info/bug-buddy.mime
+share/gnome/omf/gdp-example1/bug-buddy-C.omf
share/gnome/pixmaps/bug-buddy.png
share/locale/az/LC_MESSAGES/bug-buddy.mo
share/locale/ca/LC_MESSAGES/bug-buddy.mo
@@ -59,9 +25,9 @@ share/locale/cs/LC_MESSAGES/bug-buddy.mo
share/locale/da/LC_MESSAGES/bug-buddy.mo
share/locale/de/LC_MESSAGES/bug-buddy.mo
share/locale/el/LC_MESSAGES/bug-buddy.mo
-share/locale/en_AU/LC_MESSAGES/bug-buddy.mo
share/locale/en_GB/LC_MESSAGES/bug-buddy.mo
share/locale/es/LC_MESSAGES/bug-buddy.mo
+share/locale/et/LC_MESSAGES/bug-buddy.mo
share/locale/fi/LC_MESSAGES/bug-buddy.mo
share/locale/fr/LC_MESSAGES/bug-buddy.mo
share/locale/ga/LC_MESSAGES/bug-buddy.mo
@@ -71,10 +37,13 @@ share/locale/it/LC_MESSAGES/bug-buddy.mo
share/locale/ja/LC_MESSAGES/bug-buddy.mo
share/locale/ko/LC_MESSAGES/bug-buddy.mo
share/locale/lt/LC_MESSAGES/bug-buddy.mo
+share/locale/lv/LC_MESSAGES/bug-buddy.mo
+share/locale/ms/LC_MESSAGES/bug-buddy.mo
share/locale/nl/LC_MESSAGES/bug-buddy.mo
share/locale/nn/LC_MESSAGES/bug-buddy.mo
share/locale/no/LC_MESSAGES/bug-buddy.mo
share/locale/pl/LC_MESSAGES/bug-buddy.mo
+share/locale/pt/LC_MESSAGES/bug-buddy.mo
share/locale/pt_BR/LC_MESSAGES/bug-buddy.mo
share/locale/ro/LC_MESSAGES/bug-buddy.mo
share/locale/ru/LC_MESSAGES/bug-buddy.mo
@@ -84,12 +53,9 @@ share/locale/sv/LC_MESSAGES/bug-buddy.mo
share/locale/tr/LC_MESSAGES/bug-buddy.mo
share/locale/uk/LC_MESSAGES/bug-buddy.mo
share/locale/wa/LC_MESSAGES/bug-buddy.mo
-share/locale/zh_CN.GB2312/LC_MESSAGES/bug-buddy.mo
-share/locale/zh_TW.Big5/LC_MESSAGES/bug-buddy.mo
-@dirrm share/gnome/help/bug-buddy/it/stylesheet-images
-@dirrm share/gnome/help/bug-buddy/it/figures
-@dirrm share/gnome/help/bug-buddy/it
-@dirrm share/gnome/help/bug-buddy/C/stylesheet-images
+share/locale/zh_CN/LC_MESSAGES/bug-buddy.mo
+share/locale/zh_TW/LC_MESSAGES/bug-buddy.mo
+@dirrm share/gnome/omf/gdp-example1
@dirrm share/gnome/help/bug-buddy/C/figures
@dirrm share/gnome/help/bug-buddy/C
@dirrm share/gnome/help/bug-buddy