aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla2/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-03-24 15:15:45 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-03-24 15:15:45 +0000
commitc928f4bc0fdeee1f23133ad822d854fcbacd11b3 (patch)
tree24eb54d19b5a758416339223ba244275b6a1ab7a /devel/bugzilla2/Makefile
parent775f41988abb6b9a3d7bf339f7fffdd98f86969d (diff)
downloadports-c928f4bc0fdeee1f23133ad822d854fcbacd11b3.tar.gz
ports-c928f4bc0fdeee1f23133ad822d854fcbacd11b3.zip
Notes
Diffstat (limited to 'devel/bugzilla2/Makefile')
-rw-r--r--devel/bugzilla2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index d086b966ea59..6c263ad1638d 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -35,6 +35,12 @@ RUN_DEPENDS+= ${PERL_SITEDIR}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
RUN_DEPENDS+= ${PERL_SITEDIR}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
.endif
+.if defined(WITH_CONTRIB)
+PLIST_SUB+= CONTRIB=""
+.else
+PLIST_SUB+= CONTRIB="@comment "
+.endif
+
USE_REINPLACE= yes
NO_BUILD= yes
@@ -62,6 +68,10 @@ pre-everything::
@${ECHO_MSG} " export/import feature to move bugs to or from"
@${ECHO_MSG} " other bugzilla installations"
@${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_CONTRIB to install various user-contributed scripts,"
+ @${ECHO_MSG} " e.g. to import bugs from other databases, to
+ @${ECHO_MSG} " allow follow-ups/submissions by e-mail etc."
+ @${ECHO_MSG} ""
post-patch:
@find -d ${WRKSRC} -name CVS -type d -exec ${RM} -rf {} \;
@@ -93,6 +103,19 @@ do-install:
${MKDIR} ${DOCSDIR}
${TAR} -C ${WRKSRC}/docs -cf - . | ${TAR} --unlink -C ${DOCSDIR} -xf -
.endif
+.if defined(WITH_CONTRIB)
+ ${MKDIR} ${BUGZILLADIR}/contrib ${BUGZILLADIR}/contrib/cmdline
+ cd ${WRKSRC}/contrib; ${INSTALL_SCRIPT} BugzillaEmail.pm bug_email.pl \
+ bugzilla_email_append.pl cvs-update.sh gnats2bz.pl jb2bz.py \
+ mysqld-watcher.pl yp_nomail.sh ${BUGZILLADIR}/contrib
+ cd ${WRKSRC}/contrib/cmdline; ${INSTALL_SCRIPT} buglist bugs \
+ query.conf ${BUGZILLADIR}/contrib/cmdline
+.if !defined(NOPORTSDOCS)
+ ${MKDIR} ${DOCSDIR}/contrib
+ cd ${WRKSRC}/contrib; ${INSTALL_DATA} README README.Mailif \
+ bugmail_help.html bugzilla.procmailrc ${DOCSDIR}/contrib
+.endif
+.endif
post-install:
@${SED} -e "s:%%PREFIX%%:${PREFIX}:g" pkg-message >${PKGMESSAGE}