aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla3/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-07-28 16:25:11 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-07-28 16:25:11 +0000
commitd0228223f2d6c913b39cb81f7c25ae67935468e4 (patch)
treea520752426df36344cfdf4d15ff4cdfcb6df63ef /devel/bugzilla3/Makefile
parent3cea2eef383599b28d35a22d201168ba6cfb6208 (diff)
Notes
Diffstat (limited to 'devel/bugzilla3/Makefile')
-rw-r--r--devel/bugzilla3/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 46fcd670386c..e70f5884a9ee 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -37,6 +37,9 @@ SUB_FILES= pkg-message
DATA_DIRS_LIST= images js skins
+# checksetup will fail if these directories are not present!
+EMPTY_DIRS_LIST=data graphs contrib lib t
+
.include "${.CURDIR}/Makefile.common"
.include "${.CURDIR}/Makefile.options"
.include <bsd.port.options.mk>
@@ -166,15 +169,13 @@ do-install: .SILENT
(cd ${WRKSRC}/${D} && ${COPYTREE_SHARE} . ${WWWDIR}/${D})
.endfor
${TAR} -C ${WRKSRC} -cf - Bugzilla template | ${TAR} --unlink -C ${WWWDIR} -xf -
+ @${MKDIR} ${EMPTY_DIRS_LIST:S!^!${WWWDIR}/!}
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC}/docs/ && ${COPYTREE_SHARE} . ${DOCSDIR}/)
.endif
-# checksetup will fail if these directories are not present!
- ${MKDIR} ${WWWDIR}/contrib ${WWWDIR}/lib ${WWWDIR}/t
-
.if ${PORT_OPTIONS:MCONTRIB}
@cd ${WRKSRC}/contrib && \
${FIND} . -type d -exec ${MKDIR} "${WWWDIR}/contrib/{}" \; && \