aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla3
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-29 10:20:00 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-29 10:20:00 +0000
commit47d7ecfddff6aa8af488a1c7a703e2ff85e35678 (patch)
treef2b3b30b5c45fb5a4549ebf72c8df88a3e31e876 /devel/bugzilla3
parent4c44c06b4b67067a59ad9ec9b75e5ed68f89f06e (diff)
downloadports-47d7ecfddff6aa8af488a1c7a703e2ff85e35678.tar.gz
ports-47d7ecfddff6aa8af488a1c7a703e2ff85e35678.zip
Notes
Diffstat (limited to 'devel/bugzilla3')
-rw-r--r--devel/bugzilla3/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index ad9235bb4989..b5e02c50a56c 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -17,7 +17,7 @@ COMMENT= Bug-tracking system developed by Mozilla Project
LICENSE= MPL
RUN_DEPENDS= \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-DBI>=1.41:${PORTSDIR}/databases/p5-DBI \
p5-Template-Toolkit>=2.22:${PORTSDIR}/www/p5-Template-Toolkit \
p5-DateTime>=0.28:${PORTSDIR}/devel/p5-DateTime \
@@ -76,9 +76,9 @@ USE_PGSQL= yes
.ifdef WITH_GRAPH_REPORTS
RUN_DEPENDS+= p5-GD>=1.20:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
- ${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
- ${SITE_PERL}/Template/Plugin/GD/Image.pm:${PORTSDIR}/www/p5-Template-GD
+ p5-GD-Graph>=0:${PORTSDIR}/graphics/p5-GD-Graph \
+ p5-GD-TextUtil>=0:${PORTSDIR}/graphics/p5-GD-TextUtil \
+ p5-Template-GD>=0:${PORTSDIR}/www/p5-Template-GD
.endif
.ifdef WITH_CHARTING_MODULES
@@ -92,12 +92,12 @@ RUN_DEPENDS+= p5-PatchReader>=0.9.4:${PORTSDIR}/devel/p5-PatchReader \
.ifdef WITH_MORE_HTML
RUN_DEPENDS+= p5-HTML-Parser>=3.40:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber
+ p5-HTML-Scrubber>=0:${PORTSDIR}/www/p5-HTML-Scrubber
.endif
.ifdef WITH_INBOUND_EMAIL
-RUN_DEPENDS+= ${SITE_PERL}/Email/MIME/Attachment/Stripper.pm:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
- ${SITE_PERL}/Email/Reply.pm:${PORTSDIR}/mail/p5-Email-Reply
+RUN_DEPENDS+= p5-Email-MIME-Attachment-Stripper>=0:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
+ p5-Email-Reply>=0:${PORTSDIR}/mail/p5-Email-Reply
.endif
.ifdef WITH_MAIL_QUEUEING
@@ -106,12 +106,12 @@ RUN_DEPENDS+= p5-TheSchwartz>=0:${PORTSDIR}/devel/p5-TheSchwartz \
.endif
.ifdef WITH_MOVE_BUGZ
-RUN_DEPENDS+= ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
+RUN_DEPENDS+= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig
.endif
.ifdef WITH_BMP2PNG
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS+= ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick
.endif
.if defined(WITH_XMLRPC) || defined(WITH_JSONRPC)
@@ -119,7 +119,7 @@ RUN_DEPENDS+= p5-Test-Taint>=0:${PORTSDIR}/devel/p5-Test-Taint
.endif
.ifdef WITH_XMLRPC
-RUN_DEPENDS+= ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS+= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
.endif
.ifdef WITH_JSONRPC
@@ -127,8 +127,8 @@ RUN_DEPENDS+= p5-JSON-RPC>=0:${PORTSDIR}/devel/p5-JSON-RPC
.endif
.ifdef WITH_MODPERL2
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
- ${SITE_PERL}/Apache/DBI.pm:${PORTSDIR}/www/p5-Apache-DBI
+RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
+ p5-Apache-DBI>=0:${PORTSDIR}/www/p5-Apache-DBI
.endif
.ifdef WITH_GRAPHVIZ
@@ -136,8 +136,8 @@ RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
.endif
.ifdef WITH_EXPORT_IMPORT
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
+RUN_DEPENDS+= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig
.endif
.ifdef WITH_CONTRIB
@@ -147,7 +147,7 @@ PLIST_SUB+= CONTRIB="@comment "
.endif
.ifdef WITH_LDAP
-RUN_DEPENDS+= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS+= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
.endif
.ifdef WITH_RADIUS