aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-05-28 12:03:47 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-05-28 12:03:47 +0000
commit9cf6f3df33cfa96a85b2c6e80a5fa7e177f839ae (patch)
treea352569f84fe4313b1d29e061a28b09353e3b8e4 /devel/bugzilla
parent4c0bb12d59e4e1464694c215d75ebd5463ea2cc2 (diff)
downloadports-9cf6f3df33cfa96a85b2c6e80a5fa7e177f839ae.tar.gz
ports-9cf6f3df33cfa96a85b2c6e80a5fa7e177f839ae.zip
Notes
Diffstat (limited to 'devel/bugzilla')
-rw-r--r--devel/bugzilla/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 3d98a30d7515..67be6c1b1594 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -77,7 +77,7 @@ USE_PGSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
- ${SITE_PERL}/Template/Plugin/GD/Image:${PORTSDIR}/www/p5-Template-GD
+ ${SITE_PERL}/Template/Plugin/GD/Image.pm:${PORTSDIR}/www/p5-Template-GD
.endif
.ifdef WITH_CHARTING_MODULES
@@ -85,7 +85,8 @@ RUN_DEPENDS+= ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
.endif
.ifdef WITH_PATCH_VIEWER
-RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader
+RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader \
+ interdiff:${PORTSDIR}/misc/patchutils
.endif
.ifdef WITH_MORE_HTML
@@ -95,7 +96,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-P
.ifdef WITH_INBOUND_EMAIL
RUN_DEPENDS+= ${SITE_PERL}/Email/MIME/Attachment/Stripper.pm:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
- ${SITE_PERL}/Email/Reply:${PORTSDIR}/mail/p5-Email-Reply
+ ${SITE_PERL}/Email/Reply.pm:${PORTSDIR}/mail/p5-Email-Reply
.endif
.ifdef WITH_MOVE_BUGZ
@@ -140,8 +141,8 @@ post-patch:
${WRKSRC}/checksetup.pl
@${FIND} ${WRKSRC} \( -name "CVS" -or -name ".cvsignore" -or -name "*.orig" \
-or -name "README.docs" \) | ${XARGS} ${RM} -rf
- @${FIND} ${WRKSRC} -name "*.p[ml]" | \
- ${XARGS} ${REINPLACE_CMD} -i '' -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!'
+ ${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -i '' \
+ -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!g; s=/usr/bin/perl=${PERL}=g' {} \+
do-build:
@${SED} -e "s:%%BUGZILLADIR%%:${BUGZILLADIR}:g; s:%%DOCSDIR%%:${DOCSDIR}:g" \