aboutsummaryrefslogtreecommitdiff
path: root/devel/bugzilla
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-05-02 13:27:51 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-05-02 13:27:51 +0000
commit3120faa9ae18d136deda2b84677c403f70c9525d (patch)
treed807faf993d45543174d4c9b99ea4402c08541c3 /devel/bugzilla
parent48570a4c38e71e1112c034a48d6dc6fb6ebc8cd2 (diff)
downloadports-3120faa9ae18d136deda2b84677c403f70c9525d.tar.gz
ports-3120faa9ae18d136deda2b84677c403f70c9525d.zip
Notes
Diffstat (limited to 'devel/bugzilla')
-rw-r--r--devel/bugzilla/Makefile24
-rw-r--r--devel/bugzilla/distinfo6
-rw-r--r--devel/bugzilla/pkg-plist84
3 files changed, 91 insertions, 23 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index d638325b0e6d..bffa2d79054c 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME?= bugzilla
-PORTVERSION?= 2.20.1
+PORTVERSION?= 2.22
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= webtools webtools/archived
@@ -14,14 +14,16 @@ MASTER_SITE_SUBDIR= webtools webtools/archived
MAINTAINER?= skv@FreeBSD.org
COMMENT?= Bug-tracking system developed by Mozilla Project
-OPTIONS= CHARTING_MODULES "Bug charting support" on \
+OPTIONS= MYSQL "MySQL database support" on \
+ PGSQL "PostgreSQL database support" off \
+ CHARTING_MODULES "Bug charting support" on \
GRAPHVIZ "Use GraphViz" off \
EMAIL_GATEWAY "Use email gateway" off \
EXPORT_IMPORT "Import/export bugs (via XML)" off \
CONTRIB "Install user-contributed scripts" off \
LDAP "Enable LDAP support" off
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+RUN_DEPENDS+= \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
@@ -34,7 +36,6 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DB
CONFLICTS?= ja-bugzilla-2.*
USE_PERL5= yes
-USE_REINPLACE= yes
BINMODE= 700
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -55,6 +56,18 @@ DATA_DIRS_LIST= images js skins/standard skins/standard/global \
.include <bsd.port.pre.mk>
+.ifdef WITH_MYSQL
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+USE_MYSQL= yes
+DEFAULT_MYSQL_VER= 41
+BROKEN_WITH_MYSQL= 323
+.endif
+
+.ifdef WITH_PGSQL
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+USE_PGSQL= yes
+.endif
+
.ifdef WITH_CHARTING_MODULES
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart \
@@ -71,7 +84,8 @@ RUN_DEPENDS+= ${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools
.endif
.ifdef WITH_EXPORT_IMPORT
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig
.endif
.ifdef WITH_CONTRIB
diff --git a/devel/bugzilla/distinfo b/devel/bugzilla/distinfo
index fc835c97b494..a218c4fddc18 100644
--- a/devel/bugzilla/distinfo
+++ b/devel/bugzilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (bugzilla-2.20.1.tar.gz) = b9c74195ce0f446be40b3e81104b934d
-SHA256 (bugzilla-2.20.1.tar.gz) = c87d8c93d5dbd9d2dfd49552e47fd23d8748070929b26910772d712ad6716bbe
-SIZE (bugzilla-2.20.1.tar.gz) = 1918866
+MD5 (bugzilla-2.22.tar.gz) = bbf2f1ec5607978d39855df104231973
+SHA256 (bugzilla-2.22.tar.gz) = 9d7e2144cd8499430c802ef5267dd2237aaec401546e5b9476db4f9ca19ebd4d
+SIZE (bugzilla-2.22.tar.gz) = 1956898
diff --git a/devel/bugzilla/pkg-plist b/devel/bugzilla/pkg-plist
index 9419a27274e6..f05b08c00f76 100644
--- a/devel/bugzilla/pkg-plist
+++ b/devel/bugzilla/pkg-plist
@@ -7,6 +7,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/administration.html
%%PORTDOCS%%%%DOCSDIR%%/html/bug_page.html
%%PORTDOCS%%%%DOCSDIR%%/html/bugreports.html
+%%PORTDOCS%%%%DOCSDIR%%/html/classifications.html
%%PORTDOCS%%%%DOCSDIR%%/html/cmdline-bugmail.html
%%PORTDOCS%%%%DOCSDIR%%/html/cmdline.html
%%PORTDOCS%%%%DOCSDIR%%/html/components.html
@@ -87,7 +88,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/versions.html
%%PORTDOCS%%%%DOCSDIR%%/html/voting.html
%%PORTDOCS%%%%DOCSDIR%%/html/whining.html
-%%PORTDOCS%%%%DOCSDIR%%/html/x3190.html
+%%PORTDOCS%%%%DOCSDIR%%/html/x3269.html
%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.png
%%PORTDOCS%%%%DOCSDIR%%/images/bzLifecycle.xml
%%PORTDOCS%%%%DOCSDIR%%/images/callouts/1.gif
@@ -134,7 +135,26 @@
%%BUGZILLADIR%%/Bugzilla/BugMail.pm
%%BUGZILLADIR%%/Bugzilla/CGI.pm
%%BUGZILLADIR%%/Bugzilla/Chart.pm
+%%BUGZILLADIR%%/Bugzilla/Classification.pm
+%%BUGZILLADIR%%/Bugzilla/Component.pm
%%BUGZILLADIR%%/Bugzilla/Config.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Admin.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Attachment.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Auth.pm
+%%BUGZILLADIR%%/Bugzilla/Config/BugChange.pm
+%%BUGZILLADIR%%/Bugzilla/Config/BugFields.pm
+%%BUGZILLADIR%%/Bugzilla/Config/BugMove.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Common.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Core.pm
+%%BUGZILLADIR%%/Bugzilla/Config/DependencyGraph.pm
+%%BUGZILLADIR%%/Bugzilla/Config/GroupSecurity.pm
+%%BUGZILLADIR%%/Bugzilla/Config/L10n.pm
+%%BUGZILLADIR%%/Bugzilla/Config/LDAP.pm
+%%BUGZILLADIR%%/Bugzilla/Config/MTA.pm
+%%BUGZILLADIR%%/Bugzilla/Config/PatchViewer.pm
+%%BUGZILLADIR%%/Bugzilla/Config/Query.pm
+%%BUGZILLADIR%%/Bugzilla/Config/ShadowDB.pm
+%%BUGZILLADIR%%/Bugzilla/Config/UserMatch.pm
%%BUGZILLADIR%%/Bugzilla/Constants.pm
%%BUGZILLADIR%%/Bugzilla/DB.pm
%%BUGZILLADIR%%/Bugzilla/DB/Mysql.pm
@@ -143,24 +163,27 @@
%%BUGZILLADIR%%/Bugzilla/DB/Schema/Mysql.pm
%%BUGZILLADIR%%/Bugzilla/DB/Schema/Pg.pm
%%BUGZILLADIR%%/Bugzilla/Error.pm
+%%BUGZILLADIR%%/Bugzilla/Field.pm
%%BUGZILLADIR%%/Bugzilla/Flag.pm
%%BUGZILLADIR%%/Bugzilla/FlagType.pm
%%BUGZILLADIR%%/Bugzilla/Group.pm
+%%BUGZILLADIR%%/Bugzilla/Milestone.pm
+%%BUGZILLADIR%%/Bugzilla/Product.pm
%%BUGZILLADIR%%/Bugzilla/Search.pm
+%%BUGZILLADIR%%/Bugzilla/Search/Quicksearch.pm
%%BUGZILLADIR%%/Bugzilla/Series.pm
%%BUGZILLADIR%%/Bugzilla/Template.pm
-%%BUGZILLADIR%%/Bugzilla/Token.pm
-%%BUGZILLADIR%%/Bugzilla/User.pm
-%%BUGZILLADIR%%/Bugzilla/Util.pm
%%BUGZILLADIR%%/Bugzilla/Template/Plugin/Bugzilla.pm
%%BUGZILLADIR%%/Bugzilla/Template/Plugin/Hook.pm
%%BUGZILLADIR%%/Bugzilla/Template/Plugin/User.pm
+%%BUGZILLADIR%%/Bugzilla/Token.pm
+%%BUGZILLADIR%%/Bugzilla/User.pm
%%BUGZILLADIR%%/Bugzilla/User/Setting.pm
+%%BUGZILLADIR%%/Bugzilla/Util.pm
+%%BUGZILLADIR%%/Bugzilla/Version.pm
%%BUGZILLADIR%%/Bugzilla.pm
-%%BUGZILLADIR%%/CGI.pl
%%BUGZILLADIR%%/QUICKSTART
%%BUGZILLADIR%%/README
-%%BUGZILLADIR%%/ant.jpg
%%BUGZILLADIR%%/attachment.cgi
%%BUGZILLADIR%%/buglist.cgi
%%BUGZILLADIR%%/bugzilla.dtd
@@ -171,6 +194,7 @@
%%BUGZILLADIR%%/config.cgi
%%BUGZILLADIR%%/js/duplicates.js
%%BUGZILLADIR%%/js/productform.js
+%%BUGZILLADIR%%/js/TUI.js
%%BUGZILLADIR%%/skins/standard/admin.css
%%BUGZILLADIR%%/skins/standard/buglist.css
%%BUGZILLADIR%%/skins/standard/duplicates.css
@@ -178,12 +202,12 @@
%%BUGZILLADIR%%/skins/standard/global.css
%%BUGZILLADIR%%/skins/standard/index.css
%%BUGZILLADIR%%/skins/standard/panel.css
+%%BUGZILLADIR%%/skins/standard/params.css
%%BUGZILLADIR%%/skins/standard/show_multiple.css
%%BUGZILLADIR%%/skins/standard/summarize-time.css
%%BUGZILLADIR%%/skins/standard/voting.css
%%BUGZILLADIR%%/skins/standard/global/body-back.gif
%%BUGZILLADIR%%/skins/standard/global/header.png
-%%BUGZILLADIR%%/skins/standard/index/front.jpg
%%BUGZILLADIR%%/skins/standard/index/front.png
%%CONTRIB%%%%BUGZILLADIR%%/contrib/BugzillaEmail.pm
%%CONTRIB%%%%BUGZILLADIR%%/contrib/README
@@ -212,16 +236,15 @@
%%CONTRIB%%%%BUGZILLADIR%%/contrib/gnatsparse/magic.py
%%CONTRIB%%%%BUGZILLADIR%%/contrib/gnatsparse/specialuu.py
%%CONTRIB%%%%BUGZILLADIR%%/contrib/jb2bz.py
+%%CONTRIB%%%%BUGZILLADIR%%/contrib/merge-users.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/mysqld-watcher.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/sendbugmail.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/sendunsentbugmail.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/syncLDAP.pl
%%CONTRIB%%%%BUGZILLADIR%%/contrib/yp_nomail.sh
%%BUGZILLADIR%%/createaccount.cgi
-%%BUGZILLADIR%%/defparams.pl
%%BUGZILLADIR%%/describecomponents.cgi
%%BUGZILLADIR%%/describekeywords.cgi
-%%BUGZILLADIR%%/doeditparams.cgi
%%BUGZILLADIR%%/duplicates.cgi
%%BUGZILLADIR%%/duplicates.xul
%%BUGZILLADIR%%/editclassifications.cgi
@@ -242,17 +265,12 @@
%%BUGZILLADIR%%/images/padlock.png
%%BUGZILLADIR%%/importxml.pl
%%BUGZILLADIR%%/index.cgi
-%%BUGZILLADIR%%/localconfig.js
%%BUGZILLADIR%%/long_list.cgi
-%%BUGZILLADIR%%/move.pl
%%BUGZILLADIR%%/page.cgi
%%BUGZILLADIR%%/post_bug.cgi
%%BUGZILLADIR%%/process_bug.cgi
%%BUGZILLADIR%%/productmenu.js
%%BUGZILLADIR%%/query.cgi
-%%BUGZILLADIR%%/quicksearch.html
-%%BUGZILLADIR%%/quicksearch.js
-%%BUGZILLADIR%%/quicksearchhack.html
%%BUGZILLADIR%%/quips.cgi
%%BUGZILLADIR%%/relogin.cgi
%%BUGZILLADIR%%/report.cgi
@@ -287,6 +305,7 @@
%%BUGZILLADIR%%/template/en/default/account/prefs/prefs.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/prefs/saved-searches.html.tmpl
%%BUGZILLADIR%%/template/en/default/account/prefs/settings.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/sudo.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/table.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/classifications/add.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/classifications/del.html.tmpl
@@ -340,13 +359,38 @@
%%BUGZILLADIR%%/template/en/default/admin/milestones/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/milestones/select-product.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/milestones/updated.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/admin.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/attachment.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/auth.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/bugchange.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/bugfields.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/bugmove.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/common.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/core.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/dependencygraph.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/editparams.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/groupsecurity.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/index.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/l10n.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/ldap.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/mta.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/patchviewer.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/query.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/shadowdb.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/params/usermatch.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/create.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/created.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/confirm-delete.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/deleted.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/edit-common.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/edit.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/footer.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/list-classifications.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/groupcontrol/confirm-edit.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/products/groupcontrol/edit.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/groupcontrol/updated.html.tmpl
+%%BUGZILLADIR%%/template/en/default/admin/products/updated.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/settings/edit.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/settings/updated.html.tmpl
%%BUGZILLADIR%%/template/en/default/admin/users/confirm-delete.html.tmpl
@@ -396,7 +440,6 @@
%%BUGZILLADIR%%/template/en/default/bug/process/confirm-duplicate.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/process/header.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/process/midair.html.tmpl
-%%BUGZILLADIR%%/template/en/default/bug/process/next.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/process/results.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/process/verify-new-product.html.tmpl
%%BUGZILLADIR%%/template/en/default/bug/show-multiple.html.tmpl
@@ -409,6 +452,7 @@
%%BUGZILLADIR%%/template/en/default/bug/votes/list-for-user.html.tmpl
%%BUGZILLADIR%%/template/en/default/config.js.tmpl
%%BUGZILLADIR%%/template/en/default/config.rdf.tmpl
+%%BUGZILLADIR%%/template/en/default/email/sudo.txt.tmpl
%%BUGZILLADIR%%/template/en/default/filterexceptions.pl
%%BUGZILLADIR%%/template/en/default/flag/list.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/banner.html.tmpl
@@ -425,9 +469,12 @@
%%BUGZILLADIR%%/template/en/default/global/initialize.none.tmpl
%%BUGZILLADIR%%/template/en/default/global/message.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/messages.html.tmpl
+%%BUGZILLADIR%%/template/en/default/global/message.txt.tmpl
+%%BUGZILLADIR%%/template/en/default/global/per-bug-queries.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/select-menu.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/setting-descs.none.tmpl
%%BUGZILLADIR%%/template/en/default/global/site-navigation.html.tmpl
+%%BUGZILLADIR%%/template/en/default/global/tabs.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/useful-links.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/user-error.html.tmpl
%%BUGZILLADIR%%/template/en/default/global/userselect.html.tmpl
@@ -449,6 +496,9 @@
%%BUGZILLADIR%%/template/en/default/pages/fields.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/linked.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/linkify.html.tmpl
+%%BUGZILLADIR%%/template/en/default/pages/quicksearch.html.tmpl
+%%BUGZILLADIR%%/template/en/default/pages/quicksearchhack.html.tmpl
+%%BUGZILLADIR%%/template/en/default/pages/sudo.html.tmpl
%%BUGZILLADIR%%/template/en/default/pages/voting.html.tmpl
%%BUGZILLADIR%%/template/en/default/reports/chart.csv.tmpl
%%BUGZILLADIR%%/template/en/default/reports/chart.html.tmpl
@@ -508,6 +558,7 @@
@dirrm %%BUGZILLADIR%%/template/en/default/list
@dirrm %%BUGZILLADIR%%/template/en/default/global
@dirrm %%BUGZILLADIR%%/template/en/default/flag
+@dirrm %%BUGZILLADIR%%/template/en/default/email
@dirrm %%BUGZILLADIR%%/template/en/default/bug/votes
@dirrm %%BUGZILLADIR%%/template/en/default/bug/process
@dirrm %%BUGZILLADIR%%/template/en/default/bug/create
@@ -519,6 +570,7 @@
@dirrm %%BUGZILLADIR%%/template/en/default/admin/settings
@dirrm %%BUGZILLADIR%%/template/en/default/admin/products/groupcontrol
@dirrm %%BUGZILLADIR%%/template/en/default/admin/products
+@dirrm %%BUGZILLADIR%%/template/en/default/admin/params
@dirrm %%BUGZILLADIR%%/template/en/default/admin/milestones
@dirrm %%BUGZILLADIR%%/template/en/default/admin/keywords
@dirrm %%BUGZILLADIR%%/template/en/default/admin/groups
@@ -542,8 +594,10 @@
@dirrm %%BUGZILLADIR%%/Bugzilla/User
@dirrm %%BUGZILLADIR%%/Bugzilla/Template/Plugin
@dirrm %%BUGZILLADIR%%/Bugzilla/Template
+@dirrm %%BUGZILLADIR%%/Bugzilla/Search
@dirrm %%BUGZILLADIR%%/Bugzilla/DB/Schema
@dirrm %%BUGZILLADIR%%/Bugzilla/DB
+@dirrm %%BUGZILLADIR%%/Bugzilla/Config
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Verify
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW/CGI
@dirrm %%BUGZILLADIR%%/Bugzilla/Auth/Login/WWW