aboutsummaryrefslogtreecommitdiff
path: root/devel/buildapp
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 01:16:52 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 01:16:52 +0000
commit0558f015231e75ef8c2532fe224cffa3522dc11a (patch)
tree8778e7f8f0e18d5325c16e6f2c8f49f62018e387 /devel/buildapp
parent4919a6348056c39483ba119abee1ec5bd4f2f977 (diff)
downloadports-0558f015231e75ef8c2532fe224cffa3522dc11a.tar.gz
ports-0558f015231e75ef8c2532fe224cffa3522dc11a.zip
Notes
Diffstat (limited to 'devel/buildapp')
-rw-r--r--devel/buildapp/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/devel/buildapp/Makefile b/devel/buildapp/Makefile
index a2a3e2752a25..cf966d44fa2b 100644
--- a/devel/buildapp/Makefile
+++ b/devel/buildapp/Makefile
@@ -13,30 +13,28 @@ DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= dunkyp@gmail.com
-COMMENT= A simple wrapped for creating executables with sbcl
-
-BUILD_DEPENDS= sbcl:${PORTSDIR}/lang/sbcl
-RUN_DEPENDS= ${BUILD_DEPENDS}
+COMMENT= A simple wrapper for creating executables with sbcl
LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/doc/LICENSE-buildapp
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE
-PLIST_FILES= bin/buildapp
-PORTDOCS= *
+USE_SBCL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
ALL_TARGET=
-post-extract:
- @${MV} ${WRKSRC}/doc/LICENSE ${WRKSRC}/doc/LICENSE-buildapp
+PLIST_FILES= bin/buildapp
+PORTDOCS= *
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+post-patch: .SILENT
+ ${REINPLACE_CMD} 's|sbcl|${SBCL}|' ${WRKSRC}/Makefile
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR} "! -name LICENSE*")
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR} "! -name LICENSE*")
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>