aboutsummaryrefslogtreecommitdiff
path: root/devel/bunny/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-01-28 20:04:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-01-28 20:04:56 +0000
commitf22ca11950a59f7df8dafd1c26022f3f95bab487 (patch)
treee7d0b17835a8bd6bb77d85fdc0bf52a8438b152b /devel/bunny/Makefile
parentc46e54a74796814ad318f9d457566cbf5e10924c (diff)
Notes
Diffstat (limited to 'devel/bunny/Makefile')
-rw-r--r--devel/bunny/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/bunny/Makefile b/devel/bunny/Makefile
new file mode 100644
index 000000000000..817c9b67489b
--- /dev/null
+++ b/devel/bunny/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: bunny
+# Date created: 28 Jan 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bunny
+PORTVERSION= 0.92
+CATEGORIES= devel
+MASTER_SITES= http://bunny-the-fuzzer.googlecode.com/files/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Closed loop, high-performance, general purpose protocol-blind fuzzer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= README
+PLIST_FILES= bin/bunny-trace bin/bunny-gcc bin/bunny-flow bin/bunny-exec \
+ bin/bunny-main
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+.for f in ${PLIST_FILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f:C/bin\///} ${PREFIX}/bin
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>