aboutsummaryrefslogtreecommitdiff
path: root/devel/bzr-fastimport
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-11-19 20:53:44 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-11-19 20:53:44 +0000
commit01990287b5ee1f6e51cfd385346461f64a1b60a8 (patch)
tree056fa48334c665934fe2528fade8c235bc6974f7 /devel/bzr-fastimport
parentabdaa7b1a5f8b6edadc63813dcd433f829adab88 (diff)
Notes
Diffstat (limited to 'devel/bzr-fastimport')
-rw-r--r--devel/bzr-fastimport/Makefile26
-rw-r--r--devel/bzr-fastimport/distinfo2
-rw-r--r--devel/bzr-fastimport/pkg-descr9
-rw-r--r--devel/bzr-fastimport/pkg-plist78
4 files changed, 115 insertions, 0 deletions
diff --git a/devel/bzr-fastimport/Makefile b/devel/bzr-fastimport/Makefile
new file mode 100644
index 000000000000..17dfa2b21d2a
--- /dev/null
+++ b/devel/bzr-fastimport/Makefile
@@ -0,0 +1,26 @@
+# Created by: Carlo Strub
+# $FreeBSD$
+#
+
+PORTNAME= bzr-fastimport
+PORTVERSION= 0.13.0
+CATEGORIES= devel
+MASTER_SITES= http://launchpadlibrarian.net/94774555/ \
+ http://www.c-s.li/ports/
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Provide fast loading of revision control data into bzr
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= bzr:${PORTSDIR}/devel/bzr
+RUN_DEPENDS= bzr:${PORTSDIR}/devel/bzr
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= bzr_fastimport
+PYDISTUTILS_PKGVERSION= ${PORTVERSION}.final.0
+
+.include <bsd.port.mk>
diff --git a/devel/bzr-fastimport/distinfo b/devel/bzr-fastimport/distinfo
new file mode 100644
index 000000000000..434dcfc22f7a
--- /dev/null
+++ b/devel/bzr-fastimport/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bzr-fastimport-0.13.0.tar.gz) = 5e296dc4ff8e9bf1b6447e81fef41e1217656b43368ee4056a1f024221e009eb
+SIZE (bzr-fastimport-0.13.0.tar.gz) = 80255
diff --git a/devel/bzr-fastimport/pkg-descr b/devel/bzr-fastimport/pkg-descr
new file mode 100644
index 000000000000..01d76652eab2
--- /dev/null
+++ b/devel/bzr-fastimport/pkg-descr
@@ -0,0 +1,9 @@
+Bazaar Fast Import is a plugin providing fast loading of revision control data
+into Bazaar. It is designed to be used in combination with front-end programs
+that generate a command/data stream for it to process. Front-ends are available
+for a wide range of foreign VCS tools including Subversion, CVS, Git,
+Mercurial, Darcs and Perforce. New front-ends are easy to develop in whatever
+programming language you prefer, making Bazaar Fast Import useful for teams
+needing a custom migration solution.
+
+WWW: https://launchpad.net/bzr-fastimport
diff --git a/devel/bzr-fastimport/pkg-plist b/devel/bzr-fastimport/pkg-plist
new file mode 100644
index 000000000000..f7a41e7d9f14
--- /dev/null
+++ b/devel/bzr-fastimport/pkg-plist
@@ -0,0 +1,78 @@
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_mapper.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_mapper.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_mapper.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_updater.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_updater.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/branch_updater.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/bzr_commit_handler.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/bzr_commit_handler.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/bzr_commit_handler.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cache_manager.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cache_manager.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cache_manager.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cmds.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cmds.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/cmds.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/exporter.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/exporter.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/exporter.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/helpers.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/helpers.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/helpers.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/idmapfile.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/idmapfile.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/idmapfile.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/info.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/info.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/info.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/marks_file.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/marks_file.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/marks_file.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/generic_processor.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/generic_processor.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/generic_processor.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/info_processor.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/info_processor.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors/info_processor.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/reftracker.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/reftracker.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/reftracker.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/revision_store.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/revision_store.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/revision_store.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_branch_mapper.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_branch_mapper.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_branch_mapper.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_commands.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_commands.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_commands.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_exporter.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_exporter.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_exporter.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_generic_processor.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_generic_processor.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_generic_processor.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_head_tracking.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_head_tracking.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_head_tracking.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_revision_store.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_revision_store.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests/test_revision_store.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/user_mapper.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/user_mapper.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/user_mapper.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/tests
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport/processors
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/fastimport
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib/plugins
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib
+@dirrmtry %%PYTHON_SITELIBDIR%%