aboutsummaryrefslogtreecommitdiff
path: root/devel/bzr-upload
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-12-20 22:37:17 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-12-20 22:37:17 +0000
commit411486685b84961d4465f2c9c09d6653218253cf (patch)
tree5a47c41ec4b147d9698f041dc9c28616948adf41 /devel/bzr-upload
parent69fe5671e4f7a7d2b91d1c1cc3d45984ffebfcaa (diff)
downloadports-411486685b84961d4465f2c9c09d6653218253cf.tar.gz
ports-411486685b84961d4465f2c9c09d6653218253cf.zip
Web sites are often hosted on servers where bzr can't be installed.
In other cases, the web site must not give access to its corresponding branch (for security reasons for example). Finally, web hosting providers often provides only ftp access to upload sites. This plugin uploads only the relevant changes in your working tree since the last upload using ftp or sftp protocols. WWW: http://wiki.bazaar.canonical.com/BazaarUploadForWebDev PR: ports/153013 Submitted by: Carlo Strub <c-s at c-s.li>
Notes
Notes: svn path=/head/; revision=266669
Diffstat (limited to 'devel/bzr-upload')
-rw-r--r--devel/bzr-upload/Makefile28
-rw-r--r--devel/bzr-upload/distinfo2
-rw-r--r--devel/bzr-upload/pkg-descr9
-rw-r--r--devel/bzr-upload/pkg-plist19
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/bzr-upload/Makefile b/devel/bzr-upload/Makefile
new file mode 100644
index 000000000000..9b269283b765
--- /dev/null
+++ b/devel/bzr-upload/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: bzr-upload
+# Date created: 2010-12-11
+# Whom: Carlo Strub <c-s@c-s.li>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bzr-upload
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://launchpadlibrarian.net/60433187/ \
+ http://www.c-s.li/ports/
+
+MAINTAINER= c-s@c-s.li
+COMMENT= Bzr plugin to incrementally upload changes to a dumb server
+
+BUILD_DEPENDS= bzr:${PORTSDIR}/devel/bazaar-ng
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= bzr_upload
+
+.include <bsd.port.mk>
diff --git a/devel/bzr-upload/distinfo b/devel/bzr-upload/distinfo
new file mode 100644
index 000000000000..77b0c50e246b
--- /dev/null
+++ b/devel/bzr-upload/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bzr-upload-1.0.0.tar.gz) = db8326e156e551b180c4abb8660fdc1f11332d41504ab26572f014ce1e655cd3
+SIZE (bzr-upload-1.0.0.tar.gz) = 21952
diff --git a/devel/bzr-upload/pkg-descr b/devel/bzr-upload/pkg-descr
new file mode 100644
index 000000000000..9e38a5f3eaaf
--- /dev/null
+++ b/devel/bzr-upload/pkg-descr
@@ -0,0 +1,9 @@
+Web sites are often hosted on servers where bzr can't be installed.
+In other cases, the web site must not give access to its corresponding
+branch (for security reasons for example). Finally, web hosting
+providers often provides only ftp access to upload sites.
+
+This plugin uploads only the relevant changes in your working tree
+since the last upload using ftp or sftp protocols.
+
+WWW: http://wiki.bazaar.canonical.com/BazaarUploadForWebDev
diff --git a/devel/bzr-upload/pkg-plist b/devel/bzr-upload/pkg-plist
new file mode 100644
index 000000000000..fe7e70ae2aa1
--- /dev/null
+++ b/devel/bzr-upload/pkg-plist
@@ -0,0 +1,19 @@
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/info.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/info.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/info.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_auto_upload_hook.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_auto_upload_hook.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_auto_upload_hook.pyo
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_upload.py
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_upload.pyc
+%%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests/test_upload.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload/tests
+@dirrm %%PYTHON_SITELIBDIR%%/bzrlib/plugins/upload
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib/plugins
+@dirrmtry %%PYTHON_SITELIBDIR%%/bzrlib