aboutsummaryrefslogtreecommitdiff
path: root/devel/bzr/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-28 09:36:43 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-28 09:36:43 +0000
commit4a9535e4ef48ba32fe3cc6b059d41b3f874ba907 (patch)
tree60c4b988d7229bf6d81b5135bb6c3cf38f1ad4bc /devel/bzr/Makefile
parent66845e0a356729d1f603a194cad383c67e680302 (diff)
downloadports-4a9535e4ef48ba32fe3cc6b059d41b3f874ba907.tar.gz
ports-4a9535e4ef48ba32fe3cc6b059d41b3f874ba907.zip
Notes
Diffstat (limited to 'devel/bzr/Makefile')
-rw-r--r--devel/bzr/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/bzr/Makefile b/devel/bzr/Makefile
new file mode 100644
index 000000000000..2d4fa57e4546
--- /dev/null
+++ b/devel/bzr/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: bazaar-ng
+# Date created: 10 October 2005
+# Whom: Ulf Lilleengen
+#
+# $FreeBSD$
+#
+
+PORTNAME= bazaar-ng
+PORTVERSION= 0.1.1
+CATEGORIES= devel
+MASTER_SITES= http://www.bazaar-ng.org/pkg/
+MASTER_SITE_SUBDIR= gnu-arch
+DISTNAME= bzr-${PORTVERSION}
+
+MAINTAINER= lulf@kerneled.org
+COMMENT= An implementation of the GNU arch RCS protocol by Canonical
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/elementtree/ElementTree.py:${PORTSDIR}/devel/py-elementtree
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+MAN1= bzr.1
+
+test:
+ cd ${WRKSRC} && ./bzr selftest
+
+post-build:
+ cd ${WRKSRC} && ${PYTHON_CMD} bzr-man.py
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/bzr.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>