aboutsummaryrefslogtreecommitdiff
path: root/devel/c2lib
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-11 16:38:48 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-11 16:38:48 +0000
commit0773c869d75b04303529baefdd1983f930d7489c (patch)
treee5ba7b32072f268bd0375e4e6b2979b3c7bc8b94 /devel/c2lib
parentac8cea2f821d3ef4de1415e6384f88f53154c547 (diff)
downloadports-0773c869d75b04303529baefdd1983f930d7489c.tar.gz
ports-0773c869d75b04303529baefdd1983f930d7489c.zip
Notes
Diffstat (limited to 'devel/c2lib')
-rw-r--r--devel/c2lib/Makefile44
-rw-r--r--devel/c2lib/distinfo2
-rw-r--r--devel/c2lib/scripts/genman3list.sh13
3 files changed, 28 insertions, 31 deletions
diff --git a/devel/c2lib/Makefile b/devel/c2lib/Makefile
index fc0799daf68e..706b0a3b0d4a 100644
--- a/devel/c2lib/Makefile
+++ b/devel/c2lib/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= c2lib
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.8
CATEGORIES= devel
MASTER_SITES= http://www.annexia.org/freeware/c2lib/
@@ -20,34 +20,18 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
-MAN3= _hash_erase.3 _hash_get.3 _hash_get_ptr.3 _hash_insert.3 _hash_new.3 \
- _sash_get.3 _vector_compare.3 _vector_fill.3 _vector_get.3 \
- _vector_get_ptr.3 _vector_insert.3 _vector_map.3 _vector_map_pool.3 \
- _vector_new.3 _vector_pop_back.3 _vector_pop_front.3 \
- _vector_push_back.3 _vector_push_front.3 _vector_replace.3 \
- _vector_sort.3 copy_hash.3 copy_sash.3 copy_vector.3 delete_pool.3 \
- global_pool.3 hash_erase.3 hash_exists.3 hash_get.3 \
- hash_get_buckets_allocated.3 hash_get_buckets_used.3 hash_get_ptr.3 \
- hash_insert.3 hash_keys.3 hash_keys_in_pool.3 \
- hash_set_buckets_allocated.3 hash_size.3 hash_values.3 \
- hash_values_in_pool.3 new_hash.3 new_pool.3 new_sash.3 new_subpool.3 \
- new_vector.3 pcalloc.3 pchomp.3 pchrs.3 pconcat.3 pdtoa.3 pitoa.3 \
- pjoin.3 pmalloc.3 pmemdup.3 pool_get_stats.3 \
- pool_register_cleanup_fn.3 pool_register_fd.3 pool_register_malloc.3 \
- pool_set_bad_malloc_handler.3 prealloc.3 psort.3 psprintf.3 pstrcat.3 \
- pstrcsplit.3 pstrdup.3 pstrndup.3 pstrresplit.3 pstrs.3 pstrsplit.3 \
- pstrupr.3 psubstr.3 pvdtostr.3 pvitostr.3 pvsprintf.3 pvxtostr.3 \
- pxtoa.3 sash_erase.3 sash_exists.3 sash_get.3 \
- sash_get_buckets_allocated.3 sash_get_buckets_used.3 sash_insert.3 \
- sash_keys.3 sash_keys_in_pool.3 sash_set_buckets_allocated.3 \
- sash_size.3 sash_values.3 sash_values_in_pool.3 vector_allocated.3 \
- vector_clear.3 vector_compare.3 vector_element_size.3 vector_erase.3 \
- vector_erase_range.3 vector_fill.3 vector_get.3 vector_get_ptr.3 \
- vector_grep.3 vector_grep_pool.3 vector_insert.3 \
- vector_insert_array.3 vector_map.3 vector_map_pool.3 \
- vector_pop_back.3 vector_pop_front.3 vector_push_back.3 \
- vector_push_front.3 vector_reallocate.3 vector_replace.3 \
- vector_replace_array.3 vector_reverse.3 vector_size.3 vector_sort.3 \
- vector_swap.3
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ REALCURDIR="${.CURDIR}" \
+ DISTNAME="${DISTNAME}"
+
+post-extract:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/genman3list.sh
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
.include <bsd.port.mk>
diff --git a/devel/c2lib/distinfo b/devel/c2lib/distinfo
index 3a8639b61a5f..cca4b282f0d6 100644
--- a/devel/c2lib/distinfo
+++ b/devel/c2lib/distinfo
@@ -1 +1 @@
-MD5 (c2lib-1.2.1.tar.gz) = 27bb673b00778badec0120db3f78d4b2
+MD5 (c2lib-1.2.8.tar.gz) = 86437c6fb8f89720a3fda781ce664f00
diff --git a/devel/c2lib/scripts/genman3list.sh b/devel/c2lib/scripts/genman3list.sh
new file mode 100644
index 000000000000..d93c72b86fc8
--- /dev/null
+++ b/devel/c2lib/scripts/genman3list.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+# $FreeBSD$
+
+if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
+ exit
+fi
+
+${MKDIR} ${WRKDIRPREFIX}${REALCURDIR}
+exec > ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
+
+cd ${WRKDIRPREFIX}${REALCURDIR}/work/${DISTNAME}
+echo "MAN3= \\"
+echo *.3