aboutsummaryrefslogtreecommitdiff
path: root/devel/calibrator
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-10-13 10:24:19 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-10-13 10:24:19 +0000
commit11e2501c18c34009c1c5e3595147991915685da0 (patch)
treeb0605e80a63816c7708e8c208a409fab6a460d87 /devel/calibrator
parent9fa1a8ca1ed9b02519dc7c32620112a7862aee77 (diff)
downloadports-11e2501c18c34009c1c5e3595147991915685da0.tar.gz
ports-11e2501c18c34009c1c5e3595147991915685da0.zip
Notes
Diffstat (limited to 'devel/calibrator')
-rw-r--r--devel/calibrator/Makefile27
-rw-r--r--devel/calibrator/distinfo1
-rw-r--r--devel/calibrator/files/patch-Makefile12
-rw-r--r--devel/calibrator/pkg-descr16
-rw-r--r--devel/calibrator/pkg-plist1
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/calibrator/Makefile b/devel/calibrator/Makefile
new file mode 100644
index 000000000000..7a2952be0c01
--- /dev/null
+++ b/devel/calibrator/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: calibrator
+# Date created: 13 October 2003
+# Whom: bms@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= calibrator
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= http://homepages.cwi.nl/~manegold/Calibrator/src/
+DISTNAME= ${PORTNAME}.c
+EXTRACT_SUFX=
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Cache Profiling Tool
+
+NO_WRKSUBDIR= yes
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/calibrator/distinfo b/devel/calibrator/distinfo
new file mode 100644
index 000000000000..c3e421435a2a
--- /dev/null
+++ b/devel/calibrator/distinfo
@@ -0,0 +1 @@
+MD5 (calibrator.c) = 5355f07ab1103e6d2948e08936d1ff54
diff --git a/devel/calibrator/files/patch-Makefile b/devel/calibrator/files/patch-Makefile
new file mode 100644
index 000000000000..cfb2ce045668
--- /dev/null
+++ b/devel/calibrator/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Mon Oct 13 11:14:02 2003
++++ Makefile Mon Oct 13 11:16:20 2003
+@@ -0,0 +1,9 @@
++# $FreeBSD$
++
++PROG= calibrator
++SRCS= calibrator.c
++NOMAN= defined
++
++LDADD+= -lm
++
++.include <bsd.prog.mk>
diff --git a/devel/calibrator/pkg-descr b/devel/calibrator/pkg-descr
new file mode 100644
index 000000000000..82a9ddf95fd3
--- /dev/null
+++ b/devel/calibrator/pkg-descr
@@ -0,0 +1,16 @@
+The Calibrator is a small C program that is supposed to analyze a computer's
+memory system and extract the following parameters:
+
+ * number of cache levels
+ * for each cache level: size, linesize, access/miss latency
+ * main memory access latency, number of TLB levels
+ * for each TLB level: capacity, pagesize, TLB miss latency
+
+The Calibrator is a by-product of our work on Main-Memory Databases within
+the Monet project. The Calibrator is freely available for download and usage,
+but we kindly ask all users to include a reference to the Calibrator's home
+page whenever they refer to the Calibrator or publish calibration results.
+
+Author: Stefan Manegold <Stefan.Manegold@cwi.nl>
+
+WWW: http://www.cwi.nl/~manegold/Calibrator/
diff --git a/devel/calibrator/pkg-plist b/devel/calibrator/pkg-plist
new file mode 100644
index 000000000000..6d1392336290
--- /dev/null
+++ b/devel/calibrator/pkg-plist
@@ -0,0 +1 @@
+bin/calibrator