aboutsummaryrefslogtreecommitdiff
path: root/devel/capstone
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-17 20:44:45 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-17 20:44:45 +0000
commit0e0ef34406efa4adfe1806d2c2de3db69c01bb2c (patch)
treefcd45dfd272d3d6020c6d5c5fbe998406386d732 /devel/capstone
parent4e2e1beedc7b284588635d66ba24d4301ddf5646 (diff)
Notes
Diffstat (limited to 'devel/capstone')
-rw-r--r--devel/capstone/Makefile7
-rw-r--r--devel/capstone/distinfo4
-rw-r--r--devel/capstone/files/patch-Makefile48
-rw-r--r--devel/capstone/files/patch-tests_Makefile9
-rw-r--r--devel/capstone/pkg-plist1
5 files changed, 38 insertions, 31 deletions
diff --git a/devel/capstone/Makefile b/devel/capstone/Makefile
index 098c9185d8f0..0063b35ff908 100644
--- a/devel/capstone/Makefile
+++ b/devel/capstone/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= capstone
-PORTVERSION= 2.0
+PORTVERSION= 2.1.1
CATEGORIES= devel
-MASTER_SITES= http://capstone-engine.org/download/2.0/
+MASTER_SITES= http://capstone-engine.org/download/2.1/
MAINTAINER= oliver.pntr@gmail.com
COMMENT= Multi-platform, multi-architecture disassembly framework
@@ -13,7 +13,8 @@ LICENSE= BSD3CLAUSE
USES= gmake
USE_LDCONFIG= yes
-MAKE_ENV= INSTALL_LIBRARY="${INSTALL_LIB}"
+MAKE_ENV+= INSTALL_LIB="${INSTALL_LIB}" \
+ INSTALL_DATA="${INSTALL_DATA}"
post-build:
# The pkgconfig file is generated and points to stagedir
diff --git a/devel/capstone/distinfo b/devel/capstone/distinfo
index 9c59fdf5dc3f..5844714e4057 100644
--- a/devel/capstone/distinfo
+++ b/devel/capstone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (capstone-2.0.tar.gz) = 5d871b1e52047d1b2882bbcc6f049205ba6acc8d55d746937d22af5d0b33fa9e
-SIZE (capstone-2.0.tar.gz) = 1731759
+SHA256 (capstone-2.1.1.tar.gz) = 8af3c0a0f439d516277f308938935003d072f34a34fcf2e8dcf07dd415b1ca65
+SIZE (capstone-2.1.1.tar.gz) = 1353194
diff --git a/devel/capstone/files/patch-Makefile b/devel/capstone/files/patch-Makefile
index 4abddd6f1984..dcb85bb74c81 100644
--- a/devel/capstone/files/patch-Makefile
+++ b/devel/capstone/files/patch-Makefile
@@ -1,6 +1,7 @@
---- Makefile.orig 2014-01-22 10:33:35.000000000 +0000
-+++ Makefile
-@@ -15,7 +15,7 @@ RANLIB = $(CROSS)ranlib
+diff -ru /Makefile /Makefile
+--- Makefile 2014-03-14 17:24:44.000000000 +0100
++++ Makefile 2014-03-14 17:35:33.000000000 +0100
+@@ -16,7 +16,7 @@
STRIP = $(CROSS)strip
endif
@@ -9,38 +10,41 @@
ifeq ($(USE_SYS_DYN_MEM),yes)
CFLAGS += -DUSE_SYS_DYN_MEM
-@@ -38,6 +38,8 @@ LIBDIR = $(DESTDIR)$(PREFIX)/lib
+@@ -39,9 +39,17 @@
endif
endif
++LIBDATADIR = $(LIBDIR)
++UNAME_S := $(shell uname -s)
++ifeq ($(UNAME_S), FreeBSD)
+LIBDATADIR = $(DESTDIR)$(PREFIX)/libdata
++else
++LIBDATADIR = $(LIBDIR)
++endif
+
INSTALL_BIN ?= install
INSTALL_DATA ?= $(INSTALL_BIN) -m0644
- INSTALL_LIBRARY ?= $(INSTALL_BIN) -m0755
-@@ -88,7 +90,6 @@ endif
+-INSTALL_LIBRARY ?= $(INSTALL_BIN) -m0755
++INSTALL_LIB ?= $(INSTALL_BIN) -m0755
+ LIBNAME = capstone
+
+@@ -138,8 +146,7 @@
LIBOBJ += MCInst.o
+
-UNAME_S := $(shell uname -s)
+-PKGCFCGDIR = $(LIBDIR)/pkgconfig
++PKGCFCGDIR = $(LIBDATADIR)/pkgconfig
+
# OSX?
ifeq ($(UNAME_S),Darwin)
- EXT = dylib
-@@ -156,14 +157,14 @@ install: $(PKGCFGF) $(ARCHIVE) $(LIBRARY
+@@ -244,7 +251,7 @@
+
+ install: $(PKGCFGF) $(ARCHIVE) $(LIBRARY)
+ mkdir -p $(LIBDIR)
+- $(INSTALL_LIBRARY) lib$(LIBNAME).$(EXT) $(LIBDIR)
++ $(INSTALL_LIB) lib$(LIBNAME).$(EXT) $(LIBDIR)
$(INSTALL_DATA) lib$(LIBNAME).$(AR_EXT) $(LIBDIR)
mkdir -p $(INCDIR)/$(LIBNAME)
$(INSTALL_DATA) include/*.h $(INCDIR)/$(LIBNAME)
-- mkdir -p $(LIBDIR)/pkgconfig
-- $(INSTALL_DATA) $(PKGCFGF) $(LIBDIR)/pkgconfig/
-+ mkdir -p $(LIBDATADIR)/pkgconfig
-+ $(INSTALL_DATA) $(PKGCFGF) $(LIBDATADIR)/pkgconfig/
-
- uninstall:
- rm -rf $(INCDIR)/$(LIBNAME)
- rm -f $(LIBDIR)/lib$(LIBNAME).$(EXT)
- rm -f $(LIBDIR)/lib$(LIBNAME).$(AR_EXT)
-- rm -f $(LIBDIR)/pkgconfig/$(LIBNAME).pc
-+ rm -f $(LIBDATADIR)/pkgconfig/$(LIBNAME).pc
-
- clean:
- rm -f $(LIBOBJ) lib$(LIBNAME).*
diff --git a/devel/capstone/files/patch-tests_Makefile b/devel/capstone/files/patch-tests_Makefile
index ea971411ffc1..02a48e66afef 100644
--- a/devel/capstone/files/patch-tests_Makefile
+++ b/devel/capstone/files/patch-tests_Makefile
@@ -1,6 +1,7 @@
---- tests/Makefile.orig 2014-01-25 19:14:03.000000000 +0100
-+++ tests/Makefile 2014-01-25 19:14:24.000000000 +0100
-@@ -11,7 +11,7 @@
+diff -ru work.orig/capstone-2.1.1/tests/Makefile work/capstone-2.1.1/tests/Makefile
+--- tests/Makefile 2014-03-14 17:24:44.000000000 +0100
++++ tests/Makefile 2014-03-14 17:52:47.000000000 +0100
+@@ -13,7 +13,7 @@
endif
@@ -9,7 +10,7 @@
LIBNAME = capstone
-@@ -48,8 +48,8 @@
+@@ -66,8 +66,8 @@
$(BINARY): $(OBJS)
%$(BIN_EXT): %.o
diff --git a/devel/capstone/pkg-plist b/devel/capstone/pkg-plist
index 702037f2ee97..9f89dc8c746d 100644
--- a/devel/capstone/pkg-plist
+++ b/devel/capstone/pkg-plist
@@ -1,6 +1,7 @@
include/capstone/arm.h
include/capstone/arm64.h
include/capstone/capstone.h
+include/capstone/diet.h
include/capstone/mips.h
include/capstone/ppc.h
include/capstone/x86.h