aboutsummaryrefslogtreecommitdiff
path: root/devel/cargo/Makefile
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2016-11-21 21:07:30 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2016-11-21 21:07:30 +0000
commit160633cd866bd8ae7a892a33b696939c0ca9a42b (patch)
tree2d9bdad87e8b9d62b43da18081ba5702a0f09fb7 /devel/cargo/Makefile
parent906b2065e82e8ee36b9f0848f482a0bb44b0c95f (diff)
Notes
Diffstat (limited to 'devel/cargo/Makefile')
-rw-r--r--devel/cargo/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/cargo/Makefile b/devel/cargo/Makefile
index d6b82929df2b..32071806e0de 100644
--- a/devel/cargo/Makefile
+++ b/devel/cargo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cargo
-PORTVERSION= 0.13.0
+PORTVERSION= 0.14.0
CATEGORIES= devel
MAINTAINER= dumbbell@FreeBSD.org
@@ -33,8 +33,8 @@ LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
# This is a collection of mainly shell scripts which are used to
# install Cargo.
-MASTER_SITES= https://static.rust-lang.org/cargo-dist/2016-08-21/:bootstrap \
- LOCAL/jbeich:registry
+MASTER_SITES= https://static.rust-lang.org/cargo-dist/2016-11-02/:bootstrap \
+ LOCAL/dumbbell/cargo:registry
.if !defined(SKIP_CARGO_REGISTRY)
DISTFILES+= ${CARGO_REGISTRY}:registry
.endif
@@ -61,8 +61,7 @@ LIB_DEPENDS= libssh2.so:security/libssh2 \
RUN_DEPENDS= rustc:${RUST_PORT}
RUST_PORT?= lang/rust
-USES= gmake python:-2.7,build pkgconfig
-USE_OPENSSL= yes
+USES= gmake python:-2.7,build pkgconfig ssl
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --mandir="${MANPREFIX}/man"
MAKE_ENV= ARGS="${CARGO_ARGS}"