aboutsummaryrefslogtreecommitdiff
path: root/devel/catch
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-05-26 15:27:07 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-05-26 15:27:07 +0000
commit35d8b48dff5490ff5d7232109c287da637b58811 (patch)
tree36d555f16caa15232c9f45867dcc3c80411e4522 /devel/catch
parentd33e6bd1870cb93484a10b0c3e7907b080bc9e31 (diff)
downloadports-35d8b48dff5490ff5d7232109c287da637b58811.tar.gz
ports-35d8b48dff5490ff5d7232109c287da637b58811.zip
Notes
Diffstat (limited to 'devel/catch')
-rw-r--r--devel/catch/Makefile26
-rw-r--r--devel/catch/distinfo2
-rw-r--r--devel/catch/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/catch/Makefile b/devel/catch/Makefile
new file mode 100644
index 000000000000..09a9622660f5
--- /dev/null
+++ b/devel/catch/Makefile
@@ -0,0 +1,26 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= catch
+PORTVERSION= 1.0.47
+CATEGORIES= devel
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= Header-only test framework for C++
+
+LICENSE= BSL
+
+USE_GITHUB= yes
+GH_ACCOUNT= gahr
+GH_PROJECT= Catch
+GH_COMMIT= 48fac9c
+
+NO_BUILD= yes
+
+PLIST_FILES= include/catch.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/single_include/catch.hpp \
+ ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/devel/catch/distinfo b/devel/catch/distinfo
new file mode 100644
index 000000000000..76e097c976c6
--- /dev/null
+++ b/devel/catch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (catch-1.0.47.tar.gz) = fabbc11cf5e0215bf756a8dda625962700ff6f8de6ab3d73b301d242708f8581
+SIZE (catch-1.0.47.tar.gz) = 262616
diff --git a/devel/catch/pkg-descr b/devel/catch/pkg-descr
new file mode 100644
index 000000000000..e68f5de99471
--- /dev/null
+++ b/devel/catch/pkg-descr
@@ -0,0 +1,6 @@
+Catch stands for C++ Automated Test Cases in Headers and is a multi-paradigm
+automated test framework for C++ and Objective-C (and, maybe, C). It is
+implemented entirely in a set of header files, but is packaged up as a single
+header for extra convenience.
+
+WWW: https://github.com/philsquared/Catch