aboutsummaryrefslogtreecommitdiff
path: root/devel/catch
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2019-03-12 12:34:23 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2019-03-12 12:34:23 +0000
commit689c58b71820f63ec8ca3f2aaff2e5265b7dd494 (patch)
tree605e821aeb5f60d129c5df98b66e2d85e7f23aca /devel/catch
parent43f0c21bcace33521a228017dbefbc43a4dba881 (diff)
downloadports-689c58b71820f63ec8ca3f2aaff2e5265b7dd494.tar.gz
ports-689c58b71820f63ec8ca3f2aaff2e5265b7dd494.zip
devel/catch: update to 2.7.0
Notes
Notes: svn path=/head/; revision=495450
Diffstat (limited to 'devel/catch')
-rw-r--r--devel/catch/Makefile2
-rw-r--r--devel/catch/distinfo6
-rw-r--r--devel/catch/files/patch-bug23621231
3 files changed, 4 insertions, 35 deletions
diff --git a/devel/catch/Makefile b/devel/catch/Makefile
index 2ac734112892..3ab1aec9d80e 100644
--- a/devel/catch/Makefile
+++ b/devel/catch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= catch
DISTVERSIONPREFIX= v
-DISTVERSION= 2.6.1
+DISTVERSION= 2.7.0
PORTREVISION= 0
CATEGORIES= devel
diff --git a/devel/catch/distinfo b/devel/catch/distinfo
index ecc49946fa66..622bb0179975 100644
--- a/devel/catch/distinfo
+++ b/devel/catch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550050778
-SHA256 (catchorg-Catch2-v2.6.1_GH0.tar.gz) = b57c2d3362102a77955d3cd0181b792c496520349bfefee8379b9d35b8819f80
-SIZE (catchorg-Catch2-v2.6.1_GH0.tar.gz) = 559715
+TIMESTAMP = 1552392787
+SHA256 (catchorg-Catch2-v2.7.0_GH0.tar.gz) = d4655e87c0ccda5a2e78bf4256fce8036feb969399503dcc8272f4c90347d9c0
+SIZE (catchorg-Catch2-v2.7.0_GH0.tar.gz) = 569753
diff --git a/devel/catch/files/patch-bug236212 b/devel/catch/files/patch-bug236212
deleted file mode 100644
index b0988adca2cd..000000000000
--- a/devel/catch/files/patch-bug236212
+++ /dev/null
@@ -1,31 +0,0 @@
-From e8bfd882e8e8738d884933ad75eb25e8a50989b8 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 12 Feb 2019 12:57:00 -0800
-Subject: [PATCH] Fix -Wdefaulted-function-deleted warning
-
-Clang8 warns
-
-catch_interfaces_reporter.h:84:25: error: explicitly defaulted move assignment operator is implicitly deleted [-Werror,-Wdefaulted-function-deleted]
-| AssertionStats& operator = ( AssertionStats && ) = default;
-| ^
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- include/internal/catch_interfaces_reporter.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/internal/catch_interfaces_reporter.h b/include/internal/catch_interfaces_reporter.h
-index 9d99c9814..e5fbf8bb0 100644
---- include/internal/catch_interfaces_reporter.h.orig
-+++ include/internal/catch_interfaces_reporter.h
-@@ -80,8 +80,8 @@ namespace Catch {
-
- AssertionStats( AssertionStats const& ) = default;
- AssertionStats( AssertionStats && ) = default;
-- AssertionStats& operator = ( AssertionStats const& ) = default;
-- AssertionStats& operator = ( AssertionStats && ) = default;
-+ AssertionStats& operator = ( AssertionStats const& ) = delete;
-+ AssertionStats& operator = ( AssertionStats && ) = delete;
- virtual ~AssertionStats();
-
- AssertionResult assertionResult;