aboutsummaryrefslogtreecommitdiff
path: root/devel/ccache
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-11-15 20:03:33 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-11-15 20:03:33 +0000
commitc7897d0359faffc8467abf408077fe6e9c433efa (patch)
tree8b5ac8d3e022d565e5b26529af1cfc8bdbd27450 /devel/ccache
parent4aace936b4bb65962aa7187cf669973850ef13d9 (diff)
downloadports-c7897d0359faffc8467abf408077fe6e9c433efa.tar.gz
ports-c7897d0359faffc8467abf408077fe6e9c433efa.zip
Notes
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile2
-rw-r--r--devel/ccache/files/patch-ccache.119
-rw-r--r--devel/ccache/files/patch-ccache.c15
3 files changed, 35 insertions, 1 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 280a16b784bb..85ba6d4c9694 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ccache
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://ccache.samba.org/ftp/ccache/
diff --git a/devel/ccache/files/patch-ccache.1 b/devel/ccache/files/patch-ccache.1
new file mode 100644
index 000000000000..83addd79e9d9
--- /dev/null
+++ b/devel/ccache/files/patch-ccache.1
@@ -0,0 +1,19 @@
+--- ccache.1.orig Mon Sep 13 06:38:30 2004
++++ ccache.1 Tue Nov 15 14:59:46 2005
+@@ -234,6 +234,16 @@
+ incorrect setting of this debug info rarely causes problems\&. If you
+ strike problems with gdb not using the correct directory then enable
+ this option\&.
++.IP
++.IP "\fBCCACHE_NOHASH_SIZE_MTIME\fP"
++This tells ccache to not hash the real compiler's size and modification
++time. Normally this is the mechanism to detect compiler upgrades.
++There are situations however, where even though the compiler's size or
++modification time has changed you can safely use the cached objects
++(e.g. if as part of your build system the compiler is built as well
++and the compiler's source has not changed; or if the compiler has only
++changes that do not affect code generation). Use this feature only if
++you know what you are doing.
+ .IP
+ .IP "\fBCCACHE_UNIFY\fP"
+ If you set the environment variable CCACHE_UNIFY
diff --git a/devel/ccache/files/patch-ccache.c b/devel/ccache/files/patch-ccache.c
new file mode 100644
index 000000000000..7ee069ace02b
--- /dev/null
+++ b/devel/ccache/files/patch-ccache.c
@@ -0,0 +1,15 @@
+--- ccache.c.orig Mon Sep 13 06:38:30 2004
++++ ccache.c Tue Nov 15 14:59:46 2005
+@@ -331,8 +331,10 @@
+ hash_string(str_basename(args->argv[0]));
+ }
+
+- hash_int(st.st_size);
+- hash_int(st.st_mtime);
++ if (!getenv("CCACHE_NOHASH_SIZE_MTIME")) {
++ hash_int(st.st_size);
++ hash_int(st.st_mtime);
++ }
+
+ /* possibly hash the current working directory */
+ if (getenv("CCACHE_HASHDIR")) {