aboutsummaryrefslogtreecommitdiff
path: root/devel/ccache
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-03-09 21:05:23 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2017-03-09 21:05:23 +0000
commitce7bc2bba950951ca6cfa3b14eb6fc09c330d588 (patch)
tree4ad74506afbaf6fd7feeba3b57eb7edf270b84ef /devel/ccache
parent0a8c68093e3b838eb3232b08af3bdb103a3d7686 (diff)
downloadports-ce7bc2bba950951ca6cfa3b14eb6fc09c330d588.tar.gz
ports-ce7bc2bba950951ca6cfa3b14eb6fc09c330d588.zip
Notes
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile6
-rw-r--r--devel/ccache/files/extra-patch-memcached-Makefile.in11
-rw-r--r--devel/ccache/files/extra-patch-memcached-configure.ac31
3 files changed, 46 insertions, 2 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 015f4d1ce159..2bb62d4aabbd 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ccache
PORTVERSION= 3.3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
LOCAL/bdrewery
@@ -34,7 +34,9 @@ MEMCACHED_DESC= Build in experimental Memcached support
USES= compiler
MEMCACHED_EXTRA_PATCHES= ${FILESDIR}/extra-patch-memcached:-p1 \
- ${FILESDIR}/extra-patch-memcached-ccache.c
+ ${FILESDIR}/extra-patch-memcached-ccache.c \
+ ${FILESDIR}/extra-patch-memcached-configure.ac \
+ ${FILESDIR}/extra-patch-memcached-Makefile.in
MEMCACHED_CONFIGURE_ENABLE= memcached
MEMCACHED_USES= autoreconf pkgconfig
MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
diff --git a/devel/ccache/files/extra-patch-memcached-Makefile.in b/devel/ccache/files/extra-patch-memcached-Makefile.in
new file mode 100644
index 000000000000..2af101a56c43
--- /dev/null
+++ b/devel/ccache/files/extra-patch-memcached-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2017-03-09 13:00:34.016595000 -0800
++++ Makefile.in 2017-03-09 13:00:39.656086000 -0800
+@@ -74,7 +74,7 @@ files_to_distclean = Makefile config.h c
+ all: ccache$(EXEEXT)
+
+ ccache$(EXEEXT): $(ccache_objs) $(extra_libs)
+- $(CC) $(all_cflags) -o $@ $(ccache_objs) $(LDFLAGS) $(extra_libs) $(LIBS)
++ $(CXX) $(all_cflags) -o $@ $(ccache_objs) $(LDFLAGS) $(extra_libs) $(LIBS)
+
+ .PHONY: install
+ install: all $(srcdir)/ccache.1
diff --git a/devel/ccache/files/extra-patch-memcached-configure.ac b/devel/ccache/files/extra-patch-memcached-configure.ac
new file mode 100644
index 000000000000..b71e2d883875
--- /dev/null
+++ b/devel/ccache/files/extra-patch-memcached-configure.ac
@@ -0,0 +1,31 @@
+--- configure.ac.orig 2017-03-09 12:57:19.209816000 -0800
++++ configure.ac 2017-03-09 13:00:24.478539000 -0800
+@@ -28,6 +28,10 @@ AC_PROG_CC_C99
+ if test "$ac_cv_prog_cc_c99" = no; then
+ AC_MSG_ERROR(cannot find a C99-compatible compiler)
+ fi
++AC_PROG_CXX
++if test "$ac_cv_prog_cxx" = no; then
++ AC_MSG_ERROR(cannot find a C++-compatible compiler)
++fi
+
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+@@ -97,6 +101,9 @@ AC_ARG_ENABLE(memcached,
+ [AS_HELP_STRING([--enable-memcached],
+ [enable memcached as a cache backend])])
+
++# Need to use C++ compiler for linking -lmemcached as static, rather than
++# hacking in GCC's -lstdc++, since we may be using Clang.
++AC_LANG(C++)
+ dnl enable-memcached: Check if -lmemcached is needed.
+ if test x${enable_memcached} != x; then
+ if test x${enable_static} != x; then
+@@ -110,6 +117,7 @@ if test x${enable_memcached} != x; then
+ ])
+ ccache_memcached='CCACHE_MEMCACHED=1 '
+ fi
++AC_LANG(C)
+
+ dnl Check for zlib
+ AC_ARG_WITH(bundled-zlib,