aboutsummaryrefslogtreecommitdiff
path: root/devel/ccache
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2015-09-04 21:19:46 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2015-09-04 21:19:46 +0000
commit26ebbddc1c82dc21c2f960b27df2239e4b257770 (patch)
tree774a770faa7709641b778e3a9ba38c4cc79a0ad5 /devel/ccache
parentf2fa7195b05cd8ed0cc2b526328643b5ac201363 (diff)
downloadports-26ebbddc1c82dc21c2f960b27df2239e4b257770.tar.gz
ports-26ebbddc1c82dc21c2f960b27df2239e4b257770.zip
Notes
Diffstat (limited to 'devel/ccache')
-rw-r--r--devel/ccache/Makefile7
-rw-r--r--devel/ccache/distinfo4
-rw-r--r--devel/ccache/files/patch-configure11
-rw-r--r--devel/ccache/files/patch-configure.ac11
4 files changed, 29 insertions, 4 deletions
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 6a158555b38a..64352b91ab74 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= ccache
-PORTVERSION= 3.2.2
-PORTREVISION= 4
+PORTVERSION= 3.2.3
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://www.samba.org/ftp/ccache/ \
LOCAL/bdrewery
@@ -29,6 +29,9 @@ LLVMLINK_DESC= Create llvm compiler links if llvm is installed
TINDERBOX_DESC= Create tarball for tinderbox usage
USES= compiler
+# Don't allow autoreconf. We want no dependencies on this to keep
+# WITH_CCACHE_BUILD working.
+USES:= ${USES:Nautoreconf}
OPTIONS_SUB= yes
diff --git a/devel/ccache/distinfo b/devel/ccache/distinfo
index 40fd0eee683a..ba031e176528 100644
--- a/devel/ccache/distinfo
+++ b/devel/ccache/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ccache-3.2.2.tar.gz) = 5d1c719c7dfe8d0dffbb4aea3ab5a67b602b065219e1f8ba7bd9298915966587
-SIZE (ccache-3.2.2.tar.gz) = 436913
+SHA256 (ccache-3.2.3.tar.gz) = 43b2c0a0f7c8c89cecdc841b4ef55c626c9ca2bc80d5d746c91efcf81d224f6b
+SIZE (ccache-3.2.3.tar.gz) = 438086
diff --git a/devel/ccache/files/patch-configure b/devel/ccache/files/patch-configure
new file mode 100644
index 000000000000..8d72ddf4ff2a
--- /dev/null
+++ b/devel/ccache/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-09-04 21:15:56 UTC
++++ configure
+@@ -5682,7 +5682,7 @@ if test x${use_bundled_zlib} = xyes; the
+ extra_libs="zlib/libz.a"
+ mkdir -p zlib
+ else
+- extra_libs="-lz"
++ LIBS="$LIBS -lz"
+ fi
+
+ if test x${windows_os} = xyes; then
diff --git a/devel/ccache/files/patch-configure.ac b/devel/ccache/files/patch-configure.ac
new file mode 100644
index 000000000000..bc8288bb7313
--- /dev/null
+++ b/devel/ccache/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2015-08-16 12:12:05 UTC
++++ configure.ac
+@@ -120,7 +120,7 @@ if test x${use_bundled_zlib} = xyes; the
+ extra_libs="zlib/libz.a"
+ mkdir -p zlib
+ else
+- extra_libs="-lz"
++ LIBS="$LIBS -lz"
+ fi
+
+ dnl Linking on Windows needs ws2_32