aboutsummaryrefslogtreecommitdiff
path: root/devel/cccc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-07 09:31:43 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-07 09:31:43 +0000
commit102f1f624bf4ce8c02c650c402de544989668149 (patch)
treed0aae9417c31989408b05fc252eab106e64708fe /devel/cccc
parentfe8d6717786ffa35f4b9140b7a483239b48ffb08 (diff)
downloadports-102f1f624bf4ce8c02c650c402de544989668149.tar.gz
ports-102f1f624bf4ce8c02c650c402de544989668149.zip
Notes
Diffstat (limited to 'devel/cccc')
-rw-r--r--devel/cccc/Makefile31
-rw-r--r--devel/cccc/distinfo6
-rw-r--r--devel/cccc/files/patch-aa47
-rw-r--r--devel/cccc/files/patch-ab17
-rw-r--r--devel/cccc/files/patch-ac12
-rw-r--r--devel/cccc/files/patch-ad11
-rw-r--r--devel/cccc/files/patch-ae19
-rw-r--r--devel/cccc/files/patch-makefile25
-rw-r--r--devel/cccc/files/patch-pccts_makefile23
-rw-r--r--devel/cccc/pkg-descr6
-rw-r--r--devel/cccc/pkg-plist7
11 files changed, 68 insertions, 136 deletions
diff --git a/devel/cccc/Makefile b/devel/cccc/Makefile
index 755e469ce0a8..36ec1293b79b 100644
--- a/devel/cccc/Makefile
+++ b/devel/cccc/Makefile
@@ -7,12 +7,10 @@
#
PORTNAME= cccc
-PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTVERSION= 3.1.4
CATEGORIES= devel textproc www
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= devel/lang/c++
-DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cccc
MAINTAINER= ports@FreeBSD.org
COMMENT= C and C++ Code Counter
@@ -20,23 +18,14 @@ COMMENT= C and C++ Code Counter
BUILD_DEPENDS= antlr:${PORTSDIR}/devel/pccts \
dlg:${PORTSDIR}/devel/pccts
-WRKSRC= ${WRKDIR}/usr/local/src/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
MAKEFILE= makefile
-MAKE_ENV= OSTYPE=FreeBSD
-USE_GCC= 2.95
-PORTDOCS= readme.txt
-
-post-patch:
- ${REINPLACE_CMD} -e 's,=g++,=${CXX},g' ${WRKSRC}/${MAKEFILE}
+PORTDOCS= readme.txt changes.txt
+PLIST_FILES= bin/cccc
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/cccc ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
-.for f in cccc_inf.dat cccc_met.dat cccc_tmt.dat cccc_ug.htm
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
-.endfor
+ @${INSTALL_PROGRAM} ${WRKSRC}/cccc/cccc ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
@@ -44,4 +33,10 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/cccc/distinfo b/devel/cccc/distinfo
index a4f71f2b382e..71199c6314b8 100644
--- a/devel/cccc/distinfo
+++ b/devel/cccc/distinfo
@@ -1,3 +1,3 @@
-MD5 (cccc-2.1.1.src.tar.gz) = 6a5fb32de6987db0e3e13e6d58733b79
-SHA256 (cccc-2.1.1.src.tar.gz) = c904943a134183f0dce5ce898f272bfa434f5ee976f10778dded3b298dff75a3
-SIZE (cccc-2.1.1.src.tar.gz) = 74931
+MD5 (cccc-3.1.4.tar.gz) = 7bd3ad868913a0beab2fde931737f928
+SHA256 (cccc-3.1.4.tar.gz) = 27b3eca9a83a66799332363a80cc4bcd6db9869eddbda1a59a25cdace3ff4dbf
+SIZE (cccc-3.1.4.tar.gz) = 632007
diff --git a/devel/cccc/files/patch-aa b/devel/cccc/files/patch-aa
deleted file mode 100644
index 2bab59e2b4cb..000000000000
--- a/devel/cccc/files/patch-aa
+++ /dev/null
@@ -1,47 +0,0 @@
-*** makefile Sun Aug 10 16:52:24 1997
---- /home/andy/tmp/wrk/makefile Sat Sep 13 18:42:12 1997
-***************
-*** 12,17 ****
---- 12,21 ----
- CONF=djgpp
- endif
-
-+ ifeq "$(OSTYPE)" "FreeBSD"
-+ CONF=FreeBSD
-+ endif
-+
- ifeq "$(OSTYPE)" "Linux"
- CONF=linux
- endif
-***************
-*** 53,58 ****
---- 57,85 ----
- CCCC_BIN = ## the name of the cccc binary
- INSTALL_BINDIR = ## the location where the binary is to be installed
- INSTALL_LIBDIR = ## the location where the .dat files are to be installed
-+ endif
-+
-+ ifeq "$(CONF)" "FreeBSD"
-+
-+ ## preferred directories for FreeBSD is under /usr/local tree
-+ ## we need pccts installed from package
-+ PCCTS = $(LOCALBASE)
-+ PCCTS_H = $(PCCTS)/include/pccts
-+ PCCTS_BIN = $(PCCTS)/bin
-+
-+ ## using the GNU C++ compiler
-+ ## we need working templates - I use version 2.7.2, I am not sure whether
-+ ## versions earlier than 2.7 are OK
-+ CCC=g++
-+ LD=g++
-+ CFLAGS+= -I/usr/include/g++-include -I. -I$(PCCTS_H)
-+ CPPEXT=cpp
-+
-+ COPY = cp
-+ CCCC_BIN = cccc
-+ INSTALL_BINDIR = $(PREFIX)/bin
-+ INSTALL_LIBDIR = $(PREFIX)/share/cccc
-+
- endif
-
- ifeq "$(CONF)" "linux"
diff --git a/devel/cccc/files/patch-ab b/devel/cccc/files/patch-ab
deleted file mode 100644
index 105138c82d32..000000000000
--- a/devel/cccc/files/patch-ab
+++ /dev/null
@@ -1,17 +0,0 @@
---- cccc.h.orig Sun Aug 10 09:52:24 1997
-+++ cccc.h Sun Apr 18 11:47:39 1999
-@@ -20,8 +20,13 @@
-
- #else
-
--#define SIGNAL_HEADER <sys/signal.h>
-+#ifdef __FreeBSD__
-+#define SIGNAL_HEADER <signal.h>
-+#define DEFAULT_LIBDIR "/usr/local/share/cccc"
-+#else
- #define DEFAULT_LIBDIR "/usr/local/lib/cccc"
-+#define SIGNAL_HEADER <sys/signal.h>
-+#endif
-
- #endif
-
diff --git a/devel/cccc/files/patch-ac b/devel/cccc/files/patch-ac
deleted file mode 100644
index 5042ca223dc6..000000000000
--- a/devel/cccc/files/patch-ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- cccc_utl.cc.orig Thu Mar 30 12:22:38 2000
-+++ cccc_utl.cc Thu Mar 30 12:25:29 2000
-@@ -212,7 +212,8 @@
- for(i=0;i<pssLAST; i++) {
- CCCC_String sep;
- if(i==pssMODULE) { sep="::"; } else { sep=" "; }
-- if(string[i]!="") { os << string[i] << sep; }
-+ if(static_cast<const char*>(string[i])!="")
-+ os << string[i] << sep;
- }
- os << " Attributes: ";
- for(i=0; i<psfLAST; i++) {
diff --git a/devel/cccc/files/patch-ad b/devel/cccc/files/patch-ad
deleted file mode 100644
index 8273415f149a..000000000000
--- a/devel/cccc/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- cccc_ast.h.orig Thu Mar 30 12:12:38 2000
-+++ cccc_ast.h Thu Mar 30 12:13:01 2000
-@@ -72,7 +72,7 @@
- int nEndLine();
-
- // access function for counts accumulated from tokens included in the AST
-- getCount(TokenCount tc);
-+ int getCount(TokenCount tc);
-
- char *filename, *classname, *membername;
-
diff --git a/devel/cccc/files/patch-ae b/devel/cccc/files/patch-ae
deleted file mode 100644
index 47d52a139cb2..000000000000
--- a/devel/cccc/files/patch-ae
+++ /dev/null
@@ -1,19 +0,0 @@
---- cccc_stg.h.orig Sun Aug 10 18:52:24 1997
-+++ cccc_stg.h Sun Jan 12 15:15:42 2003
-@@ -13,6 +13,7 @@
- #include <string.h>
- #include <iostream.h>
- #include <strstream.h>
-+#include <fstream.h>
-
- class CCCC_String {
- char *cptr;
-@@ -63,7 +64,7 @@
- // we will deliberately read too many characters from the stream,
- // so the first thing we do is to mark our current position
- streampos start=is.tellg();
-- int state=is.rdstate();
-+ istream::iostate state=is.rdstate();
-
- char buffer[MAX_IN_SIZE];
- memset(buffer,0,MAX_IN_SIZE);
diff --git a/devel/cccc/files/patch-makefile b/devel/cccc/files/patch-makefile
new file mode 100644
index 000000000000..f7132150fbde
--- /dev/null
+++ b/devel/cccc/files/patch-makefile
@@ -0,0 +1,25 @@
+--- makefile.orig Wed Apr 25 18:30:29 2001
++++ makefile Mon Sep 4 21:17:17 2006
+@@ -8,17 +8,17 @@
+
+ .PHONY : pccts cccc test install
+
+-all : pccts cccc test install
++all : pccts cccc test
+
+ pccts :
+- cd pccts ; make
++ cd pccts ; gmake
+
+ cccc :
+- cd cccc ; make -f posixgcc.mak
++ cd cccc ; gmake -f posixgcc.mak
+
+ test :
+- cd test ; make -f posix.mak
++ cd test ; gmake -f posix.mak
+
+ install :
+- cd install ; su root -c "make -f install.mak"
++ cd install ; gmake -f install.mak
+
diff --git a/devel/cccc/files/patch-pccts_makefile b/devel/cccc/files/patch-pccts_makefile
new file mode 100644
index 000000000000..c57645ec4570
--- /dev/null
+++ b/devel/cccc/files/patch-pccts_makefile
@@ -0,0 +1,23 @@
+--- pccts/makefile.orig Mon Sep 4 21:13:16 2006
++++ pccts/makefile Mon Sep 4 21:13:28 2006
+@@ -41,16 +41,16 @@
+ #
+ if [ ! -d $(BINDIR) ] ; then mkdir $(BINDIR) ; fi
+ echo Making executables...
+- (cd antlr; make -s)
++ (cd antlr; gmake -s)
+ echo antlr executable now in $(BINDIR)
+- (cd dlg; make -s)
++ (cd dlg; gmake -s)
+ echo dlg executable now in $(BINDIR)
+ echo
+ echo " PCCTS 1.33MR20 installation complete"
+
+ clean:
+- (cd antlr; make -s clean)
+- (cd dlg; make -s clean)
++ (cd antlr; gmake -s clean)
++ (cd dlg; gmake -s clean)
+
+
+ manpages:
diff --git a/devel/cccc/pkg-descr b/devel/cccc/pkg-descr
index f186d9caf5d0..fe87be5ca680 100644
--- a/devel/cccc/pkg-descr
+++ b/devel/cccc/pkg-descr
@@ -1,4 +1,6 @@
-Source code metric analyser for C, C++, Java and Ada
+Source code metric analyser for C, C++ and Java.
Presents a report in HTML with figures for
Lines of Code, McCabes Complexity, Ratio of Comments
-to Lines of Code and McCabe, module Fan-In and Fan-Out
+to Lines of Code and McCabe, module Fan-In and Fan-Out.
+
+WWW: http://cccc.sourceforge.net/
diff --git a/devel/cccc/pkg-plist b/devel/cccc/pkg-plist
deleted file mode 100644
index 8c18b7e5c51a..000000000000
--- a/devel/cccc/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-@comment $FreeBSD$
-bin/cccc
-%%DATADIR%%/cccc_inf.dat
-%%DATADIR%%/cccc_met.dat
-%%DATADIR%%/cccc_tmt.dat
-%%DATADIR%%/cccc_ug.htm
-@dirrm %%DATADIR%%