aboutsummaryrefslogtreecommitdiff
path: root/devel/cdk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
commit8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f (patch)
tree82565381028ebd8b5a674bafdecce3a45c5c2e6d /devel/cdk
parent0a59b351f616abe849539bc2afbc8eba4abe8004 (diff)
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Notes
Notes: svn path=/head/; revision=272515
Diffstat (limited to 'devel/cdk')
-rw-r--r--devel/cdk/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 9fb7caea1cc2..c5c0412cf291 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -20,24 +20,13 @@ COMMENT= Curses Development Kit for speedy development of full screen programs
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
USE_GMAKE= yes
+USE_NCURSES= yes
GNU_CONFIGURE= yes
PORTDOCS= COPYING EXPANDING INSTALL NOTES README TODO
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/include/ncurses/ncurses.h)
-TERMINFO= ${LOCALBASE}/share/misc/terminfo
-CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/ncurses
-LIBS+= -L${LOCALBASE}/lib -lncurses
-LDFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
-CONFIGURE_ENV+= TERMINFO="${TERMINFO}"\
- CPPFLAGS="${CPPFLAGS}"\
- LIBS="${LIBS}"\
- LDFLAGS="${LDFLAGS}"
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif # exists(${LOCALBASE}/include/ncurses/ncurses.h)
-
CONFIGURE_ARGS+=--with-ncurses
ALL_TARGET= default examples demos cli cdkshlib
INSTALL_TARGET= install installCDKSHLibrary