aboutsummaryrefslogtreecommitdiff
path: root/devel/cdoc
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-01 15:46:55 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-01 15:46:55 +0000
commit7e48bb0d98d977956d597952ecb7ec5cff266bf9 (patch)
treece677b15b4df1575bfd5d172245746714c2ddcd3 /devel/cdoc
parent8fb07c4a37fb81824921db5648e80a34f476ea65 (diff)
downloadports-7e48bb0d98d977956d597952ecb7ec5cff266bf9.tar.gz
ports-7e48bb0d98d977956d597952ecb7ec5cff266bf9.zip
Notes
Diffstat (limited to 'devel/cdoc')
-rw-r--r--devel/cdoc/Makefile35
-rw-r--r--devel/cdoc/distinfo1
-rw-r--r--devel/cdoc/pkg-comment1
-rw-r--r--devel/cdoc/pkg-descr6
-rw-r--r--devel/cdoc/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/cdoc/Makefile b/devel/cdoc/Makefile
new file mode 100644
index 000000000000..00055c60fcd0
--- /dev/null
+++ b/devel/cdoc/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: cdoc
+# Date created: 2002-12-22
+# Whom: Alan Eldridge <alane@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cdoc
+PORTVERSION= 0.9.6
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+MASTER_SITES= http://www.annexia.org/freeware/${PORTNAME}/
+
+MAINTAINER= alane@FreeBSD.org
+
+BUILD_REQUIRES+=make+:${.CURDIR}/../makeplus
+
+USE_GMAKE= yes
+USE_PERL5_RUN= yes
+PREFIX?= ${LOCALBASE}
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ cd ${WRKSRC}; make+
+
+do-install:
+ cd ${WRKSRC}; make+ install prefix=${PREFIX}
+
+.include <bsd.port.post.mk>
+
+#EOF
diff --git a/devel/cdoc/distinfo b/devel/cdoc/distinfo
new file mode 100644
index 000000000000..e76daf213cbc
--- /dev/null
+++ b/devel/cdoc/distinfo
@@ -0,0 +1 @@
+MD5 (cdoc-0.9.6.tar.gz) = 438f738db520b09c3a0de5da77258673
diff --git a/devel/cdoc/pkg-comment b/devel/cdoc/pkg-comment
new file mode 100644
index 000000000000..b20578dcc5e3
--- /dev/null
+++ b/devel/cdoc/pkg-comment
@@ -0,0 +1 @@
+Extracts documentation from C source code comments
diff --git a/devel/cdoc/pkg-descr b/devel/cdoc/pkg-descr
new file mode 100644
index 000000000000..443b8933ad06
--- /dev/null
+++ b/devel/cdoc/pkg-descr
@@ -0,0 +1,6 @@
+Cdoc extracts documentation from C source code comments. It is used by
+c2lib. pthrlib, and other code by the same author.
+
+WWW: http://www.annexia.org/freeware/
+
+-- AlanE
diff --git a/devel/cdoc/pkg-plist b/devel/cdoc/pkg-plist
new file mode 100644
index 000000000000..a08e03ba0f70
--- /dev/null
+++ b/devel/cdoc/pkg-plist
@@ -0,0 +1 @@
+bin/cdoc