aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-04-28 22:51:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-04-28 22:51:17 +0000
commit41a0e575f501570bf063c6321302bb483ca4ff0b (patch)
tree10ab2624eb9cfaf3ccdd42e31d7ed80007401896 /devel/cgit
parent2a3cca464d2973c6f034dc1d84ffa41998569e42 (diff)
- Fix build avoiding collision of archive.h from git and the one from libarchive
when libarchive is installed from ports Reported by: Andrzej Tobola <ato@iem.pw.edu.pl> (by private mail)
Notes
Notes: svn path=/head/; revision=295658
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile3
-rw-r--r--devel/cgit/files/patch-cgit.h47
2 files changed, 49 insertions, 1 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 188e2a2d214e..ed150f0c229b 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -43,7 +43,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^CC =/d' ${WRKSRC}/git/Makefile
@${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' \
- -e 's,/usr,${PREFIX},g' ${WRKSRC}/Makefile
+ -e 's,/usr,${PREFIX},g' \
+ -e 's,-Igit,-I.,g' ${WRKSRC}/Makefile
post-install:
@${MKDIR} /var/cache/${PORTNAME}
diff --git a/devel/cgit/files/patch-cgit.h b/devel/cgit/files/patch-cgit.h
new file mode 100644
index 000000000000..b7227664d9be
--- /dev/null
+++ b/devel/cgit/files/patch-cgit.h
@@ -0,0 +1,47 @@
+--- cgit.h.orig 2012-03-18 11:16:27.000000000 +0100
++++ cgit.h 2012-04-29 00:43:18.784960000 +0200
+@@ -2,25 +2,25 @@
+ #define CGIT_H
+
+
+-#include <git-compat-util.h>
+-#include <cache.h>
+-#include <grep.h>
+-#include <object.h>
+-#include <tree.h>
+-#include <commit.h>
+-#include <tag.h>
+-#include <diff.h>
+-#include <diffcore.h>
+-#include <refs.h>
+-#include <revision.h>
+-#include <log-tree.h>
+-#include <archive.h>
+-#include <string-list.h>
+-#include <xdiff-interface.h>
+-#include <xdiff/xdiff.h>
+-#include <utf8.h>
+-#include <notes.h>
+-#include <graph.h>
++#include <git/git-compat-util.h>
++#include <git/cache.h>
++#include <git/grep.h>
++#include <git/object.h>
++#include <git/tree.h>
++#include <git/commit.h>
++#include <git/tag.h>
++#include <git/diff.h>
++#include <git/diffcore.h>
++#include <git/refs.h>
++#include <git/revision.h>
++#include <git/log-tree.h>
++#include <git/archive.h>
++#include <git/string-list.h>
++#include <git/xdiff-interface.h>
++#include <git/xdiff/xdiff.h>
++#include <git/utf8.h>
++#include <git/notes.h>
++#include <git/graph.h>
+
+
+ /*