aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-09-25 21:18:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-09-25 21:18:21 +0000
commit3c6bb6bb0468d04eccfd6e0b3b1021c6d8b2f244 (patch)
treeb5787b25cf4bcbb0097e4a87520ec15e723cfab2 /devel/cgit
parent48e6d5f42a52d0173263e5279187ee076bafe5e0 (diff)
downloadports-3c6bb6bb0468d04eccfd6e0b3b1021c6d8b2f244.tar.gz
ports-3c6bb6bb0468d04eccfd6e0b3b1021c6d8b2f244.zip
Notes
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile5
-rw-r--r--devel/cgit/files/pkg-message.in2
-rw-r--r--devel/cgit/pkg-plist1
3 files changed, 6 insertions, 2 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index f454d3827c9a..c422eb2af768 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -7,13 +7,13 @@
PORTNAME= cgit
PORTVERSION= 0.9.0.2
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= http://hjemli.net/git/cgit/snapshot/:cgit \
${MASTER_SITE_KERNEL_ORG:S/$/:git/g}
MASTER_SITE_SUBDIR= software/scm/git/:git
DISTFILES= cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
git-${GIT_VERSION}.tar.bz2:git
-GIT_VERSION= 1.7.4
MAINTAINER= bapt@FreeBSD.org
COMMENT= A fast webinterface for git
@@ -21,6 +21,7 @@ COMMENT= A fast webinterface for git
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+GIT_VERSION= 1.7.4
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
@@ -34,6 +35,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
+PLIST_SUB+= PORTNAME=${PORTNAME}
post-extract:
@${RMDIR} ${WRKSRC}/git
@@ -47,6 +49,7 @@ post-patch:
post-install:
@${MKDIR} /var/cache/${PORTNAME}
@${CHOWN} ${WWWOWN}:${WWWGRP} /var/cache/${PORTNAME}
+ @${CAT} ${PKGMESSAGE}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
diff --git a/devel/cgit/files/pkg-message.in b/devel/cgit/files/pkg-message.in
index 6f93d73ebc0d..ac77ea940629 100644
--- a/devel/cgit/files/pkg-message.in
+++ b/devel/cgit/files/pkg-message.in
@@ -4,7 +4,7 @@
Now you need to change your webserver configuration
as follows:
- <Directory "%%WWWDIR%%/cgit/">
+ <Directory "%%WWWDIR%%/">
AllowOverride None
Options ExecCGI
Order allow,deny
diff --git a/devel/cgit/pkg-plist b/devel/cgit/pkg-plist
index be168aee2903..87cd71c392d5 100644
--- a/devel/cgit/pkg-plist
+++ b/devel/cgit/pkg-plist
@@ -10,3 +10,4 @@ lib/cgit/filters/syntax-highlighting.sh
@dirrm %%WWWDIR%%
@exec mkdir -p /var/cache/%%PORTNAME%%
@unexec rmdir /var/cache/%%PORTNAME%% 2>/dev/null || true
+@unexec rmdir /var/cache 2>/dev/null || true