aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-29 10:06:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-29 10:06:04 +0000
commitaa3d43c3f3ecae24d245af717943d1bc5318d933 (patch)
tree65317fcabf8b66d5751c14063eb2d51da57af5d8 /devel/cgit
parentccbdcd78d8d5abdb1022c7753f707d579e526f61 (diff)
downloadports-aa3d43c3f3ecae24d245af717943d1bc5318d933.tar.gz
ports-aa3d43c3f3ecae24d245af717943d1bc5318d933.zip
Notes
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile16
-rw-r--r--devel/cgit/distinfo8
-rw-r--r--devel/cgit/files/patch-Makefile23
-rw-r--r--devel/cgit/files/patch-cgit.h47
-rw-r--r--devel/cgit/files/patch-git__Makefile13
5 files changed, 12 insertions, 95 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 8414a0b2ed68..dc7b2bde7126 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -2,30 +2,30 @@
# $FreeBSD$
PORTNAME= cgit
-PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTVERSION= 0.9.2
CATEGORIES= devel www
MASTER_SITES= http://git.zx2c4.com/cgit/snapshot/:cgit \
- http://mirror.linux.org.au/software/scm/git/:git
+ GOOGLE_CODE:git
DISTFILES= cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
- git-${GIT_VERSION}.tar.bz2:git
+ git-${GIT_VERSION}.tar.gz:git
MAINTAINER= bapt@FreeBSD.org
COMMENT= A fast webinterface for git
LICENSE= GPLv2
-GIT_VERSION= 1.7.4.4
+PROJECTHOST= git-core
+GIT_VERSION= 1.8.2.3
USE_BZIP2= yes
USE_GMAKE= yes
USES= iconv
USE_GMAKE= yes
USE_OPENSSL= yes
CFLAGS+= -I${LOCALBASE}/include
-MAKE_ENV+= CGIT_SCRIPT_PATH=${WWWDIR} \
- CGIT_CONFIG=${PREFIX}/etc/cgitrc \
- NEEDS_LIBICONV=yes
+MAKE_ARGS+= CGIT_SCRIPT_PATH=${WWWDIR} \
+ CGIT_CONFIG=${PREFIX}/etc/cgitrc
LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
diff --git a/devel/cgit/distinfo b/devel/cgit/distinfo
index f4e3901211c2..57160a9fd748 100644
--- a/devel/cgit/distinfo
+++ b/devel/cgit/distinfo
@@ -1,4 +1,4 @@
-SHA256 (cgit-0.9.1.tar.bz2) = 315ba675e89f19c5db91d0694f8437aea8c85ece0422c38721bcd49e317bfbb7
-SIZE (cgit-0.9.1.tar.bz2) = 67736
-SHA256 (git-1.7.4.4.tar.bz2) = 5c3e738b01a4021ade56abebfdcce8825d2a50868e5c7befb65102f497387aa0
-SIZE (git-1.7.4.4.tar.bz2) = 2709587
+SHA256 (cgit-0.9.2.tar.bz2) = 165dc09e1334416029c3dba0c957fe8e872abad85f459d4a040631dd4dab411a
+SIZE (cgit-0.9.2.tar.bz2) = 84881
+SHA256 (git-1.8.2.3.tar.gz) = ba8d42d47b0955b17905af0133b01ab8e3f28f0e39b9967ec446403c0b49991f
+SIZE (git-1.8.2.3.tar.gz) = 4405610
diff --git a/devel/cgit/files/patch-Makefile b/devel/cgit/files/patch-Makefile
deleted file mode 100644
index 06dde653813d..000000000000
--- a/devel/cgit/files/patch-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./Makefile.orig 2011-03-05 14:23:12.000000000 +0100
-+++ ./Makefile 2011-03-07 13:03:16.000000000 +0100
-@@ -1,8 +1,8 @@
- CGIT_VERSION = v0.9
- CGIT_SCRIPT_NAME = cgit.cgi
--CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
--CGIT_DATA_PATH = $(CGIT_SCRIPT_PATH)
--CGIT_CONFIG = /etc/cgitrc
-+CGIT_SCRIPT_PATH ?= /var/www/htdocs/cgit
-+CGIT_DATA_PATH ?= $(CGIT_SCRIPT_PATH)
-+CGIT_CONFIG ?= /etc/cgitrc
- CACHE_ROOT = /var/cache/cgit
- prefix = /usr
- libdir = $(prefix)/lib
-@@ -118,7 +118,7 @@
- OBJECTS += vector.o
-
- ifdef NEEDS_LIBICONV
-- EXTLIBS += -liconv
-+ EXTLIBS += -L$(LOCALBASE)/lib -liconv
- endif
-
-
diff --git a/devel/cgit/files/patch-cgit.h b/devel/cgit/files/patch-cgit.h
deleted file mode 100644
index b7227664d9be..000000000000
--- a/devel/cgit/files/patch-cgit.h
+++ /dev/null
@@ -1,47 +0,0 @@
---- cgit.h.orig 2012-03-18 11:16:27.000000000 +0100
-+++ cgit.h 2012-04-29 00:43:18.784960000 +0200
-@@ -2,25 +2,25 @@
- #define CGIT_H
-
-
--#include <git-compat-util.h>
--#include <cache.h>
--#include <grep.h>
--#include <object.h>
--#include <tree.h>
--#include <commit.h>
--#include <tag.h>
--#include <diff.h>
--#include <diffcore.h>
--#include <refs.h>
--#include <revision.h>
--#include <log-tree.h>
--#include <archive.h>
--#include <string-list.h>
--#include <xdiff-interface.h>
--#include <xdiff/xdiff.h>
--#include <utf8.h>
--#include <notes.h>
--#include <graph.h>
-+#include <git/git-compat-util.h>
-+#include <git/cache.h>
-+#include <git/grep.h>
-+#include <git/object.h>
-+#include <git/tree.h>
-+#include <git/commit.h>
-+#include <git/tag.h>
-+#include <git/diff.h>
-+#include <git/diffcore.h>
-+#include <git/refs.h>
-+#include <git/revision.h>
-+#include <git/log-tree.h>
-+#include <git/archive.h>
-+#include <git/string-list.h>
-+#include <git/xdiff-interface.h>
-+#include <git/xdiff/xdiff.h>
-+#include <git/utf8.h>
-+#include <git/notes.h>
-+#include <git/graph.h>
-
-
- /*
diff --git a/devel/cgit/files/patch-git__Makefile b/devel/cgit/files/patch-git__Makefile
deleted file mode 100644
index ba30170c78cd..000000000000
--- a/devel/cgit/files/patch-git__Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- git/Makefile.orig 2009-06-08 16:20:54.000000000 +0200
-+++ git/Makefile 2009-06-08 16:21:48.000000000 +0200
-@@ -692,8 +692,8 @@
- ifeq ($(uname_S),FreeBSD)
- NEEDS_LIBICONV = YesPlease
- NO_MEMMEM = YesPlease
-- BASIC_CFLAGS += -I/usr/local/include
-- BASIC_LDFLAGS += -L/usr/local/lib
-+ BASIC_CFLAGS += -I${LOCALBASE}/include
-+ BASIC_LDFLAGS += -L${LOCALBASE}/lib
- DIR_HAS_BSD_GROUP_SEMANTICS = YesPlease
- THREADED_DELTA_SEARCH = YesPlease
- ifeq ($(shell expr "$(uname_R)" : '4\.'),2)