aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-10-16 11:26:36 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-10-16 11:26:36 +0000
commit9335969ae86787cdfdcf053940c0799d285a65ab (patch)
tree2327cd5634f5d62038f118679908acb2330af5e2 /devel/cgit
parentc781418d6d893224fbc4b20adb21cd09a156e8c7 (diff)
downloadports-9335969ae86787cdfdcf053940c0799d285a65ab.tar.gz
ports-9335969ae86787cdfdcf053940c0799d285a65ab.zip
Notes
Diffstat (limited to 'devel/cgit')
-rw-r--r--devel/cgit/Makefile42
-rw-r--r--devel/cgit/distinfo6
-rw-r--r--devel/cgit/files/patch-Makefile23
-rw-r--r--devel/cgit/files/patch-git_Makefile38
-rw-r--r--devel/cgit/files/pkg-message.in16
-rw-r--r--devel/cgit/pkg-descr7
-rw-r--r--devel/cgit/pkg-plist7
7 files changed, 139 insertions, 0 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
new file mode 100644
index 000000000000..2f02472573a1
--- /dev/null
+++ b/devel/cgit/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: cgit
+# Date created: Oct 16 2008
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cgit
+PORTVERSION= 0.8.1
+CATEGORIES= devel www
+MASTER_SITES= http://hjemli.net/git/cgit/snapshot/:cgit \
+ http://www.kernel.org/pub/software/scm/git/:git
+DISTFILES= cgit-${SHA1}${EXTRACT_SUFX}:cgit \
+ git-${GIT_VERSION}.tar.bz2:git
+SHA1= 140012d7a8e51df5a9f9c556696778b86ade4fc9
+GIT_VERSION= 1.6.0.2
+
+MAINTAINER= flz@FreeBSD.org
+COMMENT= A fast webinterface for git
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+CFLAGS+= -I${LOCALBASE}/include
+MAKE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" \
+ CGIT_SCRIPT_PATH=${WWWDIR} \
+ CGIT_CONFIG=${PREFIX}/etc/cgitrc
+
+SUB_FILES= pkg-message
+
+post-extract:
+ @${RMDIR} ${WRKSRC}/git
+ @${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
+
+post-install:
+ @${MKDIR} /var/cache/${PORTNAME} ${DOCSDIR}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} /var/cache/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}rc.5.txt ${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/devel/cgit/distinfo b/devel/cgit/distinfo
new file mode 100644
index 000000000000..fe326f4f1bfd
--- /dev/null
+++ b/devel/cgit/distinfo
@@ -0,0 +1,6 @@
+MD5 (cgit-140012d7a8e51df5a9f9c556696778b86ade4fc9.tar.gz) = 97865898c639c9afe22fbd410f43d9cd
+SHA256 (cgit-140012d7a8e51df5a9f9c556696778b86ade4fc9.tar.gz) = 1a74896d5cc0ea735b4a70701b95fddf8d72931fabb678c8652fa7a1b6392b1f
+SIZE (cgit-140012d7a8e51df5a9f9c556696778b86ade4fc9.tar.gz) = 52192
+MD5 (git-1.6.0.2.tar.bz2) = 1e4d9bfc1cb0abf165d4de93b5172324
+SHA256 (git-1.6.0.2.tar.bz2) = a332fbcb1c9cf8b1dc224135d5b14e99da4720fc8b082e595b4f20eaf640dad8
+SIZE (git-1.6.0.2.tar.bz2) = 1865485
diff --git a/devel/cgit/files/patch-Makefile b/devel/cgit/files/patch-Makefile
new file mode 100644
index 000000000000..d1b909a2f137
--- /dev/null
+++ b/devel/cgit/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig 2008-04-14 23:00:11.000000000 +0100
++++ Makefile 2008-04-17 01:29:10.000000000 +0100
+@@ -1,8 +1,8 @@
+ CGIT_VERSION = v0.7.2
+ CGIT_SCRIPT_NAME = cgit.cgi
+-CGIT_SCRIPT_PATH = /var/www/htdocs/cgit
+-CGIT_CONFIG = /etc/cgitrc
+-CACHE_ROOT = /var/cache/cgit
++CGIT_SCRIPT_PATH ?= /var/www/htdocs/cgit
++CGIT_CONFIG ?= /etc/cgitrc
++CACHE_ROOT ?= /var/cache/cgit
+ SHA1_HEADER = <openssl/sha.h>
+ GIT_VER = 1.5.5
+ GIT_URL = http://www.kernel.org/pub/software/scm/git/git-$(GIT_VER).tar.bz2
+@@ -46,7 +46,7 @@
+ $(QUIET_CC)$(CC) -o $*.o -c $(CFLAGS) $<
+
+
+-EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto
++EXTLIBS = git/libgit.a git/xdiff/lib.a -lz -lcrypto -L${LOCALBASE}/lib -liconv
+ OBJECTS =
+ OBJECTS += cache.o
+ OBJECTS += cgit.o
diff --git a/devel/cgit/files/patch-git_Makefile b/devel/cgit/files/patch-git_Makefile
new file mode 100644
index 000000000000..32ba3889aed6
--- /dev/null
+++ b/devel/cgit/files/patch-git_Makefile
@@ -0,0 +1,38 @@
+--- git/Makefile.orig 2008-01-15 12:21:54.000000000 +0000
++++ git/Makefile 2008-01-15 12:25:23.000000000 +0000
+@@ -135,8 +135,8 @@
+
+ # CFLAGS and LDFLAGS are for the users to override from the command line.
+
+-CFLAGS = -g -O2 -Wall
+-LDFLAGS =
++CFLAGS ?= -g -O2 -Wall
++LDFLAGS ?=
+ ALL_CFLAGS = $(CFLAGS)
+ ALL_LDFLAGS = $(LDFLAGS)
+ STRIP ?= strip
+@@ -173,15 +173,15 @@
+
+ export prefix bindir gitexecdir sharedir template_dir sysconfdir
+
+-CC = gcc
+-AR = ar
+-RM = rm -f
+-TAR = tar
+-FIND = find
+-INSTALL = install
+-RPMBUILD = rpmbuild
+-TCL_PATH = tclsh
+-TCLTK_PATH = wish
++CC ?= gcc
++AR ?= ar
++RM ?= rm -f
++TAR ?= tar
++FIND ?= find
++INSTALL ?= install
++RPMBUILD ?= rpmbuild
++TCL_PATH ?= tclsh
++TCLTK_PATH ?= wish
+
+ export TCL_PATH TCLTK_PATH
+
diff --git a/devel/cgit/files/pkg-message.in b/devel/cgit/files/pkg-message.in
new file mode 100644
index 000000000000..6f93d73ebc0d
--- /dev/null
+++ b/devel/cgit/files/pkg-message.in
@@ -0,0 +1,16 @@
+---------------------------------------------------
+%%PORTNAME%% has been successfully installed.
+
+Now you need to change your webserver configuration
+as follows:
+
+ <Directory "%%WWWDIR%%/cgit/">
+ AllowOverride None
+ Options ExecCGI
+ Order allow,deny
+ Allow from all
+ </Directory>
+
+Documentation and sample configuration can be found
+in %%DOCSDIR%%/cgitrc.5.txt.
+---------------------------------------------------
diff --git a/devel/cgit/pkg-descr b/devel/cgit/pkg-descr
new file mode 100644
index 000000000000..cad7618bfdb4
--- /dev/null
+++ b/devel/cgit/pkg-descr
@@ -0,0 +1,7 @@
+Cgit is an attempt to create a fast web interface for the git scm, using
+a builtin cache to decrease server io-pressure.
+
+WWW: http://hjemli.net/git/
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/devel/cgit/pkg-plist b/devel/cgit/pkg-plist
new file mode 100644
index 000000000000..57a478f6bdca
--- /dev/null
+++ b/devel/cgit/pkg-plist
@@ -0,0 +1,7 @@
+%%WWWDIR%%/cgit.cgi
+%%WWWDIR%%/cgit.css
+%%WWWDIR%%/cgit.png
+%%PORTDOCS%%%%DOCSDIR%%/cgitrc.5.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec mkdir -p /var/cache/%%PORTNAME%%
+@unexec rmdir /var/cache/%%PORTNAME%% 2>/dev/null || true