aboutsummaryrefslogtreecommitdiff
path: root/devel/chora
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
commite23ee358fa1ac94e411715abac088791dc154c19 (patch)
tree2f2d07d89e8f9b0b1bbbaa61fc0a3c53d8b1308c /devel/chora
parent8931540e0ace91aa22d2f957ccaefa11eb78adca (diff)
downloadports-e23ee358fa1ac94e411715abac088791dc154c19.tar.gz
ports-e23ee358fa1ac94e411715abac088791dc154c19.zip
Notes
Diffstat (limited to 'devel/chora')
-rw-r--r--devel/chora/Makefile26
-rw-r--r--devel/chora/distinfo1
-rw-r--r--devel/chora/files/pkg-deinstall.in (renamed from devel/chora/pkg-deinstall)2
-rw-r--r--devel/chora/pkg-plist2
4 files changed, 20 insertions, 11 deletions
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index 58a574981fee..b093bdd53d25 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -49,6 +49,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/cvsgraph:${PORTSDIR}/devel/cvsgraph
.endif
NO_BUILD= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_REINPLACE= yes
# Specify where your repository belongs.
@@ -62,23 +63,32 @@ DOCS= COPYING README docs/BUGS docs/CHANGES docs/CREDITS \
CONFFILE= cvsgraph.conf longIntro.txt mime_drivers.php prefs.php \
sourceroots.php
SUB_DIRS= config lib locale po templates themes
-PKGMESSAGE= ${WRKDIR}/pkg-message
LHORDEDIR?= www/horde
LCHORADIR= ${LHORDEDIR}/chora
-PLIST_SUB= CHORADIR=${LCHORADIR}
+PLIST_SUB= CHORADIR=${LCHORADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= CHORADIR=${CHORADIR} CONFDIR=${CONFDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
CONFDIR= ${CHORADIR}/config
-HORDE_INC= ${LOCALBASE}/etc/horde
-
PATCH2RM= sourceroots.php.dist.orig sourceroots.php.dist.bak conf.xml.bak
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
+HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
+
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:" \
- ${FILESDIR}/httpd.conf.chora > ${WRKDIR}/httpd.conf.chora
+ ${FILESDIR}/httpd.conf.chora > ${WRKDIR}/httpd-chora.conf
@${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" \
-e "s|/usr/bin/cvsgraph|${LOCALBASE}/bin/cvsgraph|" \
-e "s|/usr/bin/svn|${LOCALBASE}/bin/svn|" \
@@ -111,7 +121,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.chora ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-chora.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -121,10 +131,8 @@ do-install:
.endif
post-install:
- @${SED} -e "s:%%CHORADIR%%:${CHORADIR}:;s:%%CONFDIR%%:${CONFDIR}:" \
- < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/chora/distinfo b/devel/chora/distinfo
index 825cac622628..480790e21cd1 100644
--- a/devel/chora/distinfo
+++ b/devel/chora/distinfo
@@ -1,2 +1,3 @@
MD5 (chora-h3-2.0.1.tar.gz) = 8f3f3e81c839e6f13b797ab911b53652
+SHA256 (chora-h3-2.0.1.tar.gz) = 166b125f08aae7ebda5af7a58bf30c87d7bb4af7a5d3eff8f2429e10d2bd0325
SIZE (chora-h3-2.0.1.tar.gz) = 722536
diff --git a/devel/chora/pkg-deinstall b/devel/chora/files/pkg-deinstall.in
index 02a46f12daa8..0ef032fe5654 100644
--- a/devel/chora/pkg-deinstall
+++ b/devel/chora/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/chora/config/*php ${PKG_PREFIX}/www/horde/chora/config/*txt`; do
+ for cf in `ls %%CHORADIR%%/config/*php %%CHORADIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/devel/chora/pkg-plist b/devel/chora/pkg-plist
index b6347ab520dc..5498173e4f45 100644
--- a/devel/chora/pkg-plist
+++ b/devel/chora/pkg-plist
@@ -1,4 +1,4 @@
-etc/horde/httpd.conf.chora
+%%HORDE_INC%%/httpd-chora.conf
%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING