aboutsummaryrefslogtreecommitdiff
path: root/devel/cil
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2006-05-05 16:44:34 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2006-05-05 16:44:34 +0000
commit0b0a8361b233410f6f037985910521c75efa8865 (patch)
tree22e73457569d80b5dd28af72bb1c089f4191da8a /devel/cil
parent4d08f4b32e9e2115b7a4c947080f83a4f229bcb5 (diff)
downloadports-0b0a8361b233410f6f037985910521c75efa8865.tar.gz
ports-0b0a8361b233410f6f037985910521c75efa8865.zip
Notes
Diffstat (limited to 'devel/cil')
-rw-r--r--devel/cil/Makefile22
-rw-r--r--devel/cil/distinfo6
-rw-r--r--devel/cil/pkg-plist242
3 files changed, 137 insertions, 133 deletions
diff --git a/devel/cil/Makefile b/devel/cil/Makefile
index 7590ebf08d45..2e5e8fc9eeb6 100644
--- a/devel/cil/Makefile
+++ b/devel/cil/Makefile
@@ -6,11 +6,13 @@
#
PORTNAME= cil
-PORTVERSION= 1.3.3
+PORTVERSION= 1.3.4
CATEGORIES= devel lang
-MASTER_SITES= http://manju.cs.berkeley.edu/cil/distrib/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://manju.cs.berkeley.edu/cil/distrib/
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= netchild@FreeBSD.org
+MAINTAINER= jkoshy@FreeBSD.org
COMMENT= Infrastructure for C Program Analysis and Transformation
BUILD_DEPENDS= ${LOCALBASE}/bin/ocamlopt:${PORTSDIR}/lang/ocaml
@@ -30,7 +32,7 @@ EXECFILES= cilly.byte.exe machdep.exe
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500601
-IGNORE= "Does not work with perl < 5.6.1"
+IGNORE= does not work with perl < 5.6.1
.endif
post-patch:
@@ -43,17 +45,17 @@ do-install:
cd ${WRKSRC}/doc && ${FIND} . -print | \
${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${DOCSDIR}
.endif
-.for file in ${BINFILES}
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/${file} ${PREFIX}/bin/
+.for f in ${BINFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/bin/
.endfor
${MKDIR} ${SITE_PERL}/CIL
-.for file in ${LIBFILES}
- ${INSTALL_DATA} ${WRKSRC}/lib/${file} ${SITE_PERL}/CIL/
+.for f in ${LIBFILES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${f} ${SITE_PERL}/CIL/
.endfor
${INSTALL_DATA} ${WRKSRC}/bin/CilConfig.pm ${SITE_PERL}/
${MKDIR} ${PREFIX}/libexec/cil
-.for file in ${EXECFILES}
- ${INSTALL} ${WRKSRC}/obj/x86_LINUX/${file} ${PREFIX}/libexec/cil/
+.for f in ${EXECFILES}
+ ${INSTALL} ${WRKSRC}/obj/x86_LINUX/${f} ${PREFIX}/libexec/cil/
.endfor
.include <bsd.port.post.mk>
diff --git a/devel/cil/distinfo b/devel/cil/distinfo
index fd29defcd540..590dbfed241e 100644
--- a/devel/cil/distinfo
+++ b/devel/cil/distinfo
@@ -1,3 +1,3 @@
-MD5 (cil-1.3.3.tar.gz) = dafd350c154990728efb35a7073ca81a
-SHA256 (cil-1.3.3.tar.gz) = 9a8389bf371d56ce7a28152d0c3dd304a979c13f443abdd3f0680a31139a2d56
-SIZE (cil-1.3.3.tar.gz) = 1038720
+MD5 (cil-1.3.4.tar.gz) = a7fa54f19844a20562efd37f67c391da
+SHA256 (cil-1.3.4.tar.gz) = ed540d0b8ed13c7832593e08117380c1e3dd4cdc23acad5188c607778194c860
+SIZE (cil-1.3.4.tar.gz) = 1059905
diff --git a/devel/cil/pkg-plist b/devel/cil/pkg-plist
index ae3261084cce..e66889a43c6f 100644
--- a/devel/cil/pkg-plist
+++ b/devel/cil/pkg-plist
@@ -3,126 +3,128 @@ bin/patcher
bin/teetwo
libexec/cil/cilly.byte.exe
libexec/cil/machdep.exe
-%%DOCSDIR%%/CIL-API.pdf
-%%DOCSDIR%%/CIL.pdf
-%%DOCSDIR%%/api/Alpha.html
-%%DOCSDIR%%/api/Cil.cilPrinter.html
-%%DOCSDIR%%/api/Cil.cilVisitor.html
-%%DOCSDIR%%/api/Cil.defaultCilPrinterClass.html
-%%DOCSDIR%%/api/Cil.html
-%%DOCSDIR%%/api/Cil.nopCilVisitor.html
-%%DOCSDIR%%/api/Cil.plainCilPrinterClass.html
-%%DOCSDIR%%/api/Clist.html
-%%DOCSDIR%%/api/Errormsg.html
-%%DOCSDIR%%/api/Formatcil.html
-%%DOCSDIR%%/api/Pretty.MakeMapPrinter.html
-%%DOCSDIR%%/api/Pretty.html
-%%DOCSDIR%%/api/Stats.html
-%%DOCSDIR%%/api/index.html
-%%DOCSDIR%%/api/index_attributes.html
-%%DOCSDIR%%/api/index_class_types.html
-%%DOCSDIR%%/api/index_classes.html
-%%DOCSDIR%%/api/index_exceptions.html
-%%DOCSDIR%%/api/index_methods.html
-%%DOCSDIR%%/api/index_module_types.html
-%%DOCSDIR%%/api/index_modules.html
-%%DOCSDIR%%/api/index_types.html
-%%DOCSDIR%%/api/index_values.html
-%%DOCSDIR%%/api/style.css
-%%DOCSDIR%%/api/type_Alpha.html
-%%DOCSDIR%%/api/type_Cil.cilPrinter.html
-%%DOCSDIR%%/api/type_Cil.cilVisitor.html
-%%DOCSDIR%%/api/type_Cil.defaultCilPrinterClass.html
-%%DOCSDIR%%/api/type_Cil.html
-%%DOCSDIR%%/api/type_Cil.nopCilVisitor.html
-%%DOCSDIR%%/api/type_Cil.plainCilPrinterClass.html
-%%DOCSDIR%%/api/type_Clist.html
-%%DOCSDIR%%/api/type_Errormsg.html
-%%DOCSDIR%%/api/type_Formatcil.html
-%%DOCSDIR%%/api/type_Pretty.MakeMapPrinter.html
-%%DOCSDIR%%/api/type_Pretty.html
-%%DOCSDIR%%/api/type_Stats.html
-%%DOCSDIR%%/attributes.html
-%%DOCSDIR%%/cil.html
-%%DOCSDIR%%/cil.version.tex
-%%DOCSDIR%%/cil001.html
-%%DOCSDIR%%/cil002.html
-%%DOCSDIR%%/cil003.html
-%%DOCSDIR%%/cil004.html
-%%DOCSDIR%%/cil005.html
-%%DOCSDIR%%/cil006.html
-%%DOCSDIR%%/cil009.html
-%%DOCSDIR%%/cil010.html
-%%DOCSDIR%%/cil011.html
-%%DOCSDIR%%/cil012.html
-%%DOCSDIR%%/cil013.html
-%%DOCSDIR%%/cil016.html
-%%DOCSDIR%%/cil017.html
-%%DOCSDIR%%/cil018.html
-%%DOCSDIR%%/cil019.html
-%%DOCSDIR%%/cil020.html
-%%DOCSDIR%%/cil021.html
-%%DOCSDIR%%/cilheader.html
-%%DOCSDIR%%/cilly.html
-%%DOCSDIR%%/cilpp.haux
-%%DOCSDIR%%/cilpp.htoc
-%%DOCSDIR%%/ciltoc.html
-%%DOCSDIR%%/contents_motif.gif
-%%DOCSDIR%%/examples/ex1.txt
-%%DOCSDIR%%/examples/ex10.txt
-%%DOCSDIR%%/examples/ex11.txt
-%%DOCSDIR%%/examples/ex12.txt
-%%DOCSDIR%%/examples/ex13.txt
-%%DOCSDIR%%/examples/ex14.txt
-%%DOCSDIR%%/examples/ex15.txt
-%%DOCSDIR%%/examples/ex16.txt
-%%DOCSDIR%%/examples/ex17.txt
-%%DOCSDIR%%/examples/ex18.txt
-%%DOCSDIR%%/examples/ex19.txt
-%%DOCSDIR%%/examples/ex2.txt
-%%DOCSDIR%%/examples/ex20.txt
-%%DOCSDIR%%/examples/ex21.txt
-%%DOCSDIR%%/examples/ex22.txt
-%%DOCSDIR%%/examples/ex23.txt
-%%DOCSDIR%%/examples/ex24.txt
-%%DOCSDIR%%/examples/ex25.txt
-%%DOCSDIR%%/examples/ex26.txt
-%%DOCSDIR%%/examples/ex27.txt
-%%DOCSDIR%%/examples/ex28.txt
-%%DOCSDIR%%/examples/ex29.txt
-%%DOCSDIR%%/examples/ex3.txt
-%%DOCSDIR%%/examples/ex30.txt
-%%DOCSDIR%%/examples/ex31.txt
-%%DOCSDIR%%/examples/ex32.txt
-%%DOCSDIR%%/examples/ex33.txt
-%%DOCSDIR%%/examples/ex34.txt
-%%DOCSDIR%%/examples/ex35.txt
-%%DOCSDIR%%/examples/ex36.txt
-%%DOCSDIR%%/examples/ex37.txt
-%%DOCSDIR%%/examples/ex38.txt
-%%DOCSDIR%%/examples/ex39.txt
-%%DOCSDIR%%/examples/ex4.txt
-%%DOCSDIR%%/examples/ex40.txt
-%%DOCSDIR%%/examples/ex41.txt
-%%DOCSDIR%%/examples/ex42.txt
-%%DOCSDIR%%/examples/ex43.txt
-%%DOCSDIR%%/examples/ex44.txt
-%%DOCSDIR%%/examples/ex45.txt
-%%DOCSDIR%%/examples/ex46.txt
-%%DOCSDIR%%/examples/ex5.txt
-%%DOCSDIR%%/examples/ex6.txt
-%%DOCSDIR%%/examples/ex7.txt
-%%DOCSDIR%%/examples/ex8.txt
-%%DOCSDIR%%/examples/ex9.txt
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/merger.html
-%%DOCSDIR%%/next_motif.gif
-%%DOCSDIR%%/patcher.html
-%%DOCSDIR%%/previous_motif.gif
-@dirrm %%DOCSDIR%%/examples
-@dirrm %%DOCSDIR%%/api-latex
-@dirrm %%DOCSDIR%%/api
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/CIL-API.pdf
+%%PORTDOCS%%%%DOCSDIR%%/CIL.pdf
+%%PORTDOCS%%%%DOCSDIR%%/api/Alpha.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.cilPrinter.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.cilVisitor.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.defaultCilPrinterClass.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.nopCilVisitor.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Cil.plainCilPrinterClass.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Clist.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Errormsg.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Formatcil.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Pretty.MakeMapPrinter.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Pretty.html
+%%PORTDOCS%%%%DOCSDIR%%/api/Stats.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_class_types.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_module_types.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_types.html
+%%PORTDOCS%%%%DOCSDIR%%/api/index_values.html
+%%PORTDOCS%%%%DOCSDIR%%/api/style.css
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Alpha.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.cilPrinter.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.cilVisitor.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.defaultCilPrinterClass.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.nopCilVisitor.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Cil.plainCilPrinterClass.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Clist.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Errormsg.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Formatcil.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Pretty.MakeMapPrinter.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Pretty.html
+%%PORTDOCS%%%%DOCSDIR%%/api/type_Stats.html
+%%PORTDOCS%%%%DOCSDIR%%/attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/cil.css
+%%PORTDOCS%%%%DOCSDIR%%/cil.html
+%%PORTDOCS%%%%DOCSDIR%%/cil.version.tex
+%%PORTDOCS%%%%DOCSDIR%%/cil001.html
+%%PORTDOCS%%%%DOCSDIR%%/cil002.html
+%%PORTDOCS%%%%DOCSDIR%%/cil003.html
+%%PORTDOCS%%%%DOCSDIR%%/cil004.html
+%%PORTDOCS%%%%DOCSDIR%%/cil005.html
+%%PORTDOCS%%%%DOCSDIR%%/cil006.html
+%%PORTDOCS%%%%DOCSDIR%%/cil009.html
+%%PORTDOCS%%%%DOCSDIR%%/cil010.html
+%%PORTDOCS%%%%DOCSDIR%%/cil011.html
+%%PORTDOCS%%%%DOCSDIR%%/cil012.html
+%%PORTDOCS%%%%DOCSDIR%%/cil013.html
+%%PORTDOCS%%%%DOCSDIR%%/cil016.html
+%%PORTDOCS%%%%DOCSDIR%%/cil017.html
+%%PORTDOCS%%%%DOCSDIR%%/cil018.html
+%%PORTDOCS%%%%DOCSDIR%%/cil019.html
+%%PORTDOCS%%%%DOCSDIR%%/cil020.html
+%%PORTDOCS%%%%DOCSDIR%%/cil021.html
+%%PORTDOCS%%%%DOCSDIR%%/cilheader.html
+%%PORTDOCS%%%%DOCSDIR%%/cilly.html
+%%PORTDOCS%%%%DOCSDIR%%/cilpp.haux
+%%PORTDOCS%%%%DOCSDIR%%/cilpp.htoc
+%%PORTDOCS%%%%DOCSDIR%%/ciltoc.html
+%%PORTDOCS%%%%DOCSDIR%%/contents_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex1.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex10.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex11.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex12.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex13.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex14.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex15.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex16.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex17.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex18.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex19.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex2.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex20.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex21.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex22.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex23.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex24.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex25.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex26.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex27.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex28.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex29.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex3.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex30.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex31.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex32.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex33.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex34.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex35.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex36.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex37.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex38.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex39.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex4.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex40.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex41.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex42.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex43.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex44.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex45.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex46.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex5.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex6.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex7.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex8.txt
+%%PORTDOCS%%%%DOCSDIR%%/examples/ex9.txt
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/merger.html
+%%PORTDOCS%%%%DOCSDIR%%/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/patcher.html
+%%PORTDOCS%%%%DOCSDIR%%/previous_motif.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/examples
+%%PORTDOCS%%@exec mkdir -p %D/%%DOCSDIR%%/api-latex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/api-latex
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/api
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/cil
@cwd %%LOCALBASE%%
%%SITE_PERL%%/CIL/Cilly.pm