aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-asdf-cmucl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 09:13:43 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 09:13:43 +0000
commit5a2b5427e895496bec5c8ff5e16c39c6728d88fd (patch)
tree99de5745fb11f552ad5ce232a856106d05df3640 /devel/cl-asdf-cmucl
parent62ffead3233c604eb5eacd93e6a2e86f7e8e60fd (diff)
downloadports-5a2b5427e895496bec5c8ff5e16c39c6728d88fd.tar.gz
ports-5a2b5427e895496bec5c8ff5e16c39c6728d88fd.zip
Notes
Diffstat (limited to 'devel/cl-asdf-cmucl')
-rw-r--r--devel/cl-asdf-cmucl/Makefile39
-rw-r--r--devel/cl-asdf-cmucl/pkg-descr11
-rw-r--r--devel/cl-asdf-cmucl/pkg-plist3
3 files changed, 53 insertions, 0 deletions
diff --git a/devel/cl-asdf-cmucl/Makefile b/devel/cl-asdf-cmucl/Makefile
new file mode 100644
index 000000000000..2bdb91db9af8
--- /dev/null
+++ b/devel/cl-asdf-cmucl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: cl-asdf-cmucl
+# Date created: 10 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= asdf
+PORTVERSION= 2003.05.16
+CATEGORIES= devel
+MASTER_SITES= http://www.henrik-motakef.de/freebsd-distfiles/asdf/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -cmucl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= A system definition facility for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ lisp:${PORTSDIR}/lang/cmucl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ lisp:${PORTSDIR}/lang/cmucl
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+do-build:
+ lisp -noinit -nositeinit \
+ -eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/asdf.lisp" \
+ :output-file "${WRKSRC}/asdf.fasl")' \
+ -eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/wild-modules.lisp" \
+ :output-file "${WRKSRC}/wild-modules.fasl")' \
+ -eval '(quit)'
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/asdf/cmuclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/asdf/cmuclfasl
+
+.include <bsd.port.mk>
diff --git a/devel/cl-asdf-cmucl/pkg-descr b/devel/cl-asdf-cmucl/pkg-descr
new file mode 100644
index 000000000000..22d206f09da8
--- /dev/null
+++ b/devel/cl-asdf-cmucl/pkg-descr
@@ -0,0 +1,11 @@
+asdf is Another System Definition Facility for Common Lisp. It intends
+to solve the same class of problems as mk-defsystem - compiling and
+installing Lisp libraries -, but internally it takes advantage of
+modern CL features like pathname support etc., and uses CLOS for
+extensibility.
+
+This package installs binaries compiled for CMU Common Lisp.
+
+WWW: http://www.cliki.net/asdf
+
+- Henrik Motakef
diff --git a/devel/cl-asdf-cmucl/pkg-plist b/devel/cl-asdf-cmucl/pkg-plist
new file mode 100644
index 000000000000..ee41ad1da9d1
--- /dev/null
+++ b/devel/cl-asdf-cmucl/pkg-plist
@@ -0,0 +1,3 @@
+lib/common-lisp/asdf/cmuclfasl/asdf.fasl
+lib/common-lisp/asdf/cmuclfasl/wild-modules.fasl
+@dirrm lib/common-lisp/asdf/cmuclfasl