aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-asdf-sbcl
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 09:02:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 09:02:57 +0000
commit62ffead3233c604eb5eacd93e6a2e86f7e8e60fd (patch)
tree695dfc86a5ba704882b6215390fc42a12e8c2da6 /devel/cl-asdf-sbcl
parentaa869c7b7088ab5af136e8a04bf751af96274d9a (diff)
downloadports-62ffead3233c604eb5eacd93e6a2e86f7e8e60fd.tar.gz
ports-62ffead3233c604eb5eacd93e6a2e86f7e8e60fd.zip
Notes
Diffstat (limited to 'devel/cl-asdf-sbcl')
-rw-r--r--devel/cl-asdf-sbcl/Makefile39
-rw-r--r--devel/cl-asdf-sbcl/pkg-descr11
-rw-r--r--devel/cl-asdf-sbcl/pkg-plist3
3 files changed, 53 insertions, 0 deletions
diff --git a/devel/cl-asdf-sbcl/Makefile b/devel/cl-asdf-sbcl/Makefile
new file mode 100644
index 000000000000..03e40735c414
--- /dev/null
+++ b/devel/cl-asdf-sbcl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: cl-asdf-sbcl
+# Date created: 10 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= asdf
+PORTVERSION= 2003.05.16
+CATEGORIES= devel
+MASTER_SITES= http://www.henrik-motakef.de/freebsd-distfiles/asdf/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= A system definition facility for Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+do-build:
+ sbcl --noinform --userinit /dev/null --disable-debugger \
+ --eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/asdf.lisp" \
+ :output-file "${WRKSRC}/asdf.fasl")' \
+ --eval '(compile-file "${PREFIX}/lib/common-lisp/asdf/wild-modules.lisp" \
+ :output-file "${WRKSRC}/wild-modules.fasl")' \
+ --eval '(quit)'
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/asdf/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/asdf/sbclfasl
+
+.include <bsd.port.mk>
diff --git a/devel/cl-asdf-sbcl/pkg-descr b/devel/cl-asdf-sbcl/pkg-descr
new file mode 100644
index 000000000000..0168f20ffa5e
--- /dev/null
+++ b/devel/cl-asdf-sbcl/pkg-descr
@@ -0,0 +1,11 @@
+asdf is Another System Definition Facility for Common Lisp. It intends
+to solve the same class of problems as mk-defsystem - compiling and
+installing Lisp libraries -, but internally it takes advantage of
+modern CL features like pathname support etc., and uses CLOS for
+extensibility.
+
+This package installs binaries compiled for Steel Bank Common Lisp.
+
+WWW: http://www.cliki.net/asdf
+
+- Henrik Motakef
diff --git a/devel/cl-asdf-sbcl/pkg-plist b/devel/cl-asdf-sbcl/pkg-plist
new file mode 100644
index 000000000000..559cf120cfce
--- /dev/null
+++ b/devel/cl-asdf-sbcl/pkg-plist
@@ -0,0 +1,3 @@
+lib/common-lisp/asdf/sbclfasl/asdf.fasl
+lib/common-lisp/asdf/sbclfasl/wild-modules.fasl
+@dirrm lib/common-lisp/asdf/sbclfasl