aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-asdf
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-12 22:28:35 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-12 22:28:35 +0000
commit9e05620e2412dceb8ef41a429c2b24186a33e247 (patch)
treea73d467471b28fb7b3172d84722f9fb7c3727070 /devel/cl-asdf
parent04a4965b58e08791b2e1831d8f3f3b23fcd90f39 (diff)
downloadports-9e05620e2412dceb8ef41a429c2b24186a33e247.tar.gz
ports-9e05620e2412dceb8ef41a429c2b24186a33e247.zip
Notes
Diffstat (limited to 'devel/cl-asdf')
-rw-r--r--devel/cl-asdf/Makefile68
-rw-r--r--devel/cl-asdf/distinfo6
-rw-r--r--devel/cl-asdf/files/asdf-init.lisp68
-rw-r--r--devel/cl-asdf/files/patch-asdf.lisp23
-rw-r--r--devel/cl-asdf/pkg-plist38
5 files changed, 106 insertions, 97 deletions
diff --git a/devel/cl-asdf/Makefile b/devel/cl-asdf/Makefile
index 6bc0d5e9298e..4729f4732501 100644
--- a/devel/cl-asdf/Makefile
+++ b/devel/cl-asdf/Makefile
@@ -4,48 +4,54 @@
#
# $FreeBSD$
-PORTNAME= asdf
-PORTVERSION= 2003.05.16
-PORTREVISION= 2
-CATEGORIES= devel lisp
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= pav
-PKGNAMEPREFIX= cl-
-
-MAINTAINER= olgeni@FreeBSD.org
-COMMENT= A system definition facility for Common Lisp
-
-SUB_FILES+= pkg-message
-WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_BUILD= yes # Sources only, see cl-asdf-[sbcl|clisp]
+# The source tarball was obtained from the project's GIT repository:
+# wget -O asdf-1.374.tar.gz "http://common-lisp.net/gitweb?p=projects/asdf/asdf.git;a=snapshot;h=f6dfe94d2836534a7be050127123cc16fee87c48;sf=tgz"
+
+PORTNAME= asdf
+PORTVERSION= 1.374
+PORTEPOCH= 1
+CATEGORIES= devel lisp
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= olgeni
+PKGNAMEPREFIX= cl-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A system definition facility for Common Lisp
+
+SUB_FILES+= pkg-message
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes # Sources only
+DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/${UNIQUENAME}
+
CL_LIBDIR= ${PREFIX}/lib/common-lisp
ASDF_SYSTEM_REGISTRY= ${CL_LIBDIR}/system-registry
-DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${UNIQUENAME}
do-install:
- ${MKDIR} ${CL_LIBDIR}/asdf
- ${MKDIR} ${ASDF_SYSTEM_REGISTRY}
- ${INSTALL_DATA} ${WRKSRC}/asdf.lisp ${CL_LIBDIR}/asdf/
- ${INSTALL_DATA} ${WRKSRC}/wild-modules.lisp ${CL_LIBDIR}/asdf/
- ${SED} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${CL_LIBDIR}/asdf/asdf.lisp
- ${SED} -e 's|%%ASDF_PATHNAME%%|${CL_LIBDIR}/asdf/asdf|' \
+ @${MKDIR} ${CL_LIBDIR}/asdf
+ @${MKDIR} ${ASDF_SYSTEM_REGISTRY}
+
+ @${INSTALL_DATA} ${WRKSRC}/asdf.asd ${ASDF_SYSTEM_REGISTRY}
+ @${INSTALL_DATA} ${WRKSRC}/cclan.asd ${ASDF_SYSTEM_REGISTRY}
+
+ @${INSTALL_DATA} ${WRKSRC}/*.lisp ${CL_LIBDIR}/asdf/
+ @${INSTALL_DATA} ${WRKSRC}/*.asd ${CL_LIBDIR}/asdf/
+
+ @${LN} -sf ${CL_LIBDIR}/asdf/*.asd ${ASDF_SYSTEM_REGISTRY}
+
+ @${SED} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${CL_LIBDIR}/asdf/asdf.lisp
+ @${SED} -e 's|%%ASDF_PATHNAME%%|${CL_LIBDIR}/asdf/asdf|' \
-e 's|%%ASDF_SYSTEM_REGISTRY%%|${ASDF_SYSTEM_REGISTRY}|' \
-e 's|%%PREFIX%%|${PREFIX}|' \
${FILESDIR}/asdf-init.lisp > \
${PREFIX}/etc/asdf-init.lisp.default
- [ -f ${PREFIX}/etc/asdf-init.lisp ] || \
+ @[ -f ${PREFIX}/etc/asdf-init.lisp ] || \
${CP} ${PREFIX}/etc/asdf-init.lisp.default \
${PREFIX}/etc/asdf-init.lisp
.if !defined(NOPORTDOCS)
- ${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}/
- ${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${DOCSDIR}/
-.endif
-.if !defined(NOPORTEXAMPLES)
- ${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 555 -d ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}/
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ @${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${DOCSDIR}/
.endif
post-install:
diff --git a/devel/cl-asdf/distinfo b/devel/cl-asdf/distinfo
index 9b1d9c1e76ae..68a405c3068b 100644
--- a/devel/cl-asdf/distinfo
+++ b/devel/cl-asdf/distinfo
@@ -1,3 +1,3 @@
-MD5 (asdf-2003.05.16.tar.gz) = fa9b84d932ba1632df37b86e38a72e2d
-SHA256 (asdf-2003.05.16.tar.gz) = 8cfb5ca14b7429893a65e0a27f51a5c4af5a90a87e2b2368a9bb19c583bbb889
-SIZE (asdf-2003.05.16.tar.gz) = 29894
+MD5 (asdf-1.374.tar.gz) = 266e4f7252f1037784c62b84a70966ea
+SHA256 (asdf-1.374.tar.gz) = 685b6a0f7bbf968c9d4803c2971a3df36e5b605d24ee852985a3db2f5d6dedd3
+SIZE (asdf-1.374.tar.gz) = 106093
diff --git a/devel/cl-asdf/files/asdf-init.lisp b/devel/cl-asdf/files/asdf-init.lisp
index 351c24f4de3d..93408f0bb249 100644
--- a/devel/cl-asdf/files/asdf-init.lisp
+++ b/devel/cl-asdf/files/asdf-init.lisp
@@ -4,11 +4,11 @@
;; Redistribution and use in source and binary forms, with or without
;; modification, are permitted provided that the following conditions are
-;; met:
+;; met:
;; 1. Redistributions of source code must retain the above copyright
-;; notice, this list of conditions and the following disclaimer.
-;;
+;; notice, this list of conditions and the following disclaimer.
+;;
;; 2. Redistributions in binary form must reproduce the above copyright
;; notice, this list of conditions and the following disclaimer in the
;; documentation and/or other materials provided with the distribution
@@ -54,6 +54,9 @@
;; %%PREFIX%%/etc/sbclrc
;; ~/.sbclrc
;;
+;; CLOZURE CL / OPENMCL:
+;; ~/.ccl-init.lisp
+;;
;; After that, you can load your installed ports like this (using
;; textproc/cl-ppcre as an example):
;;
@@ -126,12 +129,17 @@
;;;; Paths
(defvar *asdf-pathname*
- "%%PREFIX%%/lib/common-lisp/asdf/asdf"
+ ;; Clozure CL's internal asdf
+ #+openmcl "%%PREFIX%%/lib/ccl/tools/asdf"
+ ;; SBCL's internal asdf
+ #+sbcl "%%PREFIX%%/lib/sbcl/asdf/asdf"
+ ;; CMU and clisp
+ #-(or openmcl sbcl) "%%PREFIX%%/lib/common-lisp/asdf/asdf"
"Path of the ASDF library")
(defvar *system-registry*
- "%%PREFIX%%/lib/common-lisp/system-registry"
- "FreeBSDs contribution to the entral registry for ASDF system
+ "%%PREFIX%%/lib/common-lisp/system-registry/"
+ "FreeBSD's contribution to the central registry for ASDF system
definitions. This will be added to asdf:*central-registry*, you
should modify that in order to add other directories.")
@@ -158,10 +166,11 @@ error of type UNSUPPORTED-LISP-IMPLEMENTATION.
This function has to be extended for each new Lisp implementation that
should be able to use the ASDF-based Lisp ports. If you do this, you
should probably extend GETENV as well."
- #+clisp "clispfasl"
- #+cmu "cmuclfasl"
- #+sbcl "sbclfasl"
- #-(or clisp cmu sbcl) (error 'unsupported-lisp-implementation))
+ #+clisp "clispfasl"
+ #+cmu "cmuclfasl"
+ #+sbcl "sbclfasl"
+ #+openmcl "cclfasl"
+ #-(or clisp cmu sbcl openmcl) (error 'unsupported-lisp-implementation))
(defun getenv (varname)
"Return the value of environment variable VARNAME, as a string.
@@ -179,12 +188,12 @@ has to be extended for each Lisp implementation that is to work with
FreeBSDs Lisp ports. If you do this, you should probably extend
LISP-SPECIFIC-FASL-SUBDIR as well."
#+sbcl (sb-ext:posix-getenv varname)
- #+cmu (cdr (assoc varname ext:*environment-list*
+ #+cmu (cdr (assoc varname ext:*environment-list*
:test #'equalp
:key #'string))
#+clisp (sys::getenv varname)
- #-(or sbcl cmu clisp) (error 'unsupported-lisp-implementation))
-
+ #+openmcl (ccl::getenv varname)
+ #-(or sbcl cmu clisp openmcl) (error 'unsupported-lisp-implementation))
;;;; Load and configure ASDF
@@ -205,7 +214,7 @@ LISP-SPECIFIC-FASL-SUBDIR as well."
(if (and (getenv "FBSD_ASDF_COMPILE_PORT")
(getenv "WRKSRC"))
- ;;;; We are compiling a port - fasls should go to ${WRKSRC}
+ ;; We are compiling a port - fasls should go to ${WRKSRC}
(defmethod asdf:output-files :around ((op asdf:compile-op)
(file asdf:cl-source-file))
(let ((wrksrc (getenv "WRKSRC"))
@@ -220,16 +229,21 @@ LISP-SPECIFIC-FASL-SUBDIR as well."
:name (pathname-name default-output-name)
:type "fasl"))))
- ;; Normal operation: load from lisp-specific-fasl-subdir
- (defmethod asdf:output-files :around ((op asdf:compile-op)
- (file asdf:cl-source-file))
- (let ((default-output-file (car (call-next-method))))
- (list
- (make-pathname
- :directory `(:absolute ,@(cdr (pathname-directory default-output-file))
- ,(lisp-specific-fasl-subdir))
- :type "fasl"
- :defaults default-output-file))))
-)
-
-;;; asdf-init.lisp ends here
+ ;; Normal operation: load from lisp-specific-fasl-subdir
+ (defmethod asdf:output-files :around ((op asdf:compile-op)
+ (file asdf:cl-source-file))
+ (let ((default-output-file (car (call-next-method))))
+ (let ((output-file-string (namestring default-output-file)))
+ (list
+ (if
+ (or
+ (search "%%PREFIX%%/lib/ccl" output-file-string)
+ (search "%%PREFIX%%/lib/sbcl" output-file-string))
+ (make-pathname :defaults default-output-file)
+ (make-pathname
+ :directory `(:absolute ,@(cdr (pathname-directory default-output-file))
+ ,(lisp-specific-fasl-subdir))
+ :type "fasl"
+ :defaults default-output-file)))))))
+
+;;;; asdf-init.lisp ends here
diff --git a/devel/cl-asdf/files/patch-asdf.lisp b/devel/cl-asdf/files/patch-asdf.lisp
index 4942c47e4332..ab400b695bc5 100644
--- a/devel/cl-asdf/files/patch-asdf.lisp
+++ b/devel/cl-asdf/files/patch-asdf.lisp
@@ -1,12 +1,15 @@
---- asdf.lisp.orig Thu Mar 20 13:58:09 2003
-+++ asdf.lisp Thu Mar 20 13:58:49 2003
-@@ -322,8 +322,7 @@
-
+
+$FreeBSD$
+
+--- asdf.lisp.orig
++++ asdf.lisp
+@@ -630,7 +630,8 @@
+ (system-source-file (cdr system-pair)))))))
+
(defvar *central-registry*
- '(*default-pathname-defaults*
-- #+nil "/home/dan/src/sourceforge/cclan/asdf/systems/"
-- #+nil "telent:asdf;systems;"))
-+ "%%PREFIX%%/lib/common-lisp/system-registry/"))
+- `((directory-namestring *default-pathname-defaults*))
++ `((directory-namestring *default-pathname-defaults*)
++ "%%PREFIX%%/lib/common-lisp/system-registry/")
+ "A list of 'system directory designators' ASDF uses to find systems.
- (defun sysdef-central-registry-search (system)
- (let ((name (coerce-name system)))
+ A 'system directory designator' is a pathname or a function
diff --git a/devel/cl-asdf/pkg-plist b/devel/cl-asdf/pkg-plist
index 29aac1b64a32..6379f3c19398 100644
--- a/devel/cl-asdf/pkg-plist
+++ b/devel/cl-asdf/pkg-plist
@@ -1,32 +1,18 @@
-lib/common-lisp/asdf/asdf.lisp
-lib/common-lisp/asdf/wild-modules.lisp
@unexec if cmp -s %D/etc/asdf-init.lisp.default %D/etc/asdf-init.lisp; then rm -f %D/etc/asdf-init.lisp; fi
etc/asdf-init.lisp.default
@exec [ -f %D/etc/asdf-init.lisp ] || cp %D/etc/asdf-init.lisp.default %D/etc/asdf-init.lisp
-@dirrm lib/common-lisp/asdf
-@dirrm lib/common-lisp/system-registry
-@dirrm lib/common-lisp
+%%LIB32DIR%%/common-lisp/asdf/asdf-ecl.lisp
+%%LIB32DIR%%/common-lisp/asdf/asdf-install.lisp
+%%LIB32DIR%%/common-lisp/asdf/asdf.asd
+%%LIB32DIR%%/common-lisp/asdf/asdf.lisp
+%%LIB32DIR%%/common-lisp/asdf/cclan-package.lisp
+%%LIB32DIR%%/common-lisp/asdf/cclan.asd
+%%LIB32DIR%%/common-lisp/asdf/cclan.lisp
+%%LIB32DIR%%/common-lisp/asdf/wild-modules.lisp
+%%LIB32DIR%%/common-lisp/system-registry/asdf.asd
+%%LIB32DIR%%/common-lisp/system-registry/cclan.asd
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file1.lisp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file2.lisp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file3.lisp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file4.lisp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-tests.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.script
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2.script
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2a.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2b1.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2b2.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2b3.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test3.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test3.script
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test4.script
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wild-module.asd
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wild-module.script
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@exec mkdir -p %D/lib/common-lisp/system-registry
+@dirrm %%LIB32DIR%%/common-lisp/system-registry
+@dirrm %%LIB32DIR%%/common-lisp/asdf