aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-asdf
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 18:09:01 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 18:09:01 +0000
commit53c2e94613975615837faf148b2d4d08ef284911 (patch)
tree37c835b502e75ca1ead5786702de3faa5760eed1 /devel/cl-asdf
parenta0fbb415da683c928afe0ddd53d836de1ef375a8 (diff)
downloadports-53c2e94613975615837faf148b2d4d08ef284911.tar.gz
ports-53c2e94613975615837faf148b2d4d08ef284911.zip
Notes
Diffstat (limited to 'devel/cl-asdf')
-rw-r--r--devel/cl-asdf/Makefile2
-rw-r--r--devel/cl-asdf/files/asdf-init.lisp11
2 files changed, 10 insertions, 3 deletions
diff --git a/devel/cl-asdf/Makefile b/devel/cl-asdf/Makefile
index 49e7184836c7..086298e2bea7 100644
--- a/devel/cl-asdf/Makefile
+++ b/devel/cl-asdf/Makefile
@@ -9,7 +9,7 @@
PORTNAME= asdf
PORTVERSION= 1.374
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
diff --git a/devel/cl-asdf/files/asdf-init.lisp b/devel/cl-asdf/files/asdf-init.lisp
index 9913c1fc1800..1b6eed38dd31 100644
--- a/devel/cl-asdf/files/asdf-init.lisp
+++ b/devel/cl-asdf/files/asdf-init.lisp
@@ -232,6 +232,11 @@ clispfasl, ...) by calling lisp-specific-fasl-subdir."
:type "fasl"
:defaults default-output-file))))
+;; Map each library in common-lisp/ to its fasl subdirectory
+(dolist (path (directory "%%PREFIX%%/lib/common-lisp/*/"))
+ (let ((fasldir (make-pathname :directory (append (pathname-directory path) (list (lisp-specific-fasl-subdir))))))
+ (pushnew (list path fasldir) asdf:*source-to-target-mappings*)))
+
(if (and (getenv "FBSD_ASDF_COMPILE_PORT")
(getenv "PORTNAME")
(getenv "WRKSRC"))
@@ -239,7 +244,9 @@ clispfasl, ...) by calling lisp-specific-fasl-subdir."
(portname (getenv "PORTNAME")))
;; If we are building a FreeBSD port, all the compiled fasl files
;; should be redirected to WRKSRC.
- (let ((package (format nil "%%PREFIX%%/lib/common-lisp/~A/" portname)))
- (pushnew (list package wrksrc) asdf:*source-to-target-mappings*))))
+ (let ((port-source (make-pathname
+ :directory (append (pathname-directory #P"%%PREFIX%%/lib/common-lisp/")
+ (list portname)))))
+ (pushnew (list port-source wrksrc) asdf:*source-to-target-mappings*))))
;;;; asdf-init.lisp ends here