aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-asdf
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2007-07-10 14:06:02 +0000
committerTim Bishop <tdb@FreeBSD.org>2007-07-10 14:06:02 +0000
commitc9ecf3592d01a0de74276f57b1724009ebaf0553 (patch)
tree30ebeabe6770f9eca563fed37badc75d5ef763dc /devel/cl-asdf
parente39dbbaf002919bc799c522e82eec323d74d909f (diff)
downloadports-c9ecf3592d01a0de74276f57b1724009ebaf0553.tar.gz
ports-c9ecf3592d01a0de74276f57b1724009ebaf0553.zip
Notes
Diffstat (limited to 'devel/cl-asdf')
-rw-r--r--devel/cl-asdf/Makefile4
-rw-r--r--devel/cl-asdf/files/asdf-init.lisp14
-rw-r--r--devel/cl-asdf/files/patch-asdf.lisp2
3 files changed, 11 insertions, 9 deletions
diff --git a/devel/cl-asdf/Makefile b/devel/cl-asdf/Makefile
index 10f1a56d24d8..4298ef9b1ed6 100644
--- a/devel/cl-asdf/Makefile
+++ b/devel/cl-asdf/Makefile
@@ -6,7 +6,7 @@
PORTNAME= asdf
PORTVERSION= 2003.05.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pav
@@ -27,8 +27,10 @@ do-install:
${MKDIR} ${ASDF_SYSTEM_REGISTRY}
${INSTALL_DATA} ${WRKSRC}/asdf.lisp ${CL_LIBDIR}/asdf/
${INSTALL_DATA} ${WRKSRC}/wild-modules.lisp ${CL_LIBDIR}/asdf/
+ ${SED} -i '' -e 's|%%PREFIX%%|${PREFIX}|' ${CL_LIBDIR}/asdf/asdf.lisp
${SED} -e 's|%%ASDF_PATHNAME%%|${CL_LIBDIR}/asdf/asdf|' \
-e 's|%%ASDF_SYSTEM_REGISTRY%%|${ASDF_SYSTEM_REGISTRY}|' \
+ -e 's|%%PREFIX%%|${PREFIX}|' \
${FILESDIR}/asdf-init.lisp > \
${PREFIX}/etc/asdf-init.lisp.default
[ -f ${PREFIX}/etc/asdf-init.lisp ] || \
diff --git a/devel/cl-asdf/files/asdf-init.lisp b/devel/cl-asdf/files/asdf-init.lisp
index 50345182f698..c3a82a9e8402 100644
--- a/devel/cl-asdf/files/asdf-init.lisp
+++ b/devel/cl-asdf/files/asdf-init.lisp
@@ -36,22 +36,22 @@
;; This file takes all neccessary actions. The easiest way is to load
;; it in your Lisp everytime it starts, by putting
;;
-;; (load "/usr/local/etc/freebsd-lisp-init")
+;; (load "%%PREFIX%%/etc/freebsd-lisp-init")
;;
;; in your init file.
;;
;; Each Lisp implementation has it's own files where this can be done:
;;
;; CLISP:
-;; /usr/local/lib/clisp/config.lisp
+;; %%PREFIX%%/lib/clisp/config.lisp
;; ~/.clisprc
;;
;; CMUCL:
-;; /usr/local/lib/cmucl/lib/cmucl/lib/site-init.lisp
+;; %%PREFIX%%/lib/cmucl/lib/cmucl/lib/site-init.lisp
;; ~/.cmucl-init.lisp
;;
;; SBCL:
-;; /usr/local/etc/sbclrc
+;; %%PREFIX%%/etc/sbclrc
;; ~/.sbclrc
;;
;; After that, you can load your installed ports like this (using
@@ -68,7 +68,7 @@
;; We mess around with asdf:output-files in interesting ways to
;; enforce a filesystem layout that works without multiple Lisp
;; implementations overwriting their fasls. Basically, each lib has
-;; it's own directory in /usr/local/lib/common-lisp, initially
+;; it's own directory in %%PREFIX%%/lib/common-lisp, initially
;; containing its sources. Each fasl port will create an
;; implementation-specific subdirectory where all it's fasls go, for
;; example ./cmuclfasl, ./clispfasl etc.
@@ -126,11 +126,11 @@
;;;; Pathes
(defvar *asdf-pathname*
- "/usr/local/lib/common-lisp/asdf/asdf"
+ "%%PREFIX%%/lib/common-lisp/asdf/asdf"
"Path of the ASDF library")
(defvar *system-registry*
- "/usr/local/lib/common-lisp/system-registry"
+ "%%PREFIX%%/lib/common-lisp/system-registry"
"FreeBSDs contribution to the entral registry for ASDF system
definitions. This will be added to asdf:*central-registry*, you
should modify that in order to add other directories.")
diff --git a/devel/cl-asdf/files/patch-asdf.lisp b/devel/cl-asdf/files/patch-asdf.lisp
index 87ef4c51cbbb..4942c47e4332 100644
--- a/devel/cl-asdf/files/patch-asdf.lisp
+++ b/devel/cl-asdf/files/patch-asdf.lisp
@@ -6,7 +6,7 @@
'(*default-pathname-defaults*
- #+nil "/home/dan/src/sourceforge/cclan/asdf/systems/"
- #+nil "telent:asdf;systems;"))
-+ "/usr/local/lib/common-lisp/system-registry/"))
++ "%%PREFIX%%/lib/common-lisp/system-registry/"))
(defun sysdef-central-registry-search (system)
(let ((name (coerce-name system)))