aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-infix-sbcl
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-19 20:59:06 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-19 20:59:06 +0000
commit62672f327719b4d19fd228f22534a9d166ff8140 (patch)
treee3211938f76a037eadefd5344d387da92304119a /devel/cl-infix-sbcl
parent32956195c6f1e5f02e4266e2f5612f94091e262a (diff)
downloadports-62672f327719b4d19fd228f22534a9d166ff8140.tar.gz
ports-62672f327719b4d19fd228f22534a9d166ff8140.zip
Notes
Diffstat (limited to 'devel/cl-infix-sbcl')
-rw-r--r--devel/cl-infix-sbcl/Makefile42
-rw-r--r--devel/cl-infix-sbcl/pkg-descr13
-rw-r--r--devel/cl-infix-sbcl/pkg-plist2
3 files changed, 57 insertions, 0 deletions
diff --git a/devel/cl-infix-sbcl/Makefile b/devel/cl-infix-sbcl/Makefile
new file mode 100644
index 000000000000..fb1d149925f3
--- /dev/null
+++ b/devel/cl-infix-sbcl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: cl-infix-sbcl
+# Date created: 13 Feb 2006
+# Whom: Pedro F Giffuni
+#
+# $FreeBSD$
+
+PORTNAME= infix
+DISTVERSION= 19960628
+CATEGORIES= devel lisp
+MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A lisp macro to read math statements in infix notation
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/infix/infix.asd:${PORTSDIR}/devel/cl-infix \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+NO_CDROM= No fees or compensation can be charged
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :infix)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/infix/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/infix/sbclfasl/
+
+.include <bsd.port.mk>
diff --git a/devel/cl-infix-sbcl/pkg-descr b/devel/cl-infix-sbcl/pkg-descr
new file mode 100644
index 000000000000..f0299ab16f91
--- /dev/null
+++ b/devel/cl-infix-sbcl/pkg-descr
@@ -0,0 +1,13 @@
+This is an implementation of an infix reader macro. It should run in any
+valid Common Lisp and has been tested in Allegro CL 4.1, Lucid CL 4.0.1,
+MCL 2.0 and CMU CL. It allows the user to type arithmetic expressions in
+the traditional way (e.g., 1+2) when writing Lisp programs instead of
+using the normal Lisp syntax (e.g., (+ 1 2)). It is not intended to be a
+full replacement for the normal Lisp syntax.
+
+This package is compiled with SBCL.
+
+Written by Mark Kantrowitz, School of Computer Science,
+Carnegie Mellon University, March 1993.
+
+WWW: http://www.cliki.net/infix
diff --git a/devel/cl-infix-sbcl/pkg-plist b/devel/cl-infix-sbcl/pkg-plist
new file mode 100644
index 000000000000..151a6aba7903
--- /dev/null
+++ b/devel/cl-infix-sbcl/pkg-plist
@@ -0,0 +1,2 @@
+lib/common-lisp/infix/sbclfasl/infix.fasl
+@dirrm lib/common-lisp/infix/sbclfasl