aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-infix
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-19 20:53:47 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-19 20:53:47 +0000
commit8a42d39c2d421dc9a4e1956660483a20fc849f64 (patch)
treea94c5654ab930850aa9f5ba2ce8f62ee80419e03 /devel/cl-infix
parent402789e57480c7e942b299796e548b4c5dc9f506 (diff)
downloadports-8a42d39c2d421dc9a4e1956660483a20fc849f64.tar.gz
ports-8a42d39c2d421dc9a4e1956660483a20fc849f64.zip
Notes
Diffstat (limited to 'devel/cl-infix')
-rw-r--r--devel/cl-infix/Makefile46
-rw-r--r--devel/cl-infix/distinfo3
-rw-r--r--devel/cl-infix/pkg-descr13
-rw-r--r--devel/cl-infix/pkg-plist8
4 files changed, 70 insertions, 0 deletions
diff --git a/devel/cl-infix/Makefile b/devel/cl-infix/Makefile
new file mode 100644
index 000000000000..d7c1fc2aa9a4
--- /dev/null
+++ b/devel/cl-infix/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: infix
+# Date created: 19 August 2006
+# Whom: Pedro F. Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME= infix
+DISTVERSION= 19960628
+CATEGORIES= devel lisp
+MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= giffunip@asme.org
+COMMENT= A lisp macro for reading math expressions in infix form
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+CL_LIBDIR= ${PREFIX}/lib/common-lisp
+
+NO_BUILD= yes
+NO_CDROM= No fees or compensation can be charged
+
+LPORTDOCS= COPYING infix.3lisp
+
+do-install:
+ ${MKDIR} ${CL_LIBDIR}/infix
+ ${INSTALL_DATA} ${WRKSRC}/infix.asd ${CL_LIBDIR}/infix/
+ ${INSTALL_DATA} ${WRKSRC}/*.cl ${CL_LIBDIR}/infix/
+ ${INSTALL_DATA} ${WRKSRC}/infix.system ${CL_LIBDIR}/infix/
+ ${LN} -sf ${CL_LIBDIR}/infix/infix.asd ${CL_LIBDIR}/system-registry/infix.asd
+.if !defined(NOPORTDOCS)
+.for i in ${LPORTDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cl-infix/distinfo b/devel/cl-infix/distinfo
new file mode 100644
index 000000000000..5a9ef0fb0ad1
--- /dev/null
+++ b/devel/cl-infix/distinfo
@@ -0,0 +1,3 @@
+MD5 (infix.tar.gz) = 85eda3dcffe70f25854265bf687bdc97
+SHA256 (infix.tar.gz) = 556fd0432eba376075129b93467d72ad16793354eeb562521cdb0996ed92a62c
+SIZE (infix.tar.gz) = 13894
diff --git a/devel/cl-infix/pkg-descr b/devel/cl-infix/pkg-descr
new file mode 100644
index 000000000000..3bebeab3d1f9
--- /dev/null
+++ b/devel/cl-infix/pkg-descr
@@ -0,0 +1,13 @@
+This is an implementation of an infix reader macro. It should run in any
+valid Common Lisp and has been tested in Allegro CL 4.1, Lucid CL 4.0.1,
+MCL 2.0 and CMU CL. It allows the user to type arithmetic expressions in
+the traditional way (e.g., 1+2) when writing Lisp programs instead of
+using the normal Lisp syntax (e.g., (+ 1 2)). It is not intended to be a
+full replacement for the normal Lisp syntax.
+
+It is known to be compatible with CMUCL, CLISP, MCL, and SBCL.
+
+Written by Mark Kantrowitz, School of Computer Science,
+Carnegie Mellon University, March 1993.
+
+WWW: http://www.cliki.net/infix
diff --git a/devel/cl-infix/pkg-plist b/devel/cl-infix/pkg-plist
new file mode 100644
index 000000000000..e7dbd04ad2e7
--- /dev/null
+++ b/devel/cl-infix/pkg-plist
@@ -0,0 +1,8 @@
+lib/common-lisp/system-registry/infix.asd
+lib/common-lisp/infix/infix.asd
+lib/common-lisp/infix/infix.cl
+lib/common-lisp/infix/infix.system
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/infix.3lisp
+@dirrm lib/common-lisp/infix
+%%PORTDOCS%%@dirrm %%DOCSDIR%%