aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-port-clisp
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /devel/cl-port-clisp
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
downloadports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.tar.gz
ports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.zip
Notes
Diffstat (limited to 'devel/cl-port-clisp')
-rw-r--r--devel/cl-port-clisp/Makefile27
1 files changed, 8 insertions, 19 deletions
diff --git a/devel/cl-port-clisp/Makefile b/devel/cl-port-clisp/Makefile
index f4b52b373653..9f053437d6c4 100644
--- a/devel/cl-port-clisp/Makefile
+++ b/devel/cl-port-clisp/Makefile
@@ -6,34 +6,23 @@
PORTNAME= port
PORTVERSION= 2002.10.02.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel lisp
MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -clisp
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+DISTFILES= # none
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Cross-Lisp portability package
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/port/port.asd:${PORTSDIR}/devel/cl-port
-do-build:
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
- clisp -q -ansi -norc \
- -i ${LOCALBASE}/etc/asdf-init \
- -x "(asdf:oos 'asdf:compile-op :port)"
-
-do-install:
- @${MKDIR} ${PREFIX}/lib/common-lisp/port/clispfasl
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/port/clispfasl/
+USE_ASDF_FASL= yes
+FASL_TARGET= clisp
+FASL_BUILD= yes
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>