aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-port-sbcl/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:23:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-28 10:23:41 +0000
commitf8fc8e462bd4dc7be969d0038182078f3212e3f7 (patch)
tree791407047c34a0dbba5d14e3f595033f90657fef /devel/cl-port-sbcl/Makefile
parentb29dcce2d290286e7edf7264c16281422127f92b (diff)
downloadports-f8fc8e462bd4dc7be969d0038182078f3212e3f7.tar.gz
ports-f8fc8e462bd4dc7be969d0038182078f3212e3f7.zip
Notes
Diffstat (limited to 'devel/cl-port-sbcl/Makefile')
-rw-r--r--devel/cl-port-sbcl/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/cl-port-sbcl/Makefile b/devel/cl-port-sbcl/Makefile
new file mode 100644
index 000000000000..d4381ab49a42
--- /dev/null
+++ b/devel/cl-port-sbcl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: cl-port-sbcl
+# Date created: 12 May 2003
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+
+PORTNAME= port
+PORTVERSION= 2002.10.02.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ ftp://www.aarg.net/pub/cclan/ \
+ http://thingamy.com/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -sbcl
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+
+MAINTAINER= henrik.motakef@web.de
+COMMENT= Cross-Lisp portability package
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/port/port.asd:${PORTSDIR}/devel/cl-port \
+ ${LOCALBASE}/lib/common-lisp/asdf/sbclfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-sbcl \
+ sbcl:${PORTSDIR}/lang/sbcl
+
+do-build:
+ WRKSRC=${WRKSRC}/ FBSD_ASDF_COMPILE_PORT=t\
+ sbcl --noinform --userinit /dev/null \
+ --eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
+ --eval "(asdf:oos 'asdf:compile-op :port)" \
+ --eval "(quit)"
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/common-lisp/port/sbclfasl
+ ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/port/sbclfasl/
+
+.include <bsd.port.mk>